Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "The service name is invalid ............" - 64-bit Driver problem

09 Mar 2015   #1

Windows 7 32 bit and 64 bit
"The service name is invalid ............" - 64-bit Driver problem

I'm trying to get a driver to work under 64-bit Windows 7 Pro but am not having any luck.

The driver is a modified version which will allow my EPROM programmer and software to access the Parallel port under 64-bit Windows (the default driver for the software only works under 32-bit Windows and works fine if I boot the same PC into 32-bit Windows 7).

The driver is called glpntdrv.sys (the guy who created this 64-bit version of the 32-bit driver says that it works on his 64-bit Win 7 installation).

I've copied this to c:\windows\system32

The above directory is in my default windows PATH (I've even tried copying it to c:\windows\system32\drivers (which is NOT in the PATH!) but that didn't of course work either)

The permissions appear to be okay (although it doesn't have a permission for trustedinstaller (does it need it?).

However, when I start up the software for the EPROM Programmer it errors saying that it's can't access the driver

If I go to the command prompt and type:

net start glpntdrv

I get the error:

"the service name is invalid"

I'ver tried rebooting and going to the menu via F8, to do this:

“Disable Driver Sign Enforcement” (which at the moment needs to be done according to the guy who revised the driver for 64-bit)

but still no luck. For some reason the driver is acting as if it's invisible.

Any ideas please anyone? This is driving me nuts.


My System SpecsSystem Spec
09 Mar 2015   #2

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

As I understand things, simply copying the .sys (and allow-ing unsigned drivers) is not enough to actually install a driver.

Could you point me to where you got this information on steps to modify the driver? I'd like to see what they say to do

/* EDIT */
Big and important Ooops! Just noticed I left out the word NOT in "is not enough to actually install a driver". Corrected
My System SpecsSystem Spec
10 Mar 2015   #3

Windows 7 32 bit and 64 bit

Thanks for the reply.

The modified driver can be found here:

Galep 4 und Windows 7 / 64 Bit ?? - International Device Programmers Forum

(scroll down to the last message for the .zip file link).

The guy who modified it has since got hold of a loan EPROM programmer and verified that it does work (on his system at least).

So now I'm wondering how to properly install it.

Here's his instructions for how to install the new driver (which don't work for me):

The missing 64-bit compilation of glpntdrv.sys driver is the
one-and-only reason why galep32.exe won't run on 64 bit editions of Windows.
This is a running, unsigned beta release of
64-bit glpntdrv.sys, with this installation instructions:

- Install galep32 as usual (with administrative privileges) and start once.

- Copy glpntdrv.sys to C:\windows\system32\drivers,
using the 64-bit version of Windows explorer, with administrative privileges.
(The 32-bit driver file should be at C:\windows\syswow64\drivers,
this file is useless in a 64-bit Windows and can be deleted safely.)

- Windows Vista,7: Reboot system, press F8 on startup, choose
“Disable Driver Sign Enforcement”.
This step must be done on every startup and reboot!

- Windows 8: Control Panel, Enhanced boot options, choose
“Disable Driver Sign Enforcement”, reboot.
This is complicated, see How to Disable Driver Signature Enforcement in Windows 8 - YouTube

- Check for working driver using console window (cmd.exe), enter
“net start glpntdrv”. This should emit no error message,
or possibly „Service already started“.

- Start galep32.exe, it works now.
My System SpecsSystem Spec

11 Mar 2015   #4

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

1) Do you see your device listed in Device Manager? If yes, what category does it fall under?
> If there, right click the device->Properties->Details tab. Use pull down menu to select Hardware IDs. Copy/paste the result into your next post

2. Download/run 64 bit version of DevManView. Click Ctl-A to select all items, Ctl-S to save, before saving the file be sure to change the file Save As pull down menu to Tab Delimited Text (.txt). Save the file upload to your next post

Attached Thumbnails
"The service name is invalid ............" - 64-bit Driver problem-save-.jpg  
My System SpecsSystem Spec
12 Mar 2015   #5

Windows 7 32 bit and 64 bit

Thanks, all sorted now - after a LOT of work I've managed to personally "test sign" the driver which works fine if Win 7 is set to run in test mode. :)
My System SpecsSystem Spec

 "The service name is invalid ............" - 64-bit Driver problem

Thread Tools

Similar help and support threads
Thread Forum
Problem with MsConfig Service called "Power" and also my audio
I was having huge lagging and crashing problems until I found out it was the Microsoft Service called "Power" in MsConfig that was the culprit. When I disable it, it fixes my problems, but now I don't have audio anymore. Can anybody help?
Performance & Maintenance
Keep Receiving "Windows could not start driver config service" on boot
For about a year I have been receiving on boot-up the message "Windows could not start driver configuration service". I may(and stress may) have inadvertently erased that service by accident. I cleaned up a lot of file about a year ago and I think I started getting this message right after that. ...
Installation & Setup
Why do I repeatedly have this "Invalid URL" problem?
For some reason, and this happens quite often, when I search in the address bar in Chrome or IE, no matter what I put in, I get the "Invalid URL" page. Other times, I will get the "Untrusted Connection" page or the red "Warning!" page that tells me that I don't want to be going to this site. ...
Browsers & Mail
"The specified service does not exist as an installed service" problem
Hi. I am having really bad problem on my WIN 7 x32. I would appreciate some help. Here's brief description of the problem: The problem started when my mcafee anti virus removed ZEROACCESS trojans from my system. After the scan was completed, my system rebooted and I lost control of all...
General Discussion
Random "Bad Pool Header" and "System Service Exception" BSODs
I have been getting these "Bad Pool Header" and "System Service Exception" BSODs for about a day now (the "Bad Pool Header" one tends to pop up more often then the other btw). I ran a registry cleaner which didn't work and ran memtest this morning and it showed that my memory was fine. The BSODs...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:37.
Twitter Facebook Google+