Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Computer will not recognize Sansa MP3 player

29 Nov 2009   #1

Windows 7 Home Premium
Computer will not recognize Sansa MP3 player

My new Windows 7 computer will not recognize my Sansa e280 player. The player is recognized on my old Vista machine and on my Dell XP laptop, so I know the settings on the player are correct.

Windows Media Player 12 is also installed and functions correctly. It will play MP3's, DVD's, etc.

If I go to Control Panel > System > Device Manager and look in the "Portable Players" section, I see a yellow triangle next to "MTP USB Device".

When I right click on that item I get 4 choices:
1. Update driver software
2. Disable
3. Uninstall
4. Scan for hardware changes

I chose "Update..." Then I got a choice to have Windows search for the driver or select a specified place for it to look. When I clicked on the automatic choice it searched and came back with "Driver up to date "MTP USB" Device." I then went back and did the second choice designating "C:\Windows\System32\drivers" and got exactly the same result:
"Driver up to date "MTP USB" Device."

Also, every time I plug the Sansa into the USB port, Windows 7 gives a message in the tray (bottom left) indicating it is installing the drivers, but in the end it throws up and gives me a message saying that the drivers were not successfully installed.

And, Sansa is not recognized as a drive with a drive letter in Windows Explorer.

I am at a loss here. How can I get Rhapsody to recognize my Sansa on this new Windows 7 machine?

My System SpecsSystem Spec
29 Nov 2009   #2

XP Pro/Vista Ultimate (64)/Windows 7 Ultimate Signature Edition(64)

1) Disconnect your e280 from the computer.
2) Turn it on.
3) Navigate to the Settings menu.
4) At the very bottom of the Settings menu, select USBMode.
Notice that it is most likely set to MTP.
5) Set the USBMode to MSC.
6) Plug it back into your computer.

Give it another shot

You might also want to go to the Sandisk firmware update site
My System SpecsSystem Spec
29 Nov 2009   #3

Windows 7 Home Premium

Thanks Orpheous. I know it can function in MSC mode, but I need it to work in MTP because Rhapsody requires that mode to allow me to download anything I want from them to my player at no cost. The necessary DRM only works in MTP. As I said, the player works fine in MTP on my old Vista box or my XP laptop. I guess I could just use the laptop to download tracks (which is what I have been doing) but it sure would be nice to be able to download tracks on this new Win 7 machine.
My System SpecsSystem Spec

29 Nov 2009   #4

XP Pro/Vista Ultimate (64)/Windows 7 Ultimate Signature Edition(64)

If the e280 has an auto detect mode, can you try it in that instead of MSC?
before you plug it back in, uninstall the device in device manager, reboot, then connect the e280 just to be sure.
I can't find any documentation on what has been fixed in the latest firmware update, but it might also be an idea to install it, perhaps on your Vista box, in case it has a W7 related update.
My System SpecsSystem Spec
02 Dec 2009   #5

Windows 7 Home Premium


I checked with Sansa support and here is the relevant portion of what they had to say:

If the issue persists, then the MTP drivers might be corrupted and need to be refreshed, please try these steps.

STEP 1 - Connect the Sansa player to the PC
Plug the device in the back USB port of the computer as this supplies more power. We would need to check the presence of the device on "Device Manager".
NOTE: It is recommended that the USB ports in the back of the computer be used to ensure that there is enough power from the USB port for the player to be detected properly.

STEP 2 - Check under Device Manager
1. Right-click My Computer, and select Manage.
2. Click Device Manager on the left pane.

NOTE: The Sansa player will show up on Device Manager's right pane as:
1. USB Mass Storage device (if the player is set to MSC)
2. Portable Device (if the player is set to MTP mode.)
If there is a yellow exclamation point (!) or question mark (?) beside the device, try to refresh the drivers.
Note: - The "!" might indicate that your device is not receiving enough power or a driver issue.
- The "?" might signify that your device has been assigned the wrong drivers or has been encountering some driver conflict.

STEP 3 - Refresh the drivers
1. Right-click the entry with the error mark, select Uninstall.
2. On the top menu, click Action then select Scan for hardware changes.
I followed the instructions and the same thing happens: I uninstall the MTP driver, then click on "scan for hardware changes" at which point Windows 7 gives a message in the tray (bottom right) indicating it is installing the drivers, but in the end it throws up and gives me a message saying that the drivers were not successfully installed.

I found a cool free program called DriverMax, which scans all the drivers on your computer and gives you a report, and will scan to see if there are updated drivers, and much more. It shows the USB Mass Storage Device driver as being up to date and properly installed! In the "details" section it shows that the driver consists of 3 files: usbstor.inf (31,352 bytes), usbstor.PNF (57,712 bytes), and USBSTOR.SYS (89,600 bytes). These files are indeed resident on my computer. Hmmmm. What is going on here?

I know this device is installed as part of Windows Media Player 12, which is part of the Windows 7 software and that there appears to be no way at present to reinstall WMP 12 without having to do a full reinstall of the operating system, which I am not interested in doing.

Oh well, I guess I'll just have to use my laptop (XP and working fine with the Sansa) to download tracks from Rhapsody. It sure would be nice to do it from the Win 7 box, but it is looking like that is not in the cards. Dang!
My System SpecsSystem Spec
05 Mar 2010   #6

Windows 7 Professional

My Sansa E280 is recognized by Windows 7 Professional 64 bit. But oddly the audio folders do now show up. Only the recording and video folders appear.
My System SpecsSystem Spec
25 Jul 2011   #7


It might be the USB 3.0 they dont like. I was having the same problems. Plugged it into the legacy 2.x usb and it came right up.
My System SpecsSystem Spec

 Computer will not recognize Sansa MP3 player

Thread Tools

Similar help and support threads
Thread Forum
Media Player 12 won't recognize flash drive
I bought a new flash drive (Sandisk Cruzer Glide 16gb) and Media player doesn't pick it up. It shows up in windows explorer and I can copy to and from it but media player won't show it so that I can sync music to it.
Music, Pictures & Video
Force recognize mp3 player as external hard drive instead of player
I wonder if there is a method to force windows7 to recognise my mp3 player as hard drive instead of player. Why? 2 things. I find it annoying that I have to click on player then internal storage, when it could go directly to internal storage right away. 2. When I first plugged my player in...
Hardware & Devices
WMP10 Sync to Sansa Nets Split Albums-3 Merge as unknown
Win 7 Hm Prem w/ WMP10 New Computer --- WMP 10 found My Music folder by itself and presented all of the Albums in the Music Section. In Syncing the Albums (tried Sync as Playlists hoping to keep all album songs together) to a Sansa e260 ('07 built) Player I notice the Sync Sort by Artist makes...
Music, Pictures & Video
Computer does not recognize DVD in player
When I play a commercial DVD, a movie for instance, the E drive shows no disk inserted. However, a CD plays with no problem. This was not always the case, but has been since I installed Windows 7 Home Premium I apologize now for anything lacking in description. I am a computer user is the...
Hardware & Devices
Sansa Clip+ - Not showing full capacity
Hello... I've just brought Sansa Clip+ 2GB MP3 Player... I've plugged the usb cable into my computer and I've noticed It isn't showing me the full size... I've got only 1.60GB Free from 1.80, I did a format from the mp3 itself and from the computer... Picture:...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App