Run as Administrator from User account not working.


  1. Posts : 3
    Windows 7 Ultimate
       #1

    Run as Administrator from User account not working.


    First, I'm sorry if this has already been answered. I've searched the forums, but haven't been able to find an answer to my situation.

    When I right click on a program from my user account (no admin privileges) and choose to "run as Administrator", I am not prompted for the Administrator password. The program then prompts: "XXX needs local Administrator privileges." This has been happening on all programs I have downloaded recently, not just one in particular.

    I do have a valid Administrator account. In the past (on the same computer, same OS) I have been able to right click, select Run as Administrator, then enter a password, and continue unhindered.

    I am not sure what has changed, but I now have to log in to the actual Administrator account to install programs when I used to be able to do it from my user account by running as administrator.

    Any help getting "Run as Administrator" to work on my lower privileged user account again is greatly appreciated.
      My Computer


  2. Posts : 1,367
    Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
       #2

    Have you tried a sys restore to a time when all was well?
      My Computer


  3. Posts : 71,270
    64-bit Windows 10 Pro
       #3

    Hello cryptzog, and welcome to Seven Forums.

    Double check to make sure that you do not have UAC disabled by at having it set to at least the default settings. Afterwards, see how it works for you.

    User Account Control - UAC - Change Notification Settings

    Hope this helps, :)
    Shawn
      My Computer


  4. Posts : 3
    Windows 7 Ultimate
    Thread Starter
       #4

    I would prefer not to restore system settings because I don't really know when it started, and I have installed quite a few things recently. Also, I have changed the UAC settings, but nothing really seems to change in regards to my issue.
      My Computer


  5. Posts : 4,566
    Windows 10 Pro
       #5

    You stated you run as admin with uac turned on. You would not be prompted for password under admin, only standard user.

    Admin you would get yes or no,

    Standard you get prompted for admin password then yes or no.

    If you keep having problems, turn uac off and restart. Then turn it back on and restart.

    I also suggest possibly renaming the account profile under the admin account. Then recreate a standard user account. See if the issue continues. It's possible that the standard user account might have gotten corrupted.

    You could also try SFC /SCANNOW Command - System File Checker
      My Computer


  6. Posts : 3
    Windows 7 Ultimate
    Thread Starter
       #6

    I don't know exactly what I did, but I think it involved a power off and power on. It is working now. Thank you all for the replies.
      My Computer


  7. Posts : 4,566
    Windows 10 Pro
       #7

    Glad you got it resolved :) Thanks for also marking the thread solved as well. Have a great day! :)
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:08.
Find Us