Fix - Catalyst Control Center - CCC - will not open/install

Page 1 of 5 123 ... LastLast

  1. Posts : 6,669
    Windows 7 x64
       #1

    Fix - Catalyst Control Center - CCC - will not open/install


    Description of problem: Ati Catalyst Control Center will not open or install in windows 7.

    Resolution follows:


    Preparation:
    Note - As with anything that makes changes to your system it is suggested you create a restore point before proceeding. System Restore Point - Create


    Before beginning:
    First thing we are going to do is download the latest amd/ati driver and catalyst package and save it to your desktop for easy access later. http://support.amd.com/us/gpudownload/Pages/index.aspx the link provided there will direct you to the proper download for your hardware.

    Once this is done
    Remove your ATI software normally through programs and features in the Control Panel using the Catalyst Install Manager (CIM). (Also called AMD Catalyst Install Manager)




    Reboot the system in Safe Mode (F8) and do the following:

    1 - Delete all ATI folders in C:\programs files and C:\programs files (x86) as well as the temp ati folder usually located at c:\ati

    2 - Go to C:\Windows\assembly and sort by "Public Key Token". Locate the following Public Key Token "90ba9c70f846762e" Usually there are only two entries. However, there can be many just be careful here we are only deleting/uninstalling entries tagged with the "90ba9c70f846762e" token. (if deletion will not work right click and uninstall)

    3 - deleting these policies in safe mode may result in a permissions error. The entries will only show up in systems affected by this issue.
    This means that searching for these entries on systems where CCC is loading properly, should result in none found *(as per ati's dev team)

    4 - Shut down and re-start normally.

    5 - Reinstall the ATI Catalyst package.

    6 (optional) -Launch CCC from the right click context menu if it doesn't start automatically.

    ______________________________________________________________
    Footnote: there should only be two policies, but 20 to 40 have been reported. Apparently the problem multiplies when you attempt multiple installations to get catalyst to appear.
    Last edited by Maguscreed; 03 Nov 2011 at 05:38.
      My Computer


  2. Posts : 7,681
    Windows 10 Pro
       #2

    Funny you should post this now. I was trying to help someone earlier who had issues with CCC. Post here.... CCC doesnt work anymore

    Anyway we couldn't get solved here so I referred him to rage3d. I'll link to this post in his thread. Maybe your info can help him should he return.

    BTW I just looked for that token in the location specified and noticed I don't have it. On the other hand I have/had no issues with CCC. Not sure what to make of it though. Maybe it's put there when there's an issue??? Just FYI.

    Thanks
      My Computer


  3. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #3

    Apparently the policies have a lot to do with the problem, and they start multiplying. It has something to do with a .net framework fault apparently. Once it occurs removing the policies is the only way to 'reset' the installation process.
    I'm not going to pretend I understood everything in the dev log the ati guys shared, but driver sweeper doesn't go after those policies (it can't remove them has to be done manually, since it's a specific policy key perhaps it can be included in a future driver sweeper version)
    I'm going to pretty this up so we can tutorial it.
    Last edited by Maguscreed; 03 Nov 2011 at 00:02.
      My Computer


  4. Posts : 7,681
    Windows 10 Pro
       #4

    Well good job in coming up with what you did. Hopefully this will turn out to be a major fix with CCC.

    BTW have you seen this thread over at rage - [SOLVED] catalyst control center wont start??????????? - Page 2 - Rage3D Discussion Area. Might help with the tutorial or give you some background info.

    Good luck
      My Computer


  5. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #5

    notice the notes, the keys should NOT appear if catalyst is working properly. I'm still working on the post. It'll likely be sometime tomorrow when it's ready for open consumption. Needs some screens and other things to straighten it out. Only problem is now that I've fixed it on my system the policy is gone so I can't screen that.
    Rage is actually one of the multiple sources I used for this, all those crazy steps and things people are suggesting and finally work, are just them trying to use various methods to clean the policy.
      My Computer


  6. Posts : 7,681
    Windows 10 Pro
       #6

    Well good luck. And nice to see you looked at other sources.

    I'm out.

    Later
      My Computer


  7. Posts : 7
    Windows 7 Pro (64bit)
       #7

    This procedure fixed my problem. I've got two HD5870's running in CrossFire and couldn't get CCC to open. I found 117 of the policies/keys on my machine. After uninstalling all of them I have no further problem opening CCC. Thank you.
      My Computer


  8. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #8

    Yes, I've run into the problem on 2 more occasions since writing this fix, I found 39 and another with over 200, so the number of them does apparently vary significantly. Just so long as you are careful to only delete policies identified by the key token 90ba9c70f846762e everything should be good though.
      My Computer


  9. Posts : 1
    Windows 7 Home Premium 64bit.
       #9

    Solved Fix - Catalyst Control Center - CCC - will not open/install Rep


    Thank you for the clear and easy to follow instructions. I had updated to CCC 12.2 with Win 7 64bit and and CCC would not open. I followed the instructions above and was able reinstall CCC and then eliminate the 1/2 inch black border on my new Samsung monitor I originally set out to do.
      My Computer


  10. Posts : 1
    Windows 7 Ultimate 32bit
       #10

    CCC Problems


    Hi there guys i am new here,

    I am having the same problem as described and i think the solution / fix will work however the problem i have is CCC wont uninstall from add/remove programs , therefore i am currently unable to follow the solution through to resolution.

    When trying to remove / uninstall it starts the process and appears to go through it but then stops and i am back to same screen with CCC still showing as installed , i dont actually get the option to uninstall as normally listed , to me this implies the original install failed , before i downloaded CCC i went onto the AMD forum and found some other people had the same issue they download then run the install during which it crashed and reboots with blue screen of death , this matches what happened to me , i still have full use of my pc but CCC cant be or wont be unistalled via add/remove ( uninstall a program )

    Any advice would be very welcome
      My Computer


 
Page 1 of 5 123 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:43.
Find Us