Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB devices Not recognized selectively

15 Apr 2011   #1
phil136

Windows 7 Ultimate 32bit
 
 
USB devices Not recognized selectively

I have become very frustrated with this problem.

Out of the blue my win 7 Ultimate SP1 will not recognize CERTAIN USB devices plugged in the rear ports (I have 2 in the front, 4 in the rear). I get the "device not recognized " pop up.

The strange thing is, all the the devices that I plug into the front 2 USB ports are recognized and work. I know the rear ports are functioning because when i plug in my scanner, or my flash drive, they work. However when i plug in my HP printer or my logitech mouse (which both work in the front ports), it says they are unrecognized.

I have scoured the forums and have tried numerous things; unplugging power, uninstalling drivers, taking out MB battery, resetting CMOS, etc. All with no luck.

I really cant imagine how my mouse can work in the front usb port but will not work in the rear one, in which my flash drive & USB-powered scanner work.


PLZ HELPPPP


My System SpecsSystem Spec
.
15 Apr 2011   #2
pooch

Windows 7 Ultimate x64
 
 

Hello Phil, welcome to the forum


Do you get any error codes?

Try doing the following;

General USB problems
Click on start orb, Type Advanced System settings in the search box and click to go there.
Click on Advanced tab, Click on Enviroment Variables.
Under the window System variables click on New.
Type " devmgr_show_nonpresent_devices" (without the ") as the variable name and type 1 as the value.
Click ok 3 times to close the windows
Click on start orb, Type Device Manager in the search box and click to go there.
Click on View, Click on Show hidden devices.
Now you can uninstall all old and unknown USB devices.
Open windows Explorer go to computer in the menu bar, Search for infcache.1 and delete it
If it still does not work remove all USB devices and then uninstall the USB controller(s) followed by a new start
My System SpecsSystem Spec
15 Apr 2011   #3
SmurofNeves

Seven ultimate 32bit
 
 

Have you tried updating your drivers? (Welcome,welcome)
My System SpecsSystem Spec
.

15 Apr 2011   #4
SmurofNeves

Seven ultimate 32bit
 
 

Some manufacture drivers like specific 3G only install for using a certain usb...Its rare but i've seen it,have you tried installing the driver again while the device is plugged in to the unrecognized port.. Maybe even uninstalling first then reinstalling after plugin.
My System SpecsSystem Spec
15 Apr 2011   #5
spinifex

 
 

Hello Phil.

Have you done a BIOS check to see what all the settings are.
It is quite interesting to see changes happen for no apparent reason.

Start your computer and click the F10 key repeatedly till the BIOS screen comes up.
If this does not work, try the F1 key instead.
Find the "Security Menu"
Then go to USB Security and check the USB settings.
If all goes well, don't forget to save your settings.

Hope this works for you.

Jon
My System SpecsSystem Spec
15 Apr 2011   #6
SmurofNeves

Seven ultimate 32bit
 
 

BIOS can be accessed by pressing DELETE on start up continuesly aswell...
My System SpecsSystem Spec
15 Apr 2011   #7
phil136

Windows 7 Ultimate 32bit
 
 

Hello All. Thank you for your responses.

Pooch: I have followed your steps, with no luck. Tried plugging in my mouse and printer; both get error 43 windows stopped the device/device reported problems. I plug those devices into the front and the work perfectly( i tried all 4 ports in rear).

spinifex/SmurofNeves: I have gone to the BIOS multiple times but the settings there are very basic. There is nothing for USB (except legacy enabled/disabled). All these devices had worked on this system previously. The only thing I can think off is windows update messed something up> I will try uninstalling the latest updates and see if that will help. Also, I would think the drivers are present if the same devices work when plugged into the front USB ports. I wouldnt be as frustrated if the usb ports flat out didnt work.



Here is a rundown of the devices I have tried on rear ports (all work on front ports):

Canolide 600F scanner - works (usb powered)
Ipod touch - works
Cruzer flsh drive - works
Logitech G500 mouse - does not work
HP photosmart 8050 - does not work

When Plugged in the mouse and the printer come up as unknown devices under the USB controlllers in the device manager. Both have Error 43
My System SpecsSystem Spec
15 Apr 2011   #8
pooch

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by phil136 View Post

Logitech G500 mouse - does not work
HP photosmart 8050 - does not work

When Plugged in the mouse and the printer come up as unknown devices under the USB controlllers in the device manager. Both have Error 43
Error code 43 One of the drivers controlling the device notified the operating system that the device failed in some manner.

This usually occurs because of old drivers, try updating Motherboard and Device drivers.
It is also best to uninstall everything USB from the offending ports

You could also try this out; Hardware devices are not working or are not detected in Windows
My System SpecsSystem Spec
15 Apr 2011   #9
phil136

Windows 7 Ultimate 32bit
 
 

Thanks pooch.

After your first reply i had uninstalled nearly everything; old drivers that were not being used by devices, and the the new ones. This included the USB controllers /hubs, and input devices (the mouse). I restarted the computer, the drivers reinstalled on their own. I plugged the mouse into the rear usb ports, and same message. Unplugged mouse plugged into the front and bam, it installed, and it works.

Also just tried to plug in a different Optical MS usb mouse, same problem (works when plugged in front though)

This is ridiculous .



At first i thought maybe it the ports were running under USB 1.1. But since my USB powered scanner works on them, and my flash drive transfers quiet fast (60 + Mbs/sec). That couldn't be.

Also thought it might be the power supply issue, but then gain, the other devices work.



Also reading about USB filter drivers now... Prob will have to format and install fresh copy of win 7 though
My System SpecsSystem Spec
15 Apr 2011   #10
pooch

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by phil136 View Post
Prob will have to format and install fresh copy of win 7 though
you could try a repair install Repair Install
This will at least leave all your bits and bobs intact
My System SpecsSystem Spec
Reply

 USB devices Not recognized selectively




Thread Tools




Similar help and support threads
Thread Forum
Unable to boot into any mode...storage devices not recognized
Woke up this morning to find my HP stuck in a boot up mode with a message about it being unable to find any storage devices...tried safe mode (F8) but no luck...would not boot into safe mode...can not get into BIOS...F2, F10, F11 all not working...only thing that had a glimmer of hope was inserting...
Hardware & Devices
All USB ports don't recognized usb drives but do see other devices
I can't remember exactly how this happened because it's been a cascading disaster. It started with my efforts to uninstall Crashplan. In the course of this I unplugged one usb drive (I have 6) from a hub while it was on. At the time everything seemed ok, but it was not the case once I shut down...
Hardware & Devices
Bluetooth dongle is installing, properly recognized, can't see devices
Purchased a brand new Asus USB-BT211 bluetooth dongle with the express goal of connecting a wiimote to my new computer. the machine runs Windows 7 x64, the drivers for the dongle install without a problem, and the bluetooth searching mode on the "add a device" screen appears to be running without a...
Hardware & Devices
Possible to selectively hide folders?
How can I make a folder completely INVISIBLE to a standard user account BUT visible to the administrators account? Before you respond, let me state that I can successfully prevent the standard user account from opening the folder. So they are unable to look inside. I can do this already. ...
General Discussion
usb pci card... devices plugged into it not recognized
I just installed a new PCI USB 2.0 card into my machine. I have a Line 6 Toneport UX8 that connects to the PC by USB as the interface for microphones and instruments. Because of the high volume of data coming down the pipe from this external interface it is pretty much a 'mandatory recommendation'...
Drivers
A few devices not recognized
I installed W7 RC with no issues, but it then fails to identify many of the devices on my machine. It doesn't find the Belkin PCI G Wifi adapter despite the fact I separately installed the latest driver, it just doesn't see the card at all. It doesn't find the sound card either. When I try to...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App