External HDD suddenly requires formatting, read as RAW instead of ntfs

Page 6 of 7 FirstFirst ... 4567 LastLast

  1. Posts : 6,458
    x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
       #51

    Thanks - figured you already looked at those. Wish I could help more, but you know I won't have Internet much longer - really expected to lose it yeaterday, but got a short extension.

    If I think of anything before I can't connect anymore, I'll post it.

    Good luck my friend,

    Bill
    jumanji said:
    If I am to answer your post its going to be a long one so I won't go the long way.:)

    In short Diskpart - no no ( Anyway I had a look at it.)

    I am not breaking anything. Ya, I am wearing out my HDD but you know it can fail anytime even when sparsely used. So what are we counting?:)
      My Computer


  2. Posts : 21,007
    Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
       #52

    jumanji said:
    @ICit2, It is not my intention to wipe the GPT Data partition at all. I do not want to overwrite it with zeros for I have precious data on it :) which I want to recover. ( To recoup, I want to create a RAW drive as it happened in the case of the OP and try to recover the data from that GPT drive that had turned RAW)

    Now regarding the 128MB reserved partition, I found out that it is not part of the GPT at all but is an MS requirement to have it on the GPT drive to store any data.For example when one converts from a basic drive to Dynamic drive some data generated needs to be stored for later reversal of the process from dynamic to basic.GPT does not allow any data to be stored in hidden sectors.So Microsoft has created a reserved space of that 128MB. It is actually called MSR, (Microsoft Reserved). When one creates a GPT drive with Windows Disk Management it effectively hides this 128MB partition and a user does not have access to it. To begin with there is no data in it and that is why even after wiping it with PW the GPT drive continued to work as if nothing has happened. I wiped it hoping that it would turn my drive to RAW.

    Now I am back to the problem. How to make my GPT drive containing valuable data RAW (as in OP's case) and then retrieve/recover the data?
    Sorry got the wrong end of the stick the only other ting I can suggest is
    Make a bootable Ubuntu disk http://www.ubuntu.com/download
    Set the BIOS to boot from the optical when the machine boots it will show you a screen with TRY or INSTALL > select TRY
    When it is finished - it takes very little time you will get a screen like in the pic .
    Open the drive you want > User and dig down until you get to the data settings you will be able to copy / paste the material you want doing this to an external for safe keeping .
    I am not sure if it will but I have recovered tons of data etc using this method both on "dead" or just plain drives that you cannot get data from using Windows.
      My Computer


  3. Posts : 7,063
    Windows 7 Home Premium 32 bit
       #53

    Thanks to inputs from Slartybart and TVeblen ( not mentioning my own google search), I managed to turn my 750GB Seagate GoFlex external HDD RAW.

    I used BOOTICE v1.1.5 to do it.

    I zeroed the NTFS partition boot record at LBA 264192.

    External HDD suddenly requires formatting, read as RAW instead of ntfs-pbr.jpg

    External HDD suddenly requires formatting, read as RAW instead of ntfs-fill0.jpg

    And then I got the following message to format my drive, a sure sign of it having turned RAW.

    External HDD suddenly requires formatting, read as RAW instead of ntfs-formatdisk.jpg

    And indeed it is RAW.

    External HDD suddenly requires formatting, read as RAW instead of ntfs-raw.jpg

    Now what happens when I zero LBA 0 that contains the Protective MBR? It turned my drive "Not initialised, Unallocated" asking me whether I want to initialise using MBR/GPT.

    When I zeroed LBA 1 that is the GPT Header, believe me, nothing catastrophic happened. My drive functional as before. Reason - it took it from the backup in the last sector LBA 1465149166. When I destroyed the backup, the drive turned Not initialised Unallocated.:)

    Same thing happened when I zeroed LBA 2, the GPT Table. My drive continued to function normally with the backup in LBA 1465149134

    Partition 1 is the MSR.It contains no data. everything is already zero. So no problem.

    ( OK, I had backed up all these sectors with BOOTICE so that I can restore them at will for this evaluation.)

    Now I can get on to recovering the data from the RAW drive. But that after a break.

    Insofar as the OP's problem involving a 4 TB drive, he needs to give a little bit of history. PW found that apart from the 128MB MSR partition there were at least three or four 30MB partitions designated as boot. That would indicate that some sort of partitioning had taken place before. This dawned on me as I was going through this exercise. I am only hoping he comes online.
    Last edited by jumanji; 28 Oct 2013 at 00:28. Reason: typos corrected
      My Computer


  4. Posts : 7,063
    Windows 7 Home Premium 32 bit
       #54

    As a natural corollary of the above exercise I would suggest the following to the OP.

    1. Check the last sectors of your Disk from n to n-32 with Bootice. If you find that the GPT backup exists in those sectors, I would say you have struck gold.:)

    2. Save each sector starting from n to n-32.

    3. Restore the nth sector to LBA 1 (sector 1), n-1 to LBA 2 and so on till you complete n-32 to LBA 33.

    Effectively you would have restored the GPT, and Windows 7 should be able to see your drive as before.

    Worth trying since in all these steps, we are definitely not writing any thing to the data sectors.

    I have also confirmed that PhotoRec will be able to recover the data after running an excruciatingly slow scan on your present RAW drive, but as you had indicated that you have mostly proprietary format files, that is not going to help you. It may not find those files.( I have recovered some mp3 files and such standard format files.)

    In that situation, Test Disk will be a better option. Even here I would think that it will do a better and fast job after restoring the GPT sectors.

    So, if restoring the GPT sectors alone does not bring the HDD to life, run Test Disk.

    Without doubt, we are still in the learning process of recovering data from a GPT drive, but for any body using GPT drives my advice would be to back up each and every sector from LBA 0-LBA 33 and also any Partition boot record sectors indicated by BOOTICE. (each sector file may only be 512 bytes and so it is not going to take much space). If your HDD becomes inaccessible due to Partition Table corruption, you will have an instant recovery by restoring that sectors. Atleast I would think so.:)
    Last edited by jumanji; 28 Oct 2013 at 09:07.
      My Computer


  5. Posts : 33
    Windows 7 ultimate 64 bits
    Thread Starter
       #55

    Hey guys,

    Sorry I haven't been present much these last few days. Got the flu which knocked me down and now trying to catch up on my work. I'll be back to practice all you wrote tomorrow. I have said it several times but I really appreciate the help.

    flows69
      My Computer


  6. Posts : 33
    Windows 7 ultimate 64 bits
    Thread Starter
       #56

    Hey,

    I kind of let you down for some time now ... sorry about that. If you don't really remember what my problem was about and don't want to reread so many posts I understand.

    I downloaded Bootice and checked the sectors from n to n-32 as asked above.

    Everything is blank beside n-32, n-3, n-2 and n. I upload the pictures of n-32 and n, if you need the other two just let me know, there is not a single word on them.

    Does it appear the GPT backup exists ?

    I am done publishing my article, don't hesitate to contact me if you need any additional info about the HDD.

    Thanks again for the help,

    flows69
    Attached Thumbnails Attached Thumbnails External HDD suddenly requires formatting, read as RAW instead of ntfs-n-32.png   External HDD suddenly requires formatting, read as RAW instead of ntfs-n.png  
      My Computer


  7. Posts : 7,063
    Windows 7 Home Premium 32 bit
       #57

    My post #54 still holds good. Follow it as suggested.

    You need not copy and restore sectors that are all zero. But keep the arithmetic right - which should go where and remember n is the last sector of your drive. Have a look at my post here that should help you do that. Lost partitions!

    As I said in my post #54, we are not at all meddling with any data sectors.

    If the GPT restore does not help, then try Test Disk.
      My Computer


  8. Posts : 33
    Windows 7 ultimate 64 bits
    Thread Starter
       #58

    Hey,

    I used Bootice to back up sectors n to n-32. When I used these back ups to restore sectors 1 to 33, I found that sector n-1 was blank but sector 2 wasn't. I tried both leaving sector 2 as it was and replacing it by a back up of a blank sector. If it turns out I shouldn't have made sector 2 blank I backed it up to be sure.

    Anyway, in both cases, the disk now appears unallocated.

    At this point I am not sure if it is an improvement but at least it is a change ;-)
    Attached Thumbnails Attached Thumbnails External HDD suddenly requires formatting, read as RAW instead of ntfs-after-bootice.png  
      My Computer


  9. Posts : 7,063
    Windows 7 Home Premium 32 bit
       #59

    Sector 2 is the GPT table. I do not know why in your case there was no backup of it in n-1.

    In the circumstances, I would advise you as follows.( I would think we are better off than before with the drive showing as unallocated. I had said it even in my post #54)

    1. Try Partition Recovery Wizard with sector 2 as it was. Both Quick Scan and if it fails to show the files then Full Scan.

    2. Try Partition Recovery Wizard with sector 2 all zeros.

    If both fail to find the correct partition info then Test Disk, again with sector 2 as it was and with all zeros.

    I know its gonna be a time consuming affair but I think there is no other go unless you turn it on to a professional recovery.

    But let me assure you one thing whether you try PW or Test Disk and ask those to write the correct partition table, right or wrong it was done, your data is still safe and will leave it so for professional Recovery or recovery attempt by any other data recovery software.

    One thing now I am certain that in view of the fact we still do not know much about GPT, if one uses GPT disk, immediately after partitioning he should backup all the relevant sectors as detailed in my post here . That will make it easy to restore in case of corruptions to these important sectors.
      My Computer


  10. Posts : 3
    Windows 8.1 Professional x64
       #60

    Thanks, this helped me out!!!


    Three quarters of a year later, but I ran into this problem with my external harddrive. Yesterday it was working fine, today it says "Local Disk", inaccessible, and Disk Management tells me the drive is RAW instead of NTFS. Ran "MiniTool Partition Wizard Home Edition" and sucessfully recovered the partition, with all files and folders showing up and usable as should be.

    So... THANK YOU !!!
      My Computer


 
Page 6 of 7 FirstFirst ... 4567 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:13.
Find Us