Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RC6 MCE Remote Not Working Correctly

20 Jun 2011   #1

Windows 7 Home Premium x64
RC6 MCE Remote Not Working Correctly

Hi guys,

I have recently reinstalled win 7 on my HTPC and got it set up very nicely. I bought a new remote for it and it worked great for a few weeks.

Recently a few of the buttons have stopped working. Mainly the back button and the volume up/down buttons.

The batteries are fresh and the LED on the remote tells me the button is working. The eHome transceiver is also lighting up so the signals are being emitted.

I tried the trial of Intelliremote which fixed the problem but it costs more than the remote!

I figure it is a driver issue but the stock drivers are very sparse with no function to configure at all.

I can only find some references to the beta versions of win 7. These issues where meant to be fixed in the RC so by SP1 you'd think it should work.

Anyone know a fix for this issue?

My System SpecsSystem Spec
21 Jun 2011   #2

Windows 7 Ultimate 32bit

I am gonna shoot in the dark since I am not sure whether this is a hardware (Remote/transceiver) failure.

Try this. It does not hurt.
  1. Get into Device Manager, and then click the infrared receiver. The device is typically listed as Microsoft eHome Infrared Transceiver, but the name may vary depending on your configuration.
  2. On the Action menu, click Uninstall, and then click OK to uninstall the infrared receiver.
  3. On the Action menu, click Scan for hardware changes to reinstall the infrared receiver.
if possible, give me the link to the device if you purchased it online. Lemme check whether I get any more grand ideas.
My System SpecsSystem Spec
21 Jun 2011   #3

Windows 7 Home Premium x64

Thanks for the reply.
I have already tried that about a dozen times. I have also tried uninstalling all the eHome and anything remotely related (around half a dozen drivers) then removing the usb cable and rebooting and letting the drivers reinstall again. Still no joy!

I'm thinking its software (driver) related due to the fact it worked (almost) perfectly after installing the trial of intelliremote. The only issue with this app is that it seems to increase the refresh rate of the remote buttons so it is hard to navigate. I just wish this software wasn't $25.

I bought it off ebay HERE

According to THIS XBMC wiki (note I'm not using xbmc at the moment) it looks most like the Dell version of the Microsoft MCE remote and installs as a Microsoft eHome device.

Thanks again for your help.
My System SpecsSystem Spec

21 Jun 2011   #4

Windows 7 Ultimate 32bit

OK, here is my final shot and thought on the issue.

I am afraid you have bought a chinese, no-name, sub-standard IR remote/ receiver. Sub-standard in that the defiicient signals from the remote or the deficiency in the IR receiver require a helper in Intelliremote to make up for it.

(Even DELL/HP/Pinnacle remotes/receivers are made in China but to strict quality and specifics imposed by the principals. The clones have no such compulsions.

Microsoft itself stopped manufacturing these long back giving rise to proliferation of such clones. It is a veritable jungle and frustrating to consumers to pick up the right one. Your receiver looks like a HP clone.)

Instead of buying the $24 or so Intelliremote software, you have two options.

1. Buy another good and known-to-work remote/receiver. Here I may refer you to this section of the Australian Media Center Community Forum Other Hardware - Windows 7 - Australian Media Center Community where I have seen a lot of queries and answers on what remote and receiver to buy and wherefrom.

2. Your second option will be to jettison Microsoft, IR altogether and go for other brand IR/RF remote/receiver. The choices are many. I believe that you are quite knowledgeable and no spoon-feed is required. All the same you can have a look at is there a hardware RF PC remote control that will work on win 7 and many other threads/posts on the subject. In the IR category have a look at EZ Commander.

Good luck.
My System SpecsSystem Spec
16 May 2012   #5

Windows 7 Ultimate x64

I had this same problem and i found a fix. I previously disabled the "Human Interface Device Access" service. Once i enabled and started the service the back and volume buttons started working again.
My System SpecsSystem Spec
27 Jan 2014   #6

Windows 7 Hope Premium 64

I just had to register and say thank you to jmandawg. His solution to disable the "Human Interface Device Access," and restart it again, works. Cheers!
My System SpecsSystem Spec
30 Dec 2014   #7

7 ultimate 64

Thanks a bunch, had the same issue and was going mad looking for the answer...
My System SpecsSystem Spec

 RC6 MCE Remote Not Working Correctly

Thread Tools

Similar help and support threads
Thread Forum
DVD/RWs suddenly not working correctly
Hi all, On my HTPC, my DVD/RW drives are not behaving properly, and I'm not sure why. They no longer have the proper menu on right-click with a disk inserted, double-clicking opens rather than playing CDs and DVDs. I CAN play a DVD by using the menu in VLC to open it, but this is causing a...
Hardware & Devices
Tried everything - Windows 7 not working correctly. Help Please
Hi everyone. I have a Acer X3990 computer. It has been working well for the past 2 years until yesterday. I haven't installed any new software or hardware. I have tried evreything I can think of to resolve - and I am COMPLETELY STUMPED!! Symptoms: When I boot up, my desktop loads...
General Discussion
keyboard not working correctly
Hello there :), Been living with this problem for a while now, trying to solve it without succes. Been into regions and languages and searched the Web. Also this is a Dutch setup laptop so "keyboard " is called "toetsenbord" !! There is a $ sign on the keyboard but no English Pound sign. ...
General Discussion
Remote features not working -remote desktop, WMC, iTunes remote, etc.
OS: Win8 64bit (My desktop is Win8, my laptop is Win7. We're dealing with the desktop here.) Where I am: university network, but these features seem to be working with my laptop. Things I've checked: allowing services through Windows Firewall (Bonjour, WMC services, etc.) Allowing remote...
Network & Sharing
Programs not working correctly
Woke up yesterday morning to find I could not sign on to the internet. Went to check email on MSN and it keeps telling me msn has stopped working. I also had to re check the box in connection settings for LAN and DSL or it would go to dial up. Went to Firefox and it said Firefox is already...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App