Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Doesn't have a valid IP configuration"

20 May 2010   #11
Ensiferum321

Windows 7
 
 

Ok ran into another problem... I restarted the computer and when it restarted the connection had the yellow Triangle again..So i went back to the router and reset it again and it works fine..

Is there something I need to do so that whenever my computer restarts I don't have to go to the router every time?


My System SpecsSystem Spec
.
20 May 2010   #12
metalmania31

Windows 7 Pro 64bit build 7601 SP1
 
 

What brand and model of wireless card are you using? Also how did you configure your connection to the router?
My System SpecsSystem Spec
20 May 2010   #13
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Ensiferum321 View Post
Ok ran into another problem... I restarted the computer and when it restarted the connection had the yellow Triangle again..So i went back to the router and reset it again and it works fine..

Is there something I need to do so that whenever my computer restarts I don't have to go to the router every time?
It should help to enter the default gateway manually although we need to know what it is first.

You can get that by doing an ipconfig when the connection is working then enter what ever default gateway is showing manually. Picture below shows you where to enter that info.

Click where it says ipv4 then choose properties then change to manual IP and enter which ever IP and default gateway shows up in your ipconfig.

It might be easier to make sure that you are using DHCP in your routers control panel. Usually the default gateway will stay put using DHCP.


Attached Thumbnails
"Doesn't have a valid IP configuration"-ipv4-ip-address-change.png  
My System SpecsSystem Spec
.

20 May 2010   #14
Ensiferum321

Windows 7
 
 

Seems to have done the trick. Restarted computer and everything went good. Thanks a lot for the help, again.
My System SpecsSystem Spec
20 May 2010   #15
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Ensiferum321 View Post
Seems to have done the trick. Restarted computer and everything went good. Thanks a lot for the help, again.
Very good Ensiferum, nice work on following those instructions. :)
My System SpecsSystem Spec
21 May 2010   #16
Ch@n

 

Glad the issue is resolved and thnx for posting back the solution that worked for you.
My System SpecsSystem Spec
Reply

 "Doesn't have a valid IP configuration"




Thread Tools




Similar help and support threads
Thread Forum
Wireless adapter doesn't work on windows 7 "No Valid IP Configuration"
Before you answer this question, I've already done the following: 1.) Download and install the latest driver for the adapter. 2.) I've already tried ipconfig /renew or release or whatever you want to call it. 3.) I've tried changing the ip address to static and rather automatic or automatic to...
Drivers
Wireless adapter doesn't work on windows 7 "No Valid IP Configuration"
Sorry for posting this in the driver section, I decided to post another in the wireless section. If you want to close one, that's fine just please close the one in the driver section. Thank you. Before you answer this question, I've already done the following: 1.) Download and install the latest...
Network & Sharing
"Local Area Connection" doesn't have a valid IP configuration - Win7
Hi. So I came back to my desktop after a weekend away, and all of a sudden my wired network has changed to "Unidentified Network" with no network access. I have never had a single problem with this before and I've tried several fixes that do not do a thing. I live in a dorm and am plugged directly...
Network & Sharing
Mind boggling network problem -"Doesn't have a valid IP configuration"
Hi everyone I've run into a problem that I really don't understand and I was hoping somebody here could help me. First a little background so you can understand the situation. My set up is that I live in a two story house and have my cable modem and a D-Link ethernet switch in my den on the...
Network & Sharing
ICS - "Local Area Connection" doesn't have a valid IP configuration
I set up ICS on my computer following the directions from http://windows.microsoft.com/en-US/windows-vista/Using-ICS-Internet-Connection-Sharing. I'm able to get network access, but no internet access. When I tell the computer to diagnose the problem, it tells me that the local area connection...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App