Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't run chldshk /r, volume write protected.

11 Jun 2012   #1

Windows 7 Home Premium 64bit
Can't run chldshk /r, volume write protected.

Plugged my iPhone into the computer and turned it on, I had to leave so when I came back I saw the startup repair screen. Left it on overnight and it wouldn't finish so I turned off my computer, when I turned it back on it brought me to the system recovery options screen. Tried startup repair again, this time it finished very quickly and said something like Windows is missing or it couldn't find windows. I started using the install/repair disk now because a few console commands wouldn't work without it. I remembered I accidentally installed a 32bit program in the 64bit program files the other day so I deleted the program's folder using the console, but it had no effect. I tried a few more commands and now startup repair says "bad hard disk".

I tried chkdsk /r, but I get a message that reads:
"The type of the file system is NTFS.
Cannot lock current drive.
Windows cannot run disk checking on this volume because it is write protected."

Any ideas as to how I can remove this write protection?

My System SpecsSystem Spec
11 Jun 2012   #2

Windows 7 Pro x64 / Pro x86 (Netbook)

If you run chkdsk from the recovery environment, it will by default attempt to run on the drive the RE considers "home", which I think is a RAMdisk, and write-protected. You need to specify the drive letter of the partition you want to scan (might not be C:, but you can try switching drives and checking their contents using "dir" until you find your actual Windows drive).
My System SpecsSystem Spec
12 Jun 2012   #3

Windows 7 Home Premium 64bit

Thanks for the reply! Turns out I already ran chkdsk, I think that's what got me from the missing windows error to the bad hard disk error. However, at the end of the chkdsk it says:

"An unspecified error occurred (69e647863686b2e 4a8)
Failed to transfer logged messages to the event log with status 50."

Windows still won't boot and i'm still getting the bad hard disk message in startup repair:
My System SpecsSystem Spec

12 Jun 2012   #4

Windows 7 Pro x64 / Pro x86 (Netbook)

Before you proceed, you should create a backup of your disk, just in case. I recently fixed a computer for my girlfriend's father which had severe boot problems, and was really lucky that a full backup was the first thing I did, because after a few day, the harddisk suddenly stopped working completely.
So, if there is any chance that the harddisk is actually damaged, create a FULL backup NOW! Unless you do not want any of the files contained on it. You can use robocopy with a USB disk, or create a system image using either Windows Backup and Restore or Sysinternals Disk2VHD, depending on what you can still use on the system. robocopy should work within the RE.

Try running a thorough chkdsk, with re-evaluation of bad blocks, maybe there really is some damage to your hard disk.

I would suggest this command:
chkdsk [drive]: /V /F /R /B /X
V just gives you more information about what is currently happening, but might be interesting, F is probably redundant because of R and B. B re-evaluates bad sectors, and X forces the system to dismount the drive, to avoid interference by other processes.
Depending on your hard disk size and the amount of data on it, this might take LONG. My 160GB netbook harddisk needs about 40 minutes (I did not measure it, but this is usually the time I have between getting up and leaving the house, and it finished within that time). Empty disk space is processed more quickly than actual files, so if your disk is very full, it will take much longer than on an empty disk.
You should avoid checking multiple partitions on the same disk at the same time (possible within the recovery environment), as this will SEVERELY slow down the process, but different disks can be checked at the same time with no significant loss of performance.
My System SpecsSystem Spec
17 Jun 2012   #5

Windows 7 Home Premium 64bit

After running chkdsk with /V, /F, /R, /B and /X, it ended at 11% complete and I received a message which states "An unspecified error occurred (696e647863686b2e 17ea)
Failed to transfer logged messages to the event log with status 50."
My System SpecsSystem Spec
17 Jun 2012   #6

Windows 7 Ultimate x64

Hopefully you do have the data backed up already. If the HD health is marginal, it's always better to first recover (copy) data that you cannot afford to lose.

You may be able to check the HD by going into the BIOS to see if there are any HD testing facilities in there. There usually are.

Or download diagnostics from the HD manufacturer which can be used to create a bootable CD/DVD/UFD with the diagnostics app on it.
My System SpecsSystem Spec
17 Jun 2012   #7

MS Windows 7 Ultimate SP1 64-bit

Did you make a backup as suggested? Yes/No.

You don't need all of those switches.
This is Win 7 and not eXPired.

the only switch you need is /R.

Go to an elevated command prompt.

if you have other drives, for example, a D: then
run CHKDSK D: /r
so on and so forth.

For an elevated command prompt:
Go To an Elevated Command Prompt

Elevated command prompt = Run CMD.EXE as administrator
WIN | type CMD.EXE | do not hit Enter |

WIN is the key with the Microsoft flag on top.



Simply brute-force it. copy from your computer to a USB stick all data dear to your heart

Awaiting the report that you have backed up your data.

After you run chkdsk over all of your drives, then:
I'll give a method whereby you can post the results.

My System SpecsSystem Spec
17 Jun 2012   #8
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Make sure your phone is not plugged into the computer.
My System SpecsSystem Spec
17 Jun 2012   #9

MS Windows 7 Ultimate SP1 64-bit

Quote   Quote: Originally Posted by Layback Bear View Post
Make sure your phone is not plugged into the computer.
A very good and valid point!
My System SpecsSystem Spec

 Can't run chldshk /r, volume write protected.

Thread Tools

Similar help and support threads
Thread Forum
USB Write protected
Hi, my sandisk USB Flash drive 4gb was not formatting. it gives error " disk is write protected". how to remove write protection... please help.
Hardware & Devices
HD write protected
Hi i have a hd which wont alow me to change write protection evan in dos i tryed but it sead drive now readable but when i try to format it in windows disk manager it says disk is write protected can anyone help me thanks:mad:
Hardware & Devices
USB drive is write protected.
Hello all. I need your help. I have a USB drive and it is write protected. I cannot format it with windows advanced boot option, I am not able to change the registry value for storage policies even. I have tried multiple PCs to format it. No luck Please help is imp. Thanks.
Hardware & Devices
USB write protected?
Hi, I have a problem with a brand new USB stick, PNY 64GB I bought on e-bay about two months ago. It started working properly, I transferred on it about 20GB of my photos. I did not notice anything weird. The pictures were there and I think I could even move them on and off, like copying and...
Hardware & Devices
HDD is write protected
I had a problem with my notebook and I got told to does this commands but it stayed like this for 3 hours..(in the picture) Anyway another website told me to do a different command and I think I might of found the problem. I found out that's its write protected. I can't boot up windows 7 because...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:04.
Twitter Facebook Google+