Realtek, Windows 7 64RTM Crackle/static/popping

Page 4 of 63 FirstFirst ... 2345614 ... LastLast

  1. Posts : 2
    Windows 7 Ultimate
       #31

    Finally I got the problem solved!!!!
    The key is to install an older driver R2.22 for vista, which is the driver just before the win7 one came out.
    techPowerUp! :: Download Realtek HD Audio 2.22 Vista
    damn Realtek spend me 1 whole month in solving the problem
      My Computer


  2. Hsg
    Posts : 5
    Windows 7 Professional x86
       #32

    tomhk said:
    Finally I got the problem solved!!!!
    The key is to install an older driver R2.22 for vista, which is the driver just before the win7 one came out.
    techPowerUp! :: Download Realtek HD Audio 2.22 Vista
    damn Realtek spend me 1 whole month in solving the problem
    HOLY SH*T DUDE, I F*CKING LOVE YOU!

    It seems that is working very well, I hope it that stays this way.
      My Computer


  3. Posts : 2
    Windows 7 Ultimate
       #33

    It proves that the windows 7 driver doesn't "support" windows 7 lol
      My Computer


  4. Posts : 24
    Windows 7 RC
       #34

    Ok heres a theory (bare with me)

    Since windows 7 first came out, I have downloaded many driver updates and gradually the sound had gotten worse and worse.. however right before 2.32 came out I had just installed windows 7 rtm (night before). I wonder if realtek drivers are leaving old files behind and corrupting newer updates. only reason i say this is because 2.32 is working perfectly fine and i think if i had the rc still.. it would not. hope that makes sense. since the last 5 updates or so, my windows log on screen had been making ridiculous noises and now theres nothing but beautiful sounds :)
      My Computer


  5. Posts : 33
    Windows 10 x64
       #35

    i still have the sound problem..
    actually mine is not so serious, just some short (0.5 seconds) Crackle/popping happen randomly..not only while playing music in WMP..but also watching youtube video, system sound .etc..

    after install and uninstall the Realtek driver (Audio and also NIC just in case it got conflict).. also reinstalled Windows 7 few times (tried x86 and x64..both got same problem).. still no perfect fixes for me..

    the best driver for me now is R2.22 (which is the latest realtek HD Audio driver for Vista).. i found out 1 thg.. the driver is dx10.. now i'm thinking that dx11 is the cause of my problem.. realtek driver not really support dx11 completely i guess..

    looking forward for future release.. hopefully can fix it..
      My Computer


  6. Posts : 5
    Windows 7 RTM
       #36

    It worked for me too! I also had the exact same problem (crack/pop/skip) with the new drivers for Windows 7!

    Thanks a lot!!

    Edit: Actually, that didn't solve my problem. The next day it got even worse. Then, for some reason, I tried disabling my firewall (Outpost) and it crashed my computer. I uninstalled it and everything is back to normal. That's why I had problems listening to music only while browsing. Anyway, I should have checked if Outpost was compatible with Windows 7 before upgrading Vista to 7...
    Last edited by brunok; 09 Sep 2009 at 19:28.
      My Computer


  7. Posts : 3
    Windows 7 Ultimate 64-bit
       #37

    ok ive been following this thread since im having the same problem. and i tried many driver including the v222. and it does not work for me...and i decided to try older driver which is vista v221. and guess what? it works! hopefully it works on u guys too. and im currently also using windows 7 ultimate 64 bit.
      My Computer


  8. Posts : 33
    Windows 10 x64
       #38

    gothfebrio said:
    ok ive been following this thread since im having the same problem. and i tried many driver including the v222. and it does not work for me...and i decided to try older driver which is vista v221. and guess what? it works! hopefully it works on u guys too. and im currently also using windows 7 ultimate 64 bit.

    are you sure? can i have the v221 download links?
      My Computer


  9. Posts : 1
    Windows 7 Ultimate x64
       #39

    ive been having this problem as well, im giving the newest driver a shot, then il try the v2.22 and/or v2.21 if the newest doesnt work.

    rangerevo08 here is a link to v2.21
    Realtek HD Audio 2.21 Driver download from Guru3D.com
      My Computer


  10. Posts : 2
    Win 7 64 RC1
       #40

    Plagued by this problem, so far 2.21 has been best, it isn't perfect, get a 'pop' every now and then.
    Getting fed up with it tbh, will more than likely buy a sound card.
      My Computer


 
Page 4 of 63 FirstFirst ... 2345614 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:16.
Find Us