Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SoundBlaster Live! Value, please!

23 Mar 2009   #1
stereomind

W7 x86 RTM Final
 
 
SoundBlaster Live! Value, please!

Hi dears

Could anyone help me to find the correct driver for my soundcard?, it is a Creative SB Live! Value (CT4670).

It was working fine on WinXP, but since I changed the OS to W7 its sounds is terrible.

I have tried to install many of those mod drivers of Daniel_K, but everytime the following error message appears:
"Setup is unable to detect a supported product on your system. Please ensure that your product is properly installed before running this setup program. Setup will exit".

An indication of the correct and working driver would help me a lot.

Thanks


My System SpecsSystem Spec
.
23 Mar 2009   #2
win7

Windows 7 Enterprise SP1 x64 Windows 8 Enterprise RTM x64
 
 

Try using the driver from windows update (i know this gives bad sound) but then install the kxproject.com drivers over the top, make sure to untick the "mixer" in msconfig/start up after the install as it causes an error, and you may need to change the default device in countrol panel/sound to get things working but thats how i got it working and im pretty sure your card is very similar to mine.

Im not 100% sure this will work for you but its worth a try
My System SpecsSystem Spec
23 Mar 2009   #3
stereomind

W7 x86 RTM Final
 
 

Thank you win7!

I will follow your tips.
Come back soon.
My System SpecsSystem Spec
.

23 Mar 2009   #4
stereomind

W7 x86 RTM Final
 
 

It works!

Great job win7, thank you for your help.

In this episode I learned many things, but mainly about the disrespect that Creative has with its consumers.

Nice day folks!
My System SpecsSystem Spec
24 Mar 2009   #5
johngalt

 

Yeah, this issue goes back to Vista - people left and right were clamoring about trying to get the Live! series of PCI cards working in Vista, and last time I tried before reverting to the onboard audio the kxproject was not working well with Vista - glad to see the project is working much better now, and that it can be used in Win 7 as well.

I still have that puppy sitting in one of my drawers, I might pull it out and put Win 7 on my old P4 machine and see how well Kx is working these days....
My System SpecsSystem Spec
25 Mar 2009   #6
win7

Windows 7 Enterprise SP1 x64 Windows 8 Enterprise RTM x64
 
 

Quote   Quote: Originally Posted by stereomind View Post
It works!

Great job win7, thank you for your help.

In this episode I learned many things, but mainly about the disrespect that Creative has with its consumers.

Nice day folks!
No problem, glad to help.

The Kx drivers are pretty good in 7, i am sat with music blasting out very loud right now with no distortion, i also use these drivers for the same card in vista.
My System SpecsSystem Spec
26 Apr 2009   #7
stereomind

W7 x86 RTM Final
 
 

Oops!

I've just installed Skype and the microphone doesn't work, I can't find where to configure it.

Could anyone help me?

Thank you

Edited: I forgot that the mix is disabled, wouldn't it be this way? how do I do now?
My System SpecsSystem Spec
27 Apr 2009   #8
win7

Windows 7 Enterprise SP1 x64 Windows 8 Enterprise RTM x64
 
 

try going into the audio settings in control panel and changing the default communication device to one of the other options, sorry i have not tried using a mic.
My System SpecsSystem Spec
19 May 2009   #9
drdamn

Windows XP
 
 

Had the same problem and it fix the "disordered" sound but the MIC ain't working for me also.
Lucky I have 2 sound card so I pluged the MIC to the other sound card.
My System SpecsSystem Spec
31 May 2009   #10
gvan39

win7
 
 

Same problem with my CT4670... Speakers are fine but micro is out :-('
Is it possible to install correctly mixer from kX project ?
Now by starting W7 I always see an error message from kX !!
I also use Skype... and without micro... :-( :-(
Thanks for answer
My System SpecsSystem Spec
Reply

 SoundBlaster Live! Value, please!




Thread Tools




Similar help and support threads
Thread Forum
Soundblaster Live! 5.1 Win7 Compatibility
I know that Creative has stopped supporting the SB Live! 5.1 way back in the day, but I was hoping anyone would know of a way to force it to function in some way. I've heard a lot about this Daniel_K guy, who's been making drivers for old Creative cards, but I can't really find anything for my...
Sound & Audio
Soundblaster Live SB0200 Drivers Win 7 x86
I wasn't able to get the onboard drivers to install so that I could get audio to the 1/8" jack, my Intel 945 PVS MOBO, so I picked up a SoundBlaster Live SB0200 board at a thrift shop and now I've been having trouble finding drivers on Creative Worldwide Support site or elsewhere. When I click on...
Sound & Audio
I have a SoundBlaster Live! and a GeForce GTX 550 Ti
At the moment I use the SoundBlaster for sound. Would using the graphics card instead be better or worse?
Sound & Audio
Creative Soundblaster Live 5.1
Good Afternoon, I've recently installed the above card (SB Live 5.1) on my system which is running Win 7 ultimate 32-bit. Prior to installation, I checked with the Microsoft Windows7 compatability website and it states completely compatable. Unfortunately, I get the red "x" in the taskbar...
Sound & Audio
Soundblaster Live Value 4.1 Speakers issue
Hi, other day, i instaled Win7 on my pc and i noticed a little big problem, i can't find drivers for my sound card Soundblaster Live Value 4.1. I used the ngocmd.exe but it only capt 2 of my 4.1 speakers. In Vista, the same patch/driver works fine, appears the 4.1 speakers, but in Win7 doesn't...
Sound & Audio
Soundblaster Live! 5.1 on windows 7
Hi, ive just upgraded my system from xp straight to windows 7 ultimate 64-bit... and installed all the drivers needed for my motherboard... but i had a creative soundblaster live! 5.1 audio card which windows 7 is not detecting on my system (uknown device, multimedia audio controller). i have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App