Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Disable forever. "Special permissions"

16 Jan 2009   #1

Disable forever. "Special permissions"

Hi everyone

i found this forum when im looking for way to disable this protection, sometimes i need to delete some folders and i cant, im tired of "Special Permissions"

how can i disable this forever? (and to any file, total control)

My System SpecsSystem Spec
16 Jan 2009   #2

Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build

Hi, dj23, and welcome to the forums.

Please see our tutorial at User Account Control - UAC - Change Notification Settings
My System SpecsSystem Spec
16 Jan 2009   #3


Quote   Quote: Originally Posted by johngalt View Post
Hi, dj23, and welcome to the forums.

Please see our tutorial at User Account Control - UAC - Change Notification Settings
thnks but dont answer to my question.
i have the UAC turned off, but i can't delete some files, pop-up window appears to tell "you need permission to perform this action".
damn i am the admin i want "special permissions" to all files, take "Full Control" of the files and folders. to delete, read wareva..

thks for the help.
My System SpecsSystem Spec

16 Jan 2009   #4

Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build

That ain't gonna happen - you cannot log in as TrustedInstaller / System, and that is the privilege set you'll need to not have those permissions there.

If you think you know your system that well, why upgrade to Vista / W7? get XP and you'll have full control - and will need 3 layers of protection that this one feature alone helps prevent....

If you cannot take control of the folders, there is not much you can do, short of (possibly) logging into Vista and taking control there.
My System SpecsSystem Spec
29 Apr 2009   #5

windows 7
Perhaps a Related question

Since I been using win 7, (I started with 7000 and now I am using 7100). some folders in my C:\ drive have a lock, for example Config.Msi, has a lock and it appears that more than one program uses this folder. I have tried to reset permission without success. Now I have a second folder Config.2Msi.
I am the admin and the owner of the machine, I turned ACL off.
Is this a security feature of win 7?
How do I disable the lock?
Thank you
My System SpecsSystem Spec
14 Jun 2009   #6

xp and win 7
Take Ownership

Ran the registry patch at this location, allowed me to edit folders I did not have access to, gives you ownership of the folders.

Add Take Ownership Option Shortcut in Right Click Menu of Windows 7
My System SpecsSystem Spec
02 Nov 2009   #7

Windows 7 Professional 64-bit
Very long reboot after "Take Ownership

I skipped Vista so all this special permission stuff is new to me. I wanted into "Documents and Settings" so I could move my .PST Outlook files from my XP system. The .reg file and the take ownership worked fine. I was worried that the "Everyone" and "System" permissions were now gone.

I booted the system to see if all was well. Well that boot took about 45 minutes. During that time the boot sequence was in super slow motion with about 1% CPU and a regular slow rythmn on the hard drive light. I left the room after about 30 minutes and had dinner. I came back to a black screen with no response to any key,

I powered down and cold booted and it came right up. Can anyone explain this. I don't know whether to keep going with the install. Should I start over and use the transfer utility or keep going?

Groton MA
My System SpecsSystem Spec
10 Jan 2010   #8

Windows 7 Professional

Never happened to me in Vista, I have Vista installed on 3 laptops and 2 computers.

I upgraded my main computer to Windows 7 at launch, everything was good for about a week then take permission dialogs started popping up whenever I want to rename, move or delete a file. It is very annoying, sometimes I feel like throwing my mouse, keyboard and computer tower out the window. The problem got to the point where I was unable to download files because the folder to save my downloads needed permission!!!

Microsoft needs to address the bug ASAP because it's driving me nuts, I've low level reformatted and reinstalled twice already and freakin bug keeps coming back after about a week or so. Funny thing is I cannot find a solitary thread @ TechNet that discusses the issue and Microsoft has acknowledge this bug with Windows 7 but doing nothing about it.

Windows 7 maybe the best Windows release ever but because of this bug a lot of users out there are having a very bad experience. I'm on the edge of insanity here, I'm thinking of going back to Vista or upgrading to XP.
My System SpecsSystem Spec
11 Jan 2010   #9

Windows 7 Ultimate x86 SP1

If it is not hard, TechNet link addressing the bug?
My System SpecsSystem Spec
30 Jan 2010   #10

Win 7 Ult 64-bit

Not sure if its the same problem or a slightly different one, but we've got similar problems with permissions on several machines running Windows 7 Ultimate 64bit.

We have a domain server (2003 SBS) which requires us to log on as domain\user. All users are administrators and UAC is turned off. These are all legit OS's, and were clean installs (not upgrades).

Most files work fine, but on some when trying to copy files or delete files from a data drive on a system with Win 7, get "must have permission from domain\user", which we are logged in as. We've tried taking ownership (which is silly because the owner is logged on anyway) and of course that doesn't work. We've tried the registry hack listed above, that doesn't work either. All of our systems are dual boot (with XP Pro), and logging onto XP with the same user/owner doesn't work either.

Since we've got this random problem on more than 1 system, and never had it before installing Win 7, it appears to be a Win 7 bug with profiles (the files in question are not inherited and won't allow us to inherit even though our users are administrators with full permissions). I have no idea why it happens on some files and not others. I have no idea what causes it or how to get around it.

Any help would be greatly appreciated as we're now virtually locked out of editing our own files. Thanx in advance. :)
My System SpecsSystem Spec

 Disable forever. "Special permissions"

Thread Tools

Similar help and support threads
Thread Forum
"User profile service failed the logon" special case access denied
Hello SevenForums! A friend of mine brought a Windows 7 Ultimate x86 laptop saying that he can't log in with his account. When he tries to log in it shows this message: "The User Profile Service failed the logon. User profile cannot be loaded." Now I've searched the internet and found a few...
General Discussion
Disable forever ""Word hyphenation feature is not avai"
When I open some documents then always a warning popup appears in Word 2007: "Word hyphenation feature is not available. RUn the MS Office Setup program..." How can I permanently and forever disable this popup (without saving the document and without re-install some other parts of MS...
Microsoft Office
Permissions for non-system, "user" drives; not "c:"
Would like to not have UAC pop-up for files & folders on non-C: drives, so expect they need to have "full control". Default is Special Permissions. Is there a way to default to "full control" when new folders are created, or do I need to mod permissions for each one? Note that I am NOT talking...
General Discussion
LAN File Sharing "7" to "XP" Permissions issue
Hello Everyone I'm really hoping there is someone here who can help me with what should be an easy issue. This might be something related to workgroup vs home group but I think I have that understood. I have a windows 7 machine with the same workgroup set as my two XP machines. I then...
Network & Sharing
Bypass "Ownership" and "permissions" to files altogether!
Hello all! I don't understand what the issue is but I am logged on as administrator on my computer and only a few of my files I can access. the window will pop up stating that i don't have permission to view the file! if I am the adminitrator i should have full access to any file, right? this...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:06.
Twitter Facebook