Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Access denied when taking ownership of a file

27 Mar 2010   #1

Windows 7
Access denied when taking ownership of a file


I recently downloaded an application file (.exe), and tried to delete it, but i keep getting the error "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item".

I tried changing the ownership of the file > right click > properties > security > owner >edit >selected my user account (administrator) > and clicked ok. All i got was an "access is denied error".

I even tried going to cmd and using the takeown and icacls functions, but am still getting the access is denied error.

Any advice on how to take ownership of this file is greatly appreciated.

My System SpecsSystem Spec
27 Mar 2010   #2
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

You seem to have used all the heavy guns available in our arsenal. How about setting back to a restore point from before you downloaded the program?
My System SpecsSystem Spec
27 Mar 2010   #3

windows 8.1 pro

there are two programs i can think of
1 - unlocker, i don't have a link for it, but it should be easy to find it.
2 - winbubbles, it gives you the right click option in the menu to delete afterwards.
the first one, never had a problem with it.
My System SpecsSystem Spec

28 Mar 2010   #4


Remove the system and hidden file attribute first. Use an elevated command prompt.

attrib -s -h C:\and the full path of the file, if your drive is not C:\ substitute correct letter

Now try to take ownership

My System SpecsSystem Spec
28 Mar 2010   #5
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Boot into safe mode, use Unlocker. That should work to delete the file. If it was a malicious file, there may be more files protecting it.
My System SpecsSystem Spec
10 Jul 2013   #6

7 Pro 32 & 7 Home Prem 64

Old thread I know - but maybe someone else stumbles upon this as I did.

Mombodog mentioned above using elevated status - this worked for me, but without having to go to the command line. I started Explorer with the right-click "Run as Administrator" option and then was able to take ownership as per OP's post.

In my case it was also a downloaded file, but a bit torrent using BitLord which I'm still not completely au fait with and I may have used an option in BL that unloaded the file without releasing it properly first. Who knows, but I wasn't about to try re-getting a 5.1 GB file that had taken over a week to download in the first place!!
My System SpecsSystem Spec

 Access denied when taking ownership of a file

Thread Tools

Similar help and support threads
Thread Forum
Ownership, permissions and now access denied
I have a WD elite hard drive that was set up on my old computer. I had changed ownership on the drive and used the Smartware to do backups. I'm pretty sure that I deleted some of the other owners when I was there too. I have a new computer and was able to change ownership back to me and can...
General Discussion
Permission not granted to access files even after taking ownership
I have a 250gb hard drive from an old PC that has ALOT of pictures ,videos, and music stored on. The PC was running Window XP. It died and I removed the hard drive and bought an enclosure to install it in. I have it hooked to a newer PC running Windows 7. At 1st when I pulled up the folders with...
General Discussion
Access Denied(despite ownership/permissions)
My storage drive has been showing signs of wear recently, so I have purchased a new one and was in the process of transfering files from one drive to the next. However I have come upon an issue regarding permissions. A seemingly random selection of files and folders have been denying me access to...
General Discussion
ACCESS DENIED ( ownership and permission )
hey guys babylon trans. kindly advise me about the image below what to do i tried every thing nothing work out !! Uploaded with
Windows cannot access when trying to taking ownership
hi, i'm trying to take ownership like you've described here but when i click "take ownership" i get an error message saying "windows cannot access the specific device, path or file. you may not have the appropriate permission to access the item". i get this same error message when i double click...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App