Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update Client failed to detect with error 0x80070bc9 - Looping

25 Dec 2012   #11

Windows 7 Professional 64bit

Thanks Noel,

Let me try the SP1 Upgrade.


My System SpecsSystem Spec
26 Dec 2012   #12
Saurabh A

Windows 7 64bit

Hi snvasanth,

You may try the following troubleshooting steps also:

1. Clean up the bloated 'Software Distribution folder': Software Distribution folder contains 'Windows Update installation files'; this folder can be deleted/renamed using 'Windows Explorer'. You may want to backup the folder on an external media. Deleting the Software Distribution folders will not affect your computerís functionality. When new 'Windows Updates' are ready for download, a new 'Software Distribution folder' will be created.

- Stop the 'Windows Automatic Updates service'
- Delete the 'Windows\SoftwareDistribution folder' (You may also choose to rename the existing folder 'SoftwareDistribution_old' so that Windows creates a new folder)
- Restart the 'Automatic Updates service'

You may want to use the following commands in an 'elevated command prompt' to perform the above mentioned tasks:
(To stop the Windows Automatic Update service): net stop wuauserv
(To delete Software Distribution Folder): del c:\windows\SoftwareDistribution /q /s
(To restart Windows Automatic Update Service): net start wuauserv

2. If the issue persists, try to reset 'Windows Update components'; you may use the following MS Fixit: How do I reset Windows Update components?

3. If you still experience issues, you may try another MS Fixit to 'Diagnose and Troubleshoot Windows Update issues': Troubleshoot problems with installing updates - WindowsUpdate_dt000

Hope this helps. Do reply if you have any further questions. I would be glad to assist.
My System SpecsSystem Spec
26 Dec 2012   #13

Windows 7 Professional 64bit

Hi Saurabh,

I had tried various options including these few days ago. Infact I did try deleting the reg subtree corresponding to Windows Updates. Nothing helped.

I just completed my SP1 upgrade with downloaded SP1 ISO.

My System SpecsSystem Spec

26 Dec 2012   #14

Windows 7 Professional 64bit

Hi Guys,

I have upgraded the system with Win 7 Prof 64bit SP1 ISO. Automatic Updates are working now.

I did use the Product Key from my COA (Which originally is Win 7 Prof 64bit - No SP1) with the Win 7 Prof 64bit SP1 Upgrade.

But when I try to Activate windows now, it says "The Windows 7 Professional Product Key you typed is invalid for activation"

Does it mean that the KEY that belonged to Win 7 Prof is not compatible with Win 7 Prof SP1?

Should I try for Phone Activation?

My System SpecsSystem Spec
26 Dec 2012   #15

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

To properly analyse and solve problems with Activation and Validation, we need to see a full copy of the report produced by the MGADiag tool
(download and save to desktop - )
Once saved, run the tool.
Click on the Continue button, which will produce the report.
To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.
My System SpecsSystem Spec
26 Dec 2012   #16

Windows 7 Professional 64bit

This system DELL VOSTRO 430 was bought in June 2010. I remember sometime in April 2012, I upgraded the Bios to 2.4.0. ( I found while googling that BIOS update did affect the OEM the Product Keys - for Lenovo).. Could that be the cause?

Here is the report...

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->
Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-FJGYB-FWXQM-G9WCB
Windows Product Key Hash: oXMPb77MTjs4aEBzhvDlGLuMPlE=
Windows Product ID: 00371-OEM-9202125-86536
Windows Product ID Type: 8
Windows License Type: COA SLP
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {C9DCF832-ACB6-4E59-9B20-B4E7B4B4E5F7}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered,
Signed By: Microsoft
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.120830-0333
TTS Error:
Validation Diagnostic:
Resolution Status: N/A
Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002
OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{C9DCF832-ACB6-4E59-9B20-B4E7B4B4E5F7}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-G9WCB</PKey><PID>00371-OEM-9202125-86536</PID><PIDType>8</PIDType><SID>S-1-5-21-1813900158-430706030-1897707973</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Vostro 430</Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>2.4.0</Version><SMBIOSVersion major="2" minor="6"/><Date>20110113000000.000000+000</Date></BIOS><HWID>55AC3B07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>MI09 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7601.17514
Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
Activation ID: c1027486-8ae8-4633-9cf9-9658ed80504d
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00184-021-286536-02-16393-7601.0000-3602012
Installation ID: 009254750062680366763446100056280796667201982743405896
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: G9WCB
License Status: Initial grace period
Time remaining: 42660 minute(s) (29 day(s))
Remaining Windows rearm count: 4
Trusted time: 26-12-2012 07:35:24
Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT DpgPmm CpuPm
My System SpecsSystem Spec
26 Dec 2012   #17

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

There's no problem with the BIOS - and I don't see any problems elsewhere, either.

This probably means that you simply need to use Telephone Activation and speak to an operator.

telephone activation (operator calls)
Click on the Start button
in the Search box, type
and hit the Enter key
follow the instructions, but when asked which service you require by the telephone ansafone, do NOT reply - this should force an operator to respond, who can deal with you
My System SpecsSystem Spec
26 Dec 2012   #18

Windows 7 Professional 64bit

Hi Noel,

I successfully activated windows! Thank you so much for the help and follow-up. Speccy does report the same product Key as my COA.

I went through Automated Phone Activation and it worked.

I did fix the issue with Desktop Themes. Need to check if any applications are broken after upgrade. I could see Google Drive is broken for now...

Thanks again,

My System SpecsSystem Spec
26 Dec 2012   #19

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Probably uninstalling and reinstalling Google Drive would fix that - I've never used it.
My System SpecsSystem Spec

 Windows Update Client failed to detect with error 0x80070bc9 - Looping

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 update failed. Error 8007065E
My computer fails to install the update for windows 7 for 64x-based systems (KB2761217) The error code is 8007065E I've tried the windows fixit program and the problem still persists. Attached is the CBS.log Can I get some help please =)
Windows Updates & Activation
Windows Update Failed: Error 8024402C
Windows update has not been able to install new updates for a couple of weeks. I first noticed this after getting a notification in my task tray saying that updates could not automatically install. However, updates will not manually install either. I get the error "Windows Could not Search for...
Windows Updates & Activation
.NET Framework 4 Client Profile causing Windows Update Error 0x8024402
Hi I'm running Windows 7 32bit. I performed a clean install on a new hard drive, I successfully ran a few updates with Windows update and eventually was offered the .NET Framework 4 Client Profile which i installed. When i tried to check for updates after that it failed with error 0x8024402f....
Windows Updates & Activation
MSE Client Update Package - V4 failed
I got an update notice for an MSE Client Package to update to MSE V4 (KB2691905). The update failed on Win7-x64 leaving no AV installed. I tried to download MSE and I get a "Page cannot be found" at Microsoft Security Essentials - Free Antivirus for Windows I did find this page can download...
System Security
Update for Windows 7 Client Beta for x64-based Systems (KB963660) error
Update for Windows 7 Client Beta for x64-based Systems (KB963660) Install this update to resolve issues with Media Player or Media Center for Windows 7 Beta where multimedia codecs are not functioning on or after 15 March 2009. For complete details of this update, see KB963660. After you install...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App