Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System Restore - major problem

18 Jan 2017   #1
teckneeculler

Win7Ultimate
 
 
System Restore - major problem

W7 Ultimate 64-bit installed on 1-year-old Apacer 250GB SSD.

Every few days or so, I set a Restore Point. This normally takes about 15 seconds. I ordered one just now and went for a coffee. When I came back about 15 minutes later, the System Restore app was still running.

Odd, I thought.

Button pushes wouldn't stop it so I did Crtl\Alt\Del and stopped it that way.

Tried to set another Restore Point but all the app buttons were greyed out and only returned after I rebooted. So I opened System Restore, intending to revert to the last Restore point, but was told that the system wasn't running and there were no Restore Points anyway!

(Incidentally, I'd had SR limited to about 30GB. But my Apacer 250GB SSD C: drive has plenty of space - 87GB used with 135GB free)

After a few more fruitless attempts I went into Services and changed Volume Shadow Copy from Manual to Auto and did the same with Microsoft Volume Shadow Copy Provider, Windows Installer and a couple of others that I'd read about, along with all their dependencies. Still no joy.

I went into Event Viewer and found that the Volume Shadow Copier had been throwing up an error every 24 hrs since 11th January 2017. Which reminded me that, months ago, I'd set Task Scheduler to run System Restore at midnight.

So I went into Task Scheduler and removed the entry. Rebooted but still no System Restore.

Without going into details, I tried another dozen or so 'fixes' I found here and on other boards, but nothing has changed.

Oh, and I ran the 'vssadmin list writers' command and that found no errors in the 11 or so listed writers.

Plus I've done a full virus check, ran Malwarebytes (full version) twice with no errors, downloaded and ran adwcleaner and rkill with no errors.

I've run sfc /scannow and chkdsk /r twice each. I tried setting an SRP in Safe Mode but the program won't run at all in Safe.

And it couldn't have been a Windows update that caused the problem because Updates has been disabled for eight months.

So I'm kinda stymied. Short of a Windows reinstall I can't think of anything else to do.

Any fresh ideas, guys?

Later: Thought I'd try creating a Restore Point in Safe Mode one more time, so in msconfig I checked 'Start in Safe Mode' and walked away for a while. When I came back, the screen was showing the "Failure configuring Windows updates. Reverting changes. Do not turn off your computer" continuous loop message. And this when I don't even have Windows Updates turned on!

I'm starting to think it's either an as-yet-unknown bug or my SSD C: drive has developed faults.


My System SpecsSystem Spec
.
21 Jan 2017   #2
MeOnMine

Windows 7 Ultimate x64 SP1 OEM
 
 

Hi, I would be running a RootKit scanner if I were you.
Kaspersky TDSSKiller.exe is my recommendation.
Virus can and will stop restore points from working.
An added piece of advice.
Don't use restore or Windows backup.
Notoriously unreliable.
Learn Image technologies, Macrium Reflect Free is always recommended here.

Good Luck
My System SpecsSystem Spec
22 Jan 2017   #3
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

I agree mate with Meonmine and there are some more you can try if you like from this listing
Best Free Rootkit Scanner and Remover | Gizmo's Freeware there are soem pretty heavy weight ones in there and as I don't know how comfortable you are using that sort of software.
My System SpecsSystem Spec
.

22 Jan 2017   #4
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

What anti virus program do you use?

Please list all security programs you have installed.

Do you have any programs by IObit?

Jack
My System SpecsSystem Spec
22 Jan 2017   #5
teckneeculler

Win7Ultimate
 
 

Thanks guys. Yeah, I'd better run some heavier stuff.

I have a full version of Malwarebytes and ran that several times, but it came up clean. However, if this actually is a bug, it's possible that it's a recent one and might take a while for the fixes to catch up.

I ran RKill and Adwcleaner but they found nil. I'll try TDSSKiller, MeOnMine - used it a few times over the years on customer's machines. Re System Restore, I know that it seems to have an unreliable reputation but I've used it for over 20 years without a problem. Plus, I've taught many customers how to use it and it's got them out of holes. Imaging I think is a PIA. Installed several brands from time to time but never had any success with recovery. I think the best value of apps like Acronis TI (which I just dumped) is the reassurance factor.

Actually, just backing up and restoring the registry is easy and fast. But every now and then you just have to do a reinstall, and I think that's where I'm heading.

Anyway, I'll try a few more bug-fixes first. If I find anything I'll come back.

Oh, and Jack - no, I'm not running any IObit software. Is there a problem with some of their stuff?
My System SpecsSystem Spec
22 Jan 2017   #6
teckneeculler

Win7Ultimate
 
 

Heads-up: TDSSKiller found nothing. ComboFix stalled because it couldn't set a Restore Point. Which is kind of ironic :-)
My System SpecsSystem Spec
22 Jan 2017   #7
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Have you tried the GMER (it's in the link I posted) yet tecknee it is fairly heavy weight as you may know and it has found nasties on my machines before - not very often I will admit because things have never been that desperate.
My System SpecsSystem Spec
22 Jan 2017   #8
teckneeculler

Win7Ultimate
 
 

Thanks. Yep, just ran GMER and I'm not sure if what it found is actually a problem.

There was only one entry under the 'Rootkit/Malware' tab:

Type - Thread
Name - C:\Windows\SysWOW64\ntdll.dll[3132:3428]
Value - 0000000000fbe72

Windows Properties show the file to be a Microsoft file, 1.25MB, dated 10Feb16 which is about when I installed W7 last.

Thing that makes me skeptical is that my wife's PC has an identical file. Similar date, I built hers about the same time.

What do you think?

Later: The same file is in my several laptops, too. But none of them are having problems with System Restore.
My System SpecsSystem Spec
22 Jan 2017   #9
MeOnMine

Windows 7 Ultimate x64 SP1 OEM
 
 

Just change the name of the file and see.
If no change put the name back,
My System SpecsSystem Spec
22 Jan 2017   #10
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Quote   Quote: Originally Posted by MeOnMine View Post
Just change the name of the file and see.
If no change put the name back,
Worth a try.
My System SpecsSystem Spec
Reply

 System Restore - major problem




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 System restore problem no restore points
I have seen numerous people are having this problem but I have not been able to find a solution that works for me. I figured I would post my own problem and maybe somebody could recommend a solution. I have been trying to use Windows System Restore on Windows 7 Home Premium. I have created...
Backup and Restore
System restore problem
EDIT....Please mark this tread as solved Hi all, Well, this all started on the 16th when an update for Silverlight got "stuck" and after 2 hours of the update running, I had to reboot the machine. When I tried to use my System restore it started giving me the "Could not restore, nothing has...
Backup and Restore
Problem with Word 2003 after system repair and system restore ?
Office Version:Office 2003 Operating System:Windows 7 http://i4.social.answers.microsoft.com/Forums/resources/images/trans.gif?cver=2.13.0068.4 After a number of issues regarding my HP OfficeJet 7410 All-In-One problems (absolutely no help from HP by the way)...I decided to try a "System...
Backup and Restore
System Restore Problem
Hi guys, I have on problem and I dont know how to fix it, when I try to launch system restore, start > right click on Computer > Properties > System Protection at left side, it shows this message: "There was unexpected error in the property page: System Restore encountered an error. Please try to...
Backup and Restore
system restore problem
I restored back to 12/3/09 and it fixed my problem,but I tryed to setup a permanant restore date and it went to todays date, when I took todays date back off and tryed to go back to 12/3/09 the earlyest date it would go back to was 12/17/09 and that is not back enough. How can I get back to...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App