Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unsigned Starforce Drivers problem with startup

19 Sep 2010   #1

Win 7 - Mac OS X - Linux
Unsigned Starforce Drivers problem with startup

I wasn't sure if I should post this in this forum or the Driver forum. I'll try this one, please let me know if I am correct.

A month ago I bought a brand new rig, mostly for work and a little bit for my Simulation videogames (Flying & Driving).

One of the games is GT Legends, an oldie but goodie. I bought the disk in a double set deal with GTR2.

I first installed the latter and all went well. But when I installed GT Legends (GTL) I was alerted that the drivers for the copy protection were unsigned. I stopped the installation, but evidently it was too late.

Upon restart I was greeted by this message:

"Reboot and Select Proper boot Device or insert boot media in selected boot device and press a key"

Upon reboot it did exactly the same thing over and over. After some search I discovered this was due to the unsigned drivers and that the only cure was to press F8 and choose the Start disregarding unsigned drivers option (an item I had never even seen before and I Have had vista and Win 7 for 3 years now).

This means that since then I have been unable to do unassisted startups, but even with me there apparently my motherboard is set up in such a way that I have to go through all of them and it takes a long time.

in fact, even for F8 to be recognized it seems like an eternity. It is only 2 to 3 minutes wait, but it sure seems forever.

This is what the computer starts at startup:

1) Displays BIOS selection window (never used to do that)
2) There I press F8 and wait the 3 minutes
3) It shows me a list of HD to boot from (my RAID 1 is, of course, the last one)
4) Next I go to the windows boot screen, where I can start.

Since it was established the unsigned drivers were at fault, I went searching for them and try to deactivate them or kill them. I followed several tutorials I found online, including the ones from Starforce. Starforce actually provides two programs: 1 to find the drivers and one to delete them.

Unfortunately, both programs told me that there were no starforce drivers in my system and after I went to look for them where they should be indeed I could not find them. I did not delete them.

Yet, Windows still assumes that the unsigned drivers are there and forces me to go through that start up procedure.

I think I am done investigating: the drivers are not there. I even used a program that searches and lists all drivers (but does not indicate which ones are not signed) How can I fix my start up?
Is there a way to find what's causing this?

Reformatting the OS is not an option, I have just finished installing and configuring my applications and it took me 2 weeks. I am a Audio/Video/Graphic Artist/Web developer kind of guy and I use this for work. I can't afford, at least at the moment to go over the configuration of my new computer again.

Below are my specs. Thank you very much for your help:

OS: Windows 7 Professional 64 bit
Processor : Intel Core i7 970 3200MHz - (OC to: 3502.34MHz)
Physical Memory : 6144MB (3 x 2048 DDR3-SDRAM ) Corsair
Video Card : NVIDIA GeForce GTX 460
Hard Disk : Seagate ST32000542AS ATA Device (2000GB)
Hard Disk : MARVELL Raid VD 0 SCSI Disk Device (1000GB)
Mainboard : Asus P6X58D-E
Physical Memory : 6144MB DDR3-SDRAM

My System SpecsSystem Spec
19 Sep 2010   #2

Windows 7 Professional x64


I suggest a system restore from the Windows DVD to a point right before you installed the offending program.
My System SpecsSystem Spec
29 Sep 2010   #3

Win 7 - Mac OS X - Linux

Thanks, but somehow widows restore does not give me the option to restore to that time. I am not sure why but I believe it's because right after that incident windows installed an update and the only restore point I Have is the one before the update. Those drivers are not listed.

Also, I am beginning to think that while the drivers are not in the system, Windows still thinks they are. Almost like the way a vaccine fools the immune system in creating antibodies.

I looked all over and those drivers are not installed. My guess is that somewhere windows is being told there are unsigned drivers and it reacts consequently, but the drivers are not really there.

Where could this trigger be? Maybe it's just a matter of eliminating an entry in the Registry or something along those lines.

It certainly is a pain though and having to baby sit every start up is getting old quick.
My System SpecsSystem Spec


 Unsigned Starforce Drivers problem with startup

Thread Tools

Similar help and support threads
Thread Forum
Unsigned Drivers problem
Hello everyone. always when i loading one program and i have error "windows requires a digitally signed driver". I tested 100 different ways how to fix that. but its impossible. Im confused and doesnt know what to do now.. i tried: 1. Disable Digital Driver Signing & Enable Test Mode 2....
unsigned drivers
Im trying to install a game in win 7 but it involves installing what the game calls 'protected files'. These are apparently unsigned drivers that Win 7 will not install. I have installed this game in win xp in the past without any problems but it seems this is yet another windows security...
unsigned drivers
Hello ,I have been using a kensington expert mouse on win 7 64bit ,and i have just tried out the kensington beta trackball works for win7 64 bit, it works great ,apart from the driver not being signed by MS,I have found that by pressing f8 and allowing windows to work with unsigned drivers the...
problem with Starforce Protection
Hello, Everyone I am having a problem with the starforce protection in Trackmania. so would you please help.
Unsigned drivers
a while ago (over a month) found that i could not use my mouse or keyboard unless i disabled driver signature enforcement on boot just today, i ran sigverif and found that these drivers are unsigned: sugi1ci.dll wudfcoinstaller.dll usbehci.sys usbhub.sys wudfpf.sys wudfrd.sys but i think...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App