Need Help ASAP, Zebra/UPS Thermal 2844 And Windows 7  

Page 4 of 6 FirstFirst ... 23456 LastLast

  1. Posts : 1
    Windows 7 Ultimate x64

    I had a lot of issues getting my Zebra UPS 2844 Thermal Printer to work. In the end, it was all so simple.

    Currently I use UPS and to ship and print labels. Both need different drivers to work correctly.

    Printing labels via UPS:

    Agree to the terms and download these drivers.
    Run setup.exe and install the drivers.
    In "Devices and Printers" rename UPS Thermal 2844 with UPS Thermal 2442

    Bam! Done!

    Setting up with

    Download and install these drivers from Seagull
    Go back into your "Devices & Printers" and you should see "Zebra UPS 2844". Configure it to use the 4x6 labels and you are done!
      My Computer

  2. Posts : 1
    Windows 7 Professional 64-bit

    Finally got my ZP 450 ctp printing from

    After what seemed like 100 attempts to get it working, pulling all of my hair out, chewing all of my fingernails off, and cussing at the top of my lungs at an inanimate object and everyone at UPS for not providing clear directions ANYWHERE, I finally got my ZP 450 ctp behaving nicely with my Windows 7 64-bit machine and printing from using a combination of several sources. In my crazed and blinded-by-frustation state, I really needed some step-by-step directions that walked me through the process, so I've included the steps that I took to get it working below:

    1. Make sure all previously installed driver attempts are deleted using Print Management.
    2. Install the driver that you find here. To install, run PrnInst64. Choose UPS Thermal 2844 as the printer you are installing (yes, I used this for my ZP 450 ctp). I have the printer plugged into my USB hub and I chose USB03 as my installation port.
    3. After installing the driver, go to Devices and Printers, right click on the printer, Go to Printer Properties, and change the name of the printer to UPS Thermal 2442.
    4. Download and the UPS 64-bit Thermal Printer Browser Plugin at this link.
    5. I use Firefox for EVERYTHING, but I never could get it to work. I tried printing from Firefox using IE Tab, however, that DID NOT work either. So, I finally tried printing directly from Internet Explorer as a last resort and it worked perfectly.

    On previous installations, I was able to print but it was never formatted correctly and was really not usable. I kept seeing that people on the Internet had gotten it to work, but I wondered if they had to figure out all the settings. When I got this to work, the formatting fit the label perfectly and I didn't have to do anything. I hope this helps someone, because I spent many frustrated hours trying to get this stupid thing working and wasted about 1/3 of my label roll trying to get printing settings fixed.
      My Computer

  3. Posts : 2
    Windows 7 Home Premium 64bit

    UPS 2844 Printer HELP

    I have tried every possible way that has been suggested on here and it will still not print as a thermal printer. It will do a test page and work with certain things in windows but it will not print from UPS web page as a thermal printer. Now the one thing that I think might be part of the problem is that my version of windows is the permium home 64 bit addition. If I upgrade to the pro version of windows do you think some of these suggest fixes will work? Please help me!
      My Computer

  4. Posts : 2
    Windows 7 Ultimate 64-bit

    Use Seagull drivers for

    To bvolanski: No, your edition of Windows has no bearing on the matter. 64-bitness matters, but that just means you need to use the available 64-bit drivers.

    Try everything again, first carefully deleting ALL previous driver installation attempts. To do that, use Control Panel > System and Security > Administrative Tools > Print Management.

    Follow the steps provided by utalkitype above. Even my own instructions from last year are now obsolete.

    It all really does work in 64-bit Windows, I swear. Good luck.
      My Computer

  5. Posts : 2
    Windows 7 Home Premium 64bit


    Thanks from keeping me from buying a windows upgrade but it still will not work. I have done that step by step multi times. My 2844 will work with windows, it will work with as a standard printer but not print the labels correctly no matter how I arranage them or if I have the templete that is shown above. As a thermal printer UPS will not even comunicate with it. UPS says the labels printed and nothing ever happens. Is there any other printer that will work fine, i'm ready to sell this one and go get one that does not have these problems. If you do have any advice please let me know.
      My Computer

  6. Posts : 4
    Windows 7 Home Premium 64 bit

    Hi, not to be a smart axxx or anything but I assume you did a dump on the UPS printer at some point? Eben plugging and unplugging it won't delete the memory sometimes so you need to dump it. Turn it off, Turn it back on while holding your finger down on the green button, it will turn red and blink 3 times, once it does that release it and it will go into dump mode, then once it prints out the labels, press the green (feed button) again and it will print a label that says "out of dump" then try printing again and see if you are still getting blank labels
      My Computer

  7. Posts : 1
    windows 7 home premium

    solving my problem was a combination of all the posts here and I thank you all.
    I'm posting so some poor guy like me will have one more thing to consider.

    I might add that the particular machine I was working with is an XP box, but googling my problems was what lead me here. I do have a win 7 laptop and will be switching out some desktops so I'm sure I'll be back.

    First, I purchased a Zebra 2844 with intention to use to replace a Zebra DA402 in my business system. Turns out the 2844 has fedex firmware and after using the Zebra downloader to update to Zebra firmware I couldn't get it to place nice.

    So I have the bright idea to turn it into a UPS printer. Researched it and got frustrated with a lot of blank labels,sideways ones with half the sample and two page instructions.

    Again thanks for all the ideas and sharing, anyone have a question on converting a fedex LP2844 back to a normal 2844 just message me.

    I tried the uPS firmware,drivers and plugin.

    AlliedArmory just a few posts above set me on the right track.
    • Went to printers properties - files - removed all drivers (there were alot for zebras of all stripes).
    • Left the Zebra stock firmware.
    • Installed the uPS driver as Eltron LP2844 then plugged in and turned it on (I also found when I dumped all those drivers windows quit trying to install on its on,i was back in control)
    • Renamed as UPS Thermal 2844 (it seems they now have the right drivers)
    • Make sure you have the plugin if youre shipping uPS online
    • Make sure in the "testlabel" you check "Print with my uPS Thermal Printer" since thats what it is when you use their drivers.
    • I had read where the fedex printers firmware wouldn't update but mine sure on printer was 2006
    Last edited by naseqp; 13 Aug 2011 at 17:04. Reason: finish
      My Computer

  8. Posts : 1
    Windows 7 Professional 64bit

    Fix For UPS

    Here is what I had to do to get the Zebra LP 2844 to work on Windows 7 Professional 64bit with UPS Worldship 2011. This is 100% tested and was given to me by UPS Worldship Prefered support.

    Zebra LP2844 UPS Worldship Setup
    1. Keep printer disconnected.
    2. Open UPS Worldship and go to Tools > System Preferences Editor.
    3. Go to the Printing Setup tab. Then click Label Printer Setup.
    4. In the Label Printer Setup dialog box click Change Label Printer.
    5. In the Printer Selection dialog box click Add Printer
    6. Select Eltron/Zebra as the Printer Type
    7. The Zebra Printer Driver Installation window will appear. Click Install Zebra Printer
    8. Be sure to select UPS Thermal 2844 as your printer from the list. This is the most important step.
    9. You will be prompted to select a port. Select the proper port based on your connection. In this case I was using the USB cable so I selected USB as my port.
    10. During setup a dialog box may open stating “The driver is locked by another process.” Ignore this and click the Next button.
    11. This should complete install and bring you back to the Printer Selection dialog. Select UPS Thermal 2844 from the list. If this option is not available, click cancel, then Change Label Printer to refresh the list. Select UPS Thermal 2844 from the list and click Select.
    12. Check the Label Configuration settings for your specific labels. I selected “Thermal 4x6 or 4x6 ¼”.
    13. Click Apply. Power on your printer and connect to your computer.
    14. Click the Print Test Label button to test your installation.
      My Computer

  9. apc
    Posts : 1
    windows vista

    don't forget to use the Windows Explorer browser on the UPS site!

    firefox and chrome were printing doubles of everything ...
      My Computer

  10. Posts : 1
    windows 7 64 bit

    Here is what FINALLY worked for us

    We were having similar problems, I could install the printer by just plugging it in and letting windows do its thing but couldn't get it to work with UPS worldship for the life of me. After days spent in frustration here is what finally worked.

    Don't install through windows. Open up Worldship, go to tools and selected System Preferences Editor. From there open up printing setup tab and click Label Printer Setup. Then I went through and did a add printer (UPS Thermal 2844 not the Zebra LP 2844) installed that way and had a few errors pop up on the install and was about ready to throw the printer out but it finally did do a test page. (We used a USB cable so make sure you choose the right port for us it was USB001.)

    However it still was not installed properly, nothing was printing just spitting out two blank labels. So I went back trying to install drivers and font things from Zebra website with no luck in getting it to work right.

    What finally did work was when I then did the windows automatic updates after installing through the UPS worldship program. There was a Zebra update listed and once I installed that, restarted my computer and then did another test on the labels, IT FINALLY WORKS! I did have to make sure none of the "Print Consignee Label/Freight Label" boxes were checked and that solved the 2 labels being printed.

    Don't know if this will work for you or not, hopefully it wasn't a fluke and it will work for others as well. Good Luck and hope you have some patience to work through the frustration you are bound to go through on this.
      My Computer

Page 4 of 6 FirstFirst ... 23456 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:17.
Find Us