Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Emperor: Battle for Dune Multi unit Lag

01 Mar 2010   #1
Bojazz

Windows 7 Ultimate
 
 
Emperor: Battle for Dune Multi unit Lag

Kay so this topic has been on a few other forums around the internet but I haven't been able to find a solution for it.

The Problem:
Emperor: Battle for Dune installs and runs fine on windows 7 machines, until you select multiple units. For some reason this causes intense video lag, and then hyper speed until the game returns to the time it should be at.


The following fixes do not work:
-Adjusting in-game graphics settings (including v-sync)
-Running in compatability modes or as admin
-disabling secondary monitors
-updating graphics card drivers
-changing to single core mode using affinity in the task manager
-re-installing the game
-running from CD or ISO on virtual machine

Machine:
According to other forums this problem occurs across all types of machines, the common factor seeming to be Nvidia graphics cards. But for argument's sake I'll post my specs.

L1N64-SLI WS Mobo
2x Athlon 6x fx dual core (socket L1)
8gb Crucial Ram 800 mhz
BFG 8800 GTX water cooled edition
1000 watt OCZ PSU
400 gb seagate sata HDD
G15 Gaming keyboard
Razer Lachesis
Dual Monitor (20" Crt/22" LCD)

If anyone can conjure up a fix for this I'd be greatly appreciative.


My System SpecsSystem Spec
.
03 Mar 2010   #2
Bojazz

Windows 7 Ultimate
 
 

Bump
My System SpecsSystem Spec
16 Mar 2010   #3
Torgo

Windows 7 x64
 
 

It worked for me, brand new out-of-the-box laptop with an ATI card. I installed E:BfD and started the Ordos campaign today, no problem selecting a large number of units. Didn't run in compatibility mode, just installed off CD#1 and played campaign off CD#4.

Maybe this is an nvidia issue as you suggest. Did you test it in all play modes (CPU skirmish/campaign/multiplayer)? I dunno, just thinking out loud...

Here is my system specs if it helps since I haven't (yet) done any modifications:
Newegg.com - ASUS K70 Series K72JR-X1 NoteBook Intel Core i5 430M(2.26GHz) 17.3" 4GB Memory DDR3 1066 500GB HDD 7200rpm DVD Super Multi ATI Mobility Radeon HD 5470 - Laptops / Notebooks

Also, have you tried installing it on an alternate OS? Ubuntu is a quick setup, just get the wine package and then install Emperor. Apparently it's well supported:
http://appdb.winehq.org/objectManage...rsion&iId=4179
My System SpecsSystem Spec
.

17 Mar 2010   #4
Bojazz

Windows 7 Ultimate
 
 

I've tried all gameplay modes with no change and it works fine with Nvidia cards on XP sp2 and 3. It just seems that Windows 7 + Nvidia cards causes this rather strange problem.

Your idea of alternate OS install would definitely work, but I'd rather not have to dual boot for one game.
Thanks for the input though, every bit of info helps.
My System SpecsSystem Spec
17 Mar 2010   #5
Frostmourne

Windows 7 Ultimate x86-64
 
 

Update your keyboard and mouse drivers, uninstall any codec packs on your PC and media players too (apart from WMP). Update DirectX.
My System SpecsSystem Spec
18 Mar 2010   #6
Bojazz

Windows 7 Ultimate
 
 

It was a fresh install of 7 so I had installed the latest drivers for all my hardware about two days prior, I've loaded no codec packs and Direct X is the most recent version. Problem persists.
My System SpecsSystem Spec
22 Mar 2010   #7
Torgo

Windows 7 x64
 
 

If you really want it working, try a dual boot setup just for diagnosis. If it works under your alternate operating system then you know the culprit.
My System SpecsSystem Spec
23 Mar 2010   #8
Bojazz

Windows 7 Ultimate
 
 

I already know it works on alternate OSes. As my original post states this only seems to happen on Windows 7 machines with Nvidia graphics cards, hence posting the problem on the windows 7 forums.

As I have also stated in a previous post I'd rather not have to dual boot for one game.
My System SpecsSystem Spec
23 Mar 2010   #9
Torgo

Windows 7 x64
 
 

Yes, you said it works on different machines, but not on a different OS on your particular machine. Since it works perfectly on mine as well as other people I've talked to that run Windows 7 with nvidia, there may be something specific to certain machines rather than an operation system issue. I know you'd rather not dual-boot but it might be the best way to diagnose this. Who knows, you might find you prefer a linux-based operating system...

Just trying to help. No need to flip out.
My System SpecsSystem Spec
24 Mar 2010   #10
Bojazz

Windows 7 Ultimate
 
 

First off - not flipping out

Secondly - The game ran fine on both XP and Vista with no hardware changes. As afore mentioned other forums around are posting the same problem with the apparent common factor being Nvidia cards and Windows 7.

You can check out the dune 2k forums for more info.
Linkage - Old problem with Emperor on Windows 7
My System SpecsSystem Spec
Reply

 Emperor: Battle for Dune Multi unit Lag




Thread Tools




Similar help and support threads
Thread Forum
Multi-Boot & Multi-Harddrive booting
OK. My computer multi-boots to Windows 7 & 8 right now. 8 is on an SSD. I am thinking about adding another HDD, moving 8 to the new HDD, and installing Windows 10 onto the SSD. If I disconnect the drives with 7 & 8 during the install, then add them to the boot menu after, can I make the...
Installation & Setup
boot from usb. bios old unit.
Hi there. I need to boot from a usb stick but the old .laptop hasn't got this option in the boot order. Is there a way of making this possible. Many thanks
General Discussion
Power Unit upgrade
I'm upgrading my power unit this Friday when I head to Fry's Electronics and am looking for recommendations as to what I should look for. I already know I'm looking for 80+ certification so I won't have to worry about under-wattage killing my current one since it doesn't have under-wattage...
Hardware & Devices
Multi-Machine, Multi-License?
I would like to purchase a full version of Windows 7 Home Premium (not an upgrade) and install it on two different machines. Is this possible or do I need to buy 2 full copies of Windows 7? Can I just buy the one copy and get like a multi-license? Amazon sells Windows 7 Family Pacs for but it's...
Windows Updates & Activation
multi users, multi ini files
Hi, I have a series of applications that depend on an INI file being in the Windows directory. Also, many diffeent users are allowed to log on and change the INI file. But Windows 7 places changed INI files in USER directories for the logged-on users. So my Apps never get to see the...
General Discussion
Win 7 upgrade on another unit
Can you use Win 7 upgrade on another computer on the same In Home network or do I have to buy another box?
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App