Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Installer - Simple Fix that worked for me.

25 Apr 2011   #1

Window 7 Professional
Windows Installer - Simple Fix that worked for me.

All the complicated fixes I've tried even those from Microsoft did not work. This one below work perfectly tor epair Windows Installer issues:

HERE IS THE FIX THAT WORKED FOR ME : Start, then Run, then type regedit Go to HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROL SET\SERVICES\MSIserver\WOW64 Right click on WOW64, then select Modify Set Value Data to 0 (mine was set at 1) and Base should be Hexadecimal Close everything, reboot, and see if you can uninstall or reinstall.

My System SpecsSystem Spec
26 Apr 2011   #2

Windows 7 Ultimate RTM (Technet)

You say this is a fix, but for what problem?
My System SpecsSystem Spec
26 Apr 2011   #3

MS Windows 8

its a problem for Error code 1719 “The Windows Installer service could not be accessed, the Windows Installer is not correctly installed”
My System SpecsSystem Spec

27 Apr 2011   #4

Window 7 Professional
Windows Installer Fix

I backracked and checked my browser history and hidden Microsoft Updates that I could not perform as well as the software I was able to install yesterday and the problems were 1) unable to install updates to the Security Update for Visual C++ 2008 Service pack 1 Redistributable, 2) unable to install updates to the Security Update for Visual C++ 2005 Service pack 1 Redistributable, 3) unable to install NitroPDF, pdf editor, 4) was unable to update AVG antivirus, 5) was unable to update the Windows Installer to version 4.5.

I tried the msconfig way, uninstalling and reinstalling the Windows Installer but couldn't uninstall it with the common error below, and as I was going to give up for another wekk or two I came across this fix on this site at:

Windows Installer - Simple Fix that worked for me.

In tracing through my browser history one error was

"Error 0xc0070643"

and another one I was looking up was the common

"The Windows Installer Service could not be accessed. This can occur if running
Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance."

I was so excited after searching for weeks trying to find a fix for these Windows Installer problems that I threw away my notes and just kept the fix stored in a txt file. I have no idea what the fix meant, was desparate to try anything and even contemplated a reinstall. Glad I didn't give up.
My System SpecsSystem Spec
27 Apr 2011   #5

Windows 7 Ultimate RTM (Technet)

Never heard of the issue (nor the word "backracked") but glad you solved your problem.
My System SpecsSystem Spec
26 Jul 2011   #6

Windows 7_64 bit
It worked for me!

CDMJ: Thank you, thank you, thank you....

I spent about 4 hours yesterday on the Microsoft website going from page to page. I tried utility tools, patch repairs, and restarted my computer I don't remember how many times. STILL, could not get Microsoft to install it's own security patch! Couldn't install Nitro .pdf either.

I found your suggestion, tried it, and lo and behold, it worked. I don't know what I would have done if I hadn't found your comments. Oh, well I guess I'd still be caught in Microsoft h*ll. Thanks to you and all the kind souls that take the time to report this stuff.
My System SpecsSystem Spec
27 Jul 2011   #7

windows xp
Also it worked for me !!!!

Thank you very much for this solution.

My head was almost broken trying to fix the error, but I found this post and .... voila !!!! Problem solved !!!!!!

Best regards.

My System SpecsSystem Spec
30 Sep 2011   #8

Windows 7 Ultimate

I have no WOW64 or WOW32 in that string of my registry. Win7 Ultimate 32.
My System SpecsSystem Spec
24 Nov 2011   #9

Windows 7 32bits

Merci beaucoup ça marche nickel.
Thank you very much. It works fine
My System SpecsSystem Spec

 Windows Installer - Simple Fix that worked for me.

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Ultimate system restore has NEVER worked.
I have had two separate computers with two separate o/s systems using Windows 7 ultimate, one installed directly from discs, one upgraded from Windows Home Premium. The restore has never worked on either of them. Another friend who has the same system has the same problem. It does work (or at...
Backup and Restore
Deleting of Windows Installer Cache (C:\Windows\Installer\) Files
Windows Installer Cache, the c:\windows\installer folder by default, is used to store important files for applications installed using the MSI Windows Installer technology and should not be deleted manually. More...
Windows 7 would not boot and tried everything (worked for me!!)
So the other night, I was working on a PS3 problem and had several tabs open on my windows 7 computer, but had not touched anything for a while. I was taking a hard drive out of my laptop and installing in my other laptop (again not touching my desktop) when it suddenly shut down without warning. ...
BSOD Help and Support
Help debugging simple .bat that worked on XP
Hello, I have a backup .bat that I have hobbled together from forums such as this. The original was made a few years ago. It worked flawlessly, until I brought it to windows 7. Very funny, now, it only works between 10am and midnight. This has been hell to figure out because sometimes it works...
General Discussion
Realtek Drivers Windows 7 (FIX) - worked for me
in Windows 7 Realtek HD Audio Drivers and instal K-Lite Codec Pack nothing more and my audio are fixed for now :)
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:20.
Twitter Facebook Google+