Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How to change Win 7 folder permissions on a linux PC?

07 Sep 2015   #11

Windows 7 Ultimate x64 SP1

You shouldn't be needing Linux to make a Win7 drive readable. If that is what you need, change ownership of Win7 partition to your Win10 account. And add it to NTFS permissions as well. Most similar cases I have seen here are old WinXP partitions unreadable under 7.

What I have proposed earlier was an attempt at making Win7 bootable.

My System SpecsSystem Spec
07 Sep 2015   #12


GokAy, Yes the goal is to get it back it is bootable state.
Your option 1 was system restore from 10 - I can try that I guess - that should not put too much ripples in Win 7 drive.

Your option 2 is what I have seriously resisted doing until I get an image of the drive before further work on it, just in case it introduces too many variable. I will do that, do you think that would work? I wont be able to try that today but I will try and report back.

I have not lost any data as my data is on another drive - so thank you for all suggesting accessing data from Linux.
My System SpecsSystem Spec
07 Sep 2015   #13

Windows 7 Ultimate x64 SP1

I don't know if it will work, but hope it will :) in my own win 7 and 10 dual boot system I remove the drive letter for the other OS when booted with one just to avoid similar problems.
My System SpecsSystem Spec

13 Sep 2015   #14


OK update on the status:

Gokay, First I tried setting permissions from win 10 win explorer, right click drive, security tab, add user - this throw up errors on some file/folders and it wouldnt complete having gone through a number of files and folders.

So next elevated command prompt in 10, using CACLS command I gave admin rights to the entire C drive, User folder and system32 folder, next reboot it was accessible in win 10 and all the files were there intact however, booting the win 7 drive up I still get the same black screen of death with mouse - so one step closer, drive now accessible but still no boot.

From attached photo you can see my E: data drive which used to host the My Doc, Music, Photos for my win 7. When for the first time accessed these folders in Win 10, I got the same prompt ' you havent got access, click OK to get permanent access' I OKed it and I have access to them (The whole problem started when I did the same on my Win 7' User' folder). Now in attached, the accessed E:\My Music security properties (on the right) now shows an unknown account which must be my Win 7 account (win 10 & 7 both have the same computer name and users). My Q: drive which is the old win 7 drive' security properties show only permissions for win 10 users and the actual Allow column is greyed out?
I am thinking if I manage to add the unknown security account ti Q drive then win 7 may boot? I am not sure and certainly dont know how to do that not knowing where that account is kept on win 7 files and guessing it is deep within a system file anyway so it may not be possible, maybe there is a way to export?


Attached Thumbnails
How to change Win 7 folder permissions on a linux PC?-slide1.jpg   How to change Win 7 folder permissions on a linux PC?-slide2.jpg  
My System SpecsSystem Spec
13 Sep 2015   #15

Windows 7 Ultimate x64 SP1

I don't know of any method to change permissions to an unknown security principal/group.

Those S-1-5-21-### are Windows 7 SIDs (Security IDs, your accounts, administrator, guest etc)

Having extra unknown SIDs in the security list shouldn't cause your issue but who knows. Did you try adding Everyone with Full Control to Win7 OS drive yet? (I don't know if this would make it bootable again).

Did you try a startup repair yet? Startup Repair
My System SpecsSystem Spec
19 Sep 2015   #16



Sorry for the delay in responding.

I have now managed to remove all the other number type users from the drive security tab. This was done again by running the CACLS commands to grant everyone full rights including C: C:\Users and C:windows System32 and then after a reboot, changing the permissions to the default. This was done in elevated Command Prompt in win 10.

I have now full access to the drive, the security tab only shows the right people i.e. system, Sean, Admins. it looks as per other drives that are OK. BUT, still I have the same BlackSD with mouse, still no boot!

Yes I have tried system repairs of all kinds to no avail.
My System SpecsSystem Spec
19 Sep 2015   #17


Hi guys and sorry for the delay in responding.

I have a bit of an update. I have managed to get access to the drive content now but still cannot boot in to windows 7.

I got access to the drive by resetting the permissions for c:, user, system32, windows and then setting the default permissions. This has now given me the rights to access it in win 10 or other windows as a second drive but still no boot and still black screen of death with mouse.

Now I am trying to find out how to boot it. And yes have tried all the repair and safe modes but they all result in the same thing.

Thanks for all your suggestions.

My System SpecsSystem Spec
19 Sep 2015   #18

Windows 7 Ultimate x64 SP1

Problem is even Safe Mode is like this.

Hmm, just searched once more, here is an interesting fix. Though there are lots to try in this link:
black screen with cursor only [Solved] - Cursor - Windows 7
My System SpecsSystem Spec
20 Sep 2015   #19


Almost - got sticky keys up but as in the thread, I dont get a link to Ease of access and the thread trail ends there, same with in key + U... interesting angle though.
BTW my Safe Mode goes as fare as the list of all the drivers etc it loads and it hangs somewhere in there and never gets to boot in to the black screen. It seems to be a hard crash as every time there is a horizontal line that appears at the very top of the screen - the type that has multi colour pixels. Like if you have a faulty video card but I havent got a faulty video card as it is working perfectly fine in 10, never had an issue. I dont think the video drivers would would suddenly play up either.

Previously the win 7 drive was not even accessible in win 10. With the sticky key experiment I am convinced of the following:
  • While in black screen, Windows has just started
  • it cannot find/correlate users so cannot even see/recognise the available profiles to show a login screen
  • I dont think Windows in its early boot part is able to run something in its Start up folder and I dont know any other way to get a utility to run when it goes in the black screen
My System SpecsSystem Spec
20 Sep 2015   #20

Windows 7 Ultimate x64 SP1

Hmm, if you can get the Ease of Access window then the login screen may be there, just not showing. Lets try a blind log in?

Start the PC and wait, say, 5 minutes. (Don't click or type anything). Then type your password and press ENTER. Lets see if it will get you to desktop.

Can you get to recovery environment (Repair Disk or Installation Disk) or was it black screen as well?
My System SpecsSystem Spec

 How to change Win 7 folder permissions on a linux PC?

Thread Tools

Similar help and support threads
Thread Forum
Bulk Change All Folder Icons in Single Folder or Folder Type
First, please forgive me if I have overlooked this issue in the many searches I have performed thus far. I would like to know if anyone has a way to change all folder icons within a single folder to one specific icon without performing each one individually. I have over 1,400 folders within a...
Network permissions for a folder inside already shared folder?
Hello, I'd like to edit network permissions for one of the folders inside a shared folder. I don't want to specifically share that folder on it's own, I like that it belongs inside existing shared folder already. I've disabled Share Wizard, and I can only edit it's settings if I share it on it's...
Network & Sharing
Cannot take ownership/cannot change permissions for windows folder
Hello all! All this started when I just wanted to change the way the clock looked to a custom one. I go to the Windows Sidebar folder to locate the Gadgets folder for the clocks, and I try to make backups of a few of the files in the clocks folder by moving some of them to a new folder I...
General Discussion
Easy change back folder & file permissions
I've made a complete mess of My Pictures folder and files. What I did: logged in as non admin user, right clicked Picures folder, then Properties, then Security tab. With Authenticated users selected clicked Edit next to change permissions. Gave admin password, then clicked Full control Deny...
System Security
Where Permissions Change
Ok, so I activated my built-in admin account hoping that I would be able to change the permissions to my actual account (also an admin.) I had the beta of W7 and when my friend installed the Home Premium version to my laptop, he changed my name. Not a problem until I tried to access my old...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:47.
Twitter Facebook Google+