Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: RC1 - "COM Surrogate Has Stopped Working"

11 May 2009   #1
meast

Win7 Build 7022
 
 
RC1 - "COM Surrogate Has Stopped Working"

So I just upgraded the 7022 build of W7 I've been running successfully for months to the new RC1 build and now a hundred times a day, I get an annoying error that says "COM Surrogate Has Stopped Working". I click OK and it goes away but it's pretty annoying. Doesn't seem to be any pattern as to when it pops up, either.

Anyone experiencing the same thing?


My System SpecsSystem Spec
.
10 Aug 2009   #2
ShadoDragon

Windows 7
 
 

I see the same thing. It generally happens when I go into a folder with large Video files in it.

After this happnes for me, Explorer crashes as well
My System SpecsSystem Spec
10 Aug 2009   #3
Kari

 

Googling your issue brought me here.

Google +1

Kari
My System SpecsSystem Spec
.

10 Aug 2009   #4
ShadoDragon

Windows 7
 
 
Nero and COM Surrogate crashing

I found a post that seems to outline the problem. It says the Nero can cause the problem. I uninstalled Nero and the problem seems to have gone away
My System SpecsSystem Spec
10 Aug 2009   #5
Kari

 

Quote   Quote: Originally Posted by ShadoDragon View Post
I found a post that seems to outline the problem. It says the Nero can cause the problem. I uninstalled Nero and the problem seems to have gone away
That's precisely what the link I found says.

Kari
My System SpecsSystem Spec
18 Nov 2009   #6
mbills

windows 7
 
 
Explore crashing and Comm Surragate crashes

well I was reading here that folks where having the same issue as I am and had Nero. I don't have Nero. I also noted that folks were having an issue such as the one I've stated when browsing folders that contained large video files. The folders I was browsing were solely folders containing photographs. Suggestions?
My System SpecsSystem Spec
30 Dec 2009   #7
Archedian

Windows 7 Ultimate 64bit
 
 

Same exact problem as "mbills", i do not have nero on my computer either. Tho when i go into my pictures and i click on a few pictures to view them, within the first 10 pictures i click on i will get the COM Surrogate has stopped working message. Not long after you could almost set your watch by it, within the next few clicks or sometimes just random right clicking on the desktop will cause Explorer.exe to crash.
My System SpecsSystem Spec
26 Sep 2010   #8
Opi8

Windows 7 Ultimate x64
 
 

I too have had this problem occur. It's only begun to happen today, I am almost positive it has to do with me doing a disk cleanup and deleting Thumbnails (says windows automatically keeps a copy of all the thumbnails, if you delete them it will recreate as needed. I figured this was okay to delete, as from what it said I assume that it simply shows thumbnails that you try to view, and any that are part of old files that I don't view anymore will remain deleted and save some space).
So, should I bother taking any steps towards fixing this, or will it eventually occur less and less as I view more of the files that I have deleted the thumbnails for? If so, than would it possibly help to highlight all the pictures I have (only things it's occurred for so far) and open all at once, so that it loads all the thumbnails? I'm not entirely sure how it works, someone please let me know if it will either eventually fix itself, or if I should do a system restore or use another method of fixing (system restore won't be much of a problem as I made a sys restore point last night, but if I can just leave it as is and it will fix itself as files are viewed, than that's best)
My System SpecsSystem Spec
06 Dec 2012   #9
Majestic One

Windows 7 x64 Ultimate
 
 

1] folder with many large video files (am watching Dark Angel TV series (folder open))
2] Nero 11 installed - gonna try 12 platinum (got it the other day)

good enough for me!
Thank you folks
My System SpecsSystem Spec
06 Dec 2012   #10
alikhan

Windows 7 Ultimate x64
 
 

I' suggest going through this article , one of the mentioned fixes might worked for you guys .

TechTips - How to Fix the 'COM Surrogate Has Stopped Working' Error - Yahoo! Voices - voices.yahoo.com
My System SpecsSystem Spec
Reply

 RC1 - "COM Surrogate Has Stopped Working"




Thread Tools




Similar help and support threads
Thread Forum
"COM Surrogate has stopped working" malware/virus??
How to get rid of this malware?
General Discussion
"Com Surrogate Has Stopped Working" - Windows 7 Ultimate x32
A few months back I received an error message caused by an act that I can no longer recall. Ever since that day I have encountered hundreds of the same message and a few others every day, prohibiting me from playing games and using programs. During these months, I have read every forum, read...
General Discussion
"Windows Module Installer has stopped working" message constantly
Hi there, I am getting a repeated "Windows Module Installer has stopped working" message which says that the file that describes the problem is: C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_TrustedInstaller_5480538538f23ac44dfcd994b3e5d340663098_cab_670b9c43\WER9B8A.tmp.hdmp. ...
Windows Updates & Activation
"Windows Control Panel has stopped working" on My Computer Properties
Hi I am running Windows 7 Pro 64-bit on a Lenovo T510. Every single time I do a Properties on My Computer, I get this pop up message that "Windows Control Panel has stopped working". Oddly, I just cancel that window and everything otherwise seems to work normally. But it happens every time...
General Discussion
"has stopped working" on starting apps ;can't install SF Diagnost Tool
Since yesterday when I try to launch several applications they don't work and show "... has stopped working" error message. They had been working perfectly before. I didn't change or install anything. They just stopped working. So far I found these apps not working: DS3_Tool.exe...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App