Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Printer Not Showing Up in Devices and Printers

04 Mar 2014   #11

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Open Device Manager,
press alt to expose the menu bar (if not already present)
Click the View menu
Click Show Hidden Devices

Is / are your printer(s) displayed?

Yes - please post a screen shot of the tabs
See: Screenshots and Files - Upload and Post in Seven Forums

Also try printing a web page in IE to an the XMS Document writer

edit begin

Please also post a screen shot of Devices and Printers

Did you happen to run a registry cleaner or system "tune up" utility? - these are known to corrupt systems.

Do you have Citrix on your system?

Can you stop and restart Start the Bluetooth service.
1) Open Services
2) Scroll down to and select / highlight Bluetooth Support Service
3) Double click and check if startup type = Automatic (change if other type and click Apply)
4) Click Stop the service in the upper left area of the window
5) Restart your machine

Try: MS Printer Trouble shooter (immediate download)

Look in Event Viewer for Error and Warning events.
edit end

My System SpecsSystem Spec
05 Mar 2014   #12

Windows 7 Home Premium x64

I can report some success! At last I can print web pages; however, still nothing showing up in Devices and Printers. That's OK, I'm happy with that.

I believe the partial correction is simply due to uninstalling and reinstalling the printer drivers. But yes, I had done that at least twice before without result.

Slartybart, I'll follow up with your suggestion over the next few days but it will take me a bit of time to get the screen-prints organized (got a bit on my plate right now).

For info, the printer is not displayed in Device Manager (Hidden Devices shown) and the 'Devices and Printers' is a blank page with "0 items" shown on the bottom left of the window.

I have in the past used CC Cleaner but not recently - discontinued sing it following advice from friends. I do not have Citrix on my PC. Also, I have tried the "Bluetooth" thing to no avail.

MS Troubleshooter does not identify any problem.
My System SpecsSystem Spec
05 Mar 2014   #13

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Thanks for the good news and great feedback.

I noticed on the Brother pages that Win8 had references to Devices and Printers, but Win7 only had references to Device Manager. Doesn't make much sense, but who knows what Brother coded specific to an OS.

This is indeed a sticky wicket. I think your solution of uninstalling and reinstalling was heading in the correct direction. You've taken some action in this thread that probably changed the outcome of your previous uninstall / reinstall.

I was going to regroup and suggest that all printers be uninstalled, followed by some cleanup and then connect (not install) the printers, one-by-one - checking the Devices and Printers as well as Device Manager.

I'll wait until I see what you see (screenshots)

cCleaner is generally a safe tool, it is not very aggressive in cleaning the registry (errs on the side of caution). Still, any operation on the registry can negatively affect a system.

Thanks for trying the suggestions, sorry that you still can't see printers in Devices and Printers.

Do you know which step allowed you to print Web pages? That might help other members - they won't have to use the shotgun approach :)

My System SpecsSystem Spec

05 Mar 2014   #14
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I have never had a printer that would print that didn't show up in Devices and Printer.
I have always had devices show up in Devices and Printers.

Could you do this tutorial by Brink.
It might help understand the problem.
Just post as the tutorial instructs.

Windows Genuine and Activation Issue Posting Instructions
My System SpecsSystem Spec
06 Mar 2014   #15

Windows 7 Home Premium x64

Hi Guys,

Delving into the unknown (for me), attempting to upload the screenshots you requested. Hope it works!

Printer Not Showing Up in Devices and Printers-dm1.jpg

Printer Not Showing Up in Devices and Printers-dm2.jpg

Printer Not Showing Up in Devices and Printers-d-p.jpg

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->
Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-G92TK-H9977-VJVG3
Windows Product Key Hash: S4TICxcrxNXb54J/Q7kFEnZawCE=
Windows Product ID: 00359-OEM-8703262-20515
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {A28406AC-772B-4955-A2E1-682BAA62FDAB}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.130828-1532
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A
Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002
OGA Data-->
Office Status: 100 Genuine
Microsoft Office Home and Student 2007 - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-b01a_E2AD56EA-766-0_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{A28406AC-772B-4955-A2E1-682BAA62FDAB}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-VJVG3</PKey><PID>00359-OEM-8703262-20515</PID><PIDType>3</PIDType><SID>S-1-5-21-759514354-3991410152-1130044811</SID><SYSTEM><Manufacturer>Gigabyte Technology Co., Ltd.</Manufacturer><Model>X58A-UD3R</Model></SYSTEM><BIOS><Manufacturer>Award Software International, Inc.</Manufacturer><Version>FB</Version><SMBIOSVersion major="2" minor="4"/><Date>20100824000000.000000+000</Date></BIOS><HWID>81BF3007018400FE</HWID><UserLCID>0C09</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>AUS Eastern Standard Time(GMT+10:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{91120000-002F-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Home and Student 2007</Name><Ver>12</Ver><Val>327A3C59C0C3F34</Val><Hash>iFbCR8AeTzYwq4uxC47+ozPMUC0=</Hash><Pid>81602-922-8347661-68165</Pid><PidType>1</PidType></Product></Products><Applications><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/><App Id="A1" Version="12" Result="100"/></Applications></Office></Software></GenuineResults> 
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7601.17514
Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: 586bc076-c93d-429a-afe5-a69fbc644e88
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00174-032-620515-02-3081-7600.0000-3402010
Installation ID: 003565332956252321876642257341175171278623893610027891
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: VJVG3
License Status: Licensed
Remaining Windows rearm count: 4
Trusted time: 6/03/2014 8:00:28 PM
Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 2:19:2014 13:01
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:
HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information: 
ACPI Table Name OEMID Value OEMTableID Value

My System SpecsSystem Spec
06 Mar 2014   #16
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Knowing more about your system would be helpful also.
Use these two tutorials.
Look at my specs they should give you a idea.

I have requested some friends to take a look at your log.
They live in different parts of the world so it might take just a little while. Hang in there.

By Brink:

System Info - See Your System Specs

By Kari:

Speccy - Publish Snapshot of your System Specs

Are you sure when you are in Device Manager you go to View and select
Show Hidden Devices?

Printer Not Showing Up in Devices and Printers-device-manger-today.png

My System SpecsSystem Spec
06 Mar 2014   #17
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

My friend looked at your Dia log and it looks fine.
I have been doing some more research and found a couple of things.

***In Services

Print Spooler is set to auto.

start Bluetooth services (and set it to automatic
) (All of them)

Then reboot and check setting again.
My System SpecsSystem Spec
06 Mar 2014   #18

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Agree with Layback Bear. Setting the "Bluetooth Support Service" to automatic in Services solved this issue for other people in the Forum.
My System SpecsSystem Spec
06 Mar 2014   #19

Windows 7 Home Premium x64

Thanks All for your continued help. This is an education for me.

OK. My screenshot of Device Manager is shown in "Show Hidden Devices" mode. Although not shown in the screenshot I have previously expanded all device lists and can find no reference to 'Printer' in any sub-list.

Bluetooth services is set to start/auto and Print Spooler the same. I have stopped and restarted both and ensured set to auto and rebooted but this has no effect.

I'll post details of my system later today.
My System SpecsSystem Spec
06 Mar 2014   #20
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Not only set to auto but also check to see if they are started after a restart.
My System SpecsSystem Spec

 Printer Not Showing Up in Devices and Printers

Thread Tools

Similar help and support threads
Thread Forum
Devices and Printers only showing physical printers
As the title says, I have a user's machine here that is displaying some weird behavior. There are multiple printer driver's installed, but only a single HP printer is showing up in Devices and Printers. Printmanagement.msc shows a single printer, but 5 drivers (including PDF, OneNote, etc.). No...
Hardware & Devices
Printers not showing up in Devices and Printers
This is the second time I have had this problem and I cannot remember what I did to fix it the last time. I have been searching for the last couple of hours and nothing is working. When I try to print I get the message that no printers are installed. What I have tried: Found print...
Hardware & Devices
Devices and Printers not showing up
I downloaded the latest Windows update just a bit ago. When the comp rebooted I had an Adobe Flash update (which I installed). Rebooted, then opened Word to print out a document and it couldn't locate any printers. Tried to "Add printer" and got the error "The Active Directory Domain Services is...
Hardware & Devices
No items showing in Devices and Printers
I've been having this problem for a while now and it's only a issue now because I have printer issues. I'm running Win 7 Pro 64bit. Every time I bring up the Devices and Printers windows either through the Windows Icon on taskbar or Control Panel, it scans forever until I close the widow never...
Hardware & Devices
No devices or printers showing in Device and printers
I've got an HP 8440p which has a Window 7 32 bit build. It's not showing anything in Devices and printers. I'm unable to get any answer other than rebuild from my fellows techs. I'm hoping someone out there has a better fix. Thanks...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:49.
Twitter Facebook Google+