Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Second Hard Drive Not Appearing in Explorer

17 Dec 2014   #11

Windows 7 Home Premium x64

You're welcome, but let's see what we can do further. :)
Try this:
1. retype in Diskpart everything till you get the message
2. after you get it, type "disk online"
3. you should see a confirming message that Disk 1 is online
4. check again with list disk

Then see how the drive is showing up in Disk Management and please post a screenshot!


Edit: It shouldn't be that big of a difference the mode in which you're running, but updating drivers always helps!

My System SpecsSystem Spec
17 Dec 2014   #12

Win 7 Pro x32

Again Thanks

Still Offline.

Re Pics: Just realized the old ScreenGrab program I'm using (have source) won't save in JPG only BMP.
Never realized this forum (fairly new to it) would not accept BMP.
Will have to rewrite code to save in JPG, which is another thing ToDo.

If you can bear with me without pics, I'll see if their is a new driver and install it and see what happens.
unless you have a better suggestion.

Will try driver upgrade.
My System SpecsSystem Spec
17 Dec 2014   #13

Windows 7 Home Premium x64

Hmm, this is kind of strange, the diskpart method with the additional information I gave in a second post should have worked.

Well, do try with updating drivers and then you can do a System restore to a point/date you know that everything was fine.

One more thing, what does the drive show you in BIOS?

My System SpecsSystem Spec

17 Dec 2014   #14

Win 7 Pro x32

Tried to Upgrade Driver. M$ says it is the latest.

Where do we go from here??
I need to take a break for about 1/2 an hour as reached my frustration level.

Will post BIOS info then since I will have to reboot. But based on
what I recall it shows just the WD drive model for each drive.
If designated UEFI that is appended in front.
As I posted previous, configured the IDE drive for legacy, but
had the same issues when designated UEFI.

This is a new American Megatrends BIOS which I dislike tremendously.
Has a GUI interface which is very busy (whoever designed forgot the KISS method)
Will take the old keyboard BIOS any day over it.

Thanks for all your efforts and time on my behalf.
Will check in, in 1/2 hour and see if you have the time to assist with anything additional.
If not, have an nice day and Happy Holidays to you and yours.

My System SpecsSystem Spec
17 Dec 2014   #15

Windows 7 Home Premium x64

David, I understand your frustration, I will have to do some research on this issue so that I can help you further. If I am not present in a half an hour I shall post back in a few hours, but I will be back. :)

Meanwhile, yes, post your BIOS information on the drives you have and how they're displayed, convert the images (if you can and have the time, of course) to post them here and after all, try and do the System Restore. It is a good last resort that not many people, facing PC problems, think of.

Cheers and happy holidays from me too! :)

My System SpecsSystem Spec
17 Dec 2014   #16

Win 7 Pro x32


Thanks for staying with me.
Like yourself have some errands to run and want to check with someone who may have some input.

do the System Restore
The problem with that is this is a brand new build. About 4 days old.
After about 2 days of effort was finally able to copy the IDE drive (which I'm trying to access now) to the new hard drive and install windows 7. I had Windows 7 on the old machine and the IDE drive but M$ (as far as I understand) makes no provisions for updating All new hardware. So I copied both partitions on the IDE to the new WD Sata and installed Windows.
That worked. I then started reinstalling my old software. I have a number of programs I wrote which I use daily and ran into some problems with them working. Again an M$ problems. Finally got all those up and running and then one of my databases (which is ACCESS and which worked fine for years) had me locked out (a key shows on the DB name in Explorer). So figured if I could see what differences if any between files on the old drive and the new I might get it resolved.. Now problems getting to that drive.

Will probably move to SQLite if I can get this database up and going. ACCESS has worked great for me for years but M$ seems to be deprecating everything that I used and I'm getting tired of looking into a black box and guessing what I need to do to fix it.


So confused over what the BIOS is doing versus Windows 7.
The new American Megatrend BIOS has something called a CSM (Compatibilty and Support Module).
However this does NOT apply to each drive individually BUT rather the setting are for a grouping.
E.G> Boot Devices, Storage Devices, Network Devices, etc.
You then have a choice to set each group to Legacy, UEFI (if I remember the term correctly), or some combination thereof.

Why they didn't let you set compability for each drive is beyond me.

How this affects each drive is unknown and what impact it has on the OS is also unknown at this time.
My guess is it set some flag in the BIOS which Windows uses to set the security level (maybe the MBR or some Windows driver during load).

I do know when I was able to transfer the drive I finally got it to work with a Legacy setting. Wrote all the specifics down so can post if needed.

I'll be back in about 4 hours (I'm on Mountain Standard Time). Will check my email for your post and hopefully we can exchange info then or sometime shortly later.

My System SpecsSystem Spec
17 Dec 2014   #17
Wandering one

Win7 sp1 Pro 64bit / XP sp2 Pro (games only)

To the O/P Regarding screen shots. W7 has this built in, go programs / accessories / snipping tool . Easy to use and saves as JPEG Art.
My System SpecsSystem Spec
17 Dec 2014   #18

Win 7 Pro x32

Wandering one:

Great suggestion, was NOT aware of it. Again thanks.

My System SpecsSystem Spec
18 Dec 2014   #19

Windows 7 Home Premium x64

Hi David!

Sorry for the delay!

I have to admit that new ideas are not quite coming to me.
It looks like you are also having a lot of trouble with the OS.

I may repeat myself, sorry for that, but I think you need to connect your drive in the motherboard directly through an IDE to SATA, but not USB powered. I don't believe we have proof that the USBs are working correctly either, though it seems they have all of their latest drivers.
For a drive to show Ofline, it usually is a Dynamic disk. MS Press Windows 7 Inside/Out says the "Offline" status only appears on such Dynamic disks. It also has been seen a lot with external drives, that's why I suggested you connecting it with the adapter in the motherboard. It is possible, just instead of the USB connection you use the motherboard ports directly with an IDE to SATA adapter.
The ways to reactivate such an Offline drive is by either right clicking on it in Disk Management and selecting Online/Reactivate, or through the diskpart commands I gave here in two posts.
This is an important line from a short article on the topic: "A dynamic disk may become Offline if it is corrupted or intermittently unavailable. A dynamic disk may also become Offline if you attempt to import a foreign (dynamic) disk and the import fails. Only dynamic disks display the Offline status."

Reactivate a missing or offline dynamic disk: Storage Services; Local File Systems

You could also try running these action in UEFI, since in Legacy mode it didn't work. But in my opinion, the most important is to connect the drive directly. You could even first try it on a different PC, see if it will work.

I am sorry for repeating myself, but there really aren't other options as this is when a disk becomes Offline and that is how it should be fixed.

Good luck!


P.S.: Yes, the Snipping Tools is quite useful, I too forgot about it. You could use it.
My System SpecsSystem Spec
18 Dec 2014   #20
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

These tutorial should help.

By Brink:
Screenshots and Files - Upload and Post in Seven Forums

By Golden:

Disk Management - Post a Screen Capture Image


These two tutorial will help you fill in your system specs so these good folks trying to help you know what they are working with.By Brink:

System Info - See Your System Specs

By Kari:

Speccy - Publish Snapshot of your System Specs
My System SpecsSystem Spec

 Second Hard Drive Not Appearing in Explorer

Thread Tools

Similar help and support threads
Thread Forum
My autorun.inf hard drive icons stopping appearing
In the root of each hard drive I have an autorun.inf file with the following command: icon = .\MyIcon.ico and I have MyIcon.ico in the same root location. The hard drive icons no longer appear. How can I get them to appear.
General Discussion
iOmega External Hard Drive Not Appearing Anywhere
A month ago, my father asked to take back the Mac he lent me, so he gave me his iOmega external hard drive to copy all of my information onto. iOmega External Hard Drive Model: EPHD-ME I did so, and waited for a month before I realized I was better off moving the information onto my Windows...
Hardware & Devices
Hard drive not appearing in BIOS after PC upgrade
Hi everyone, I know there are a lot of threads about this already but I read a lot and none have helped me. I just did a complete upgrade of my PC replacing motherboard, video card, processor and power supply but keeping original hard drives. My boot drive and external survived but for some...
Hardware & Devices
Hard Drive Memory disappearing and c:\END appearing in c drive
First, sorry if I'm a little slow with some of this as I'm moderate with my computer knowledge. Earlier today I had 517 gb of memory available in the C drive. I restarted my computer earlier today and once it restarted I saw I was down to 1.84 gb. I ran crap cleaner already and did a quick scan...
Performance & Maintenance
2nd Hard drive not appearing...
It worked fine on Windows Vista. I just formated the first and installed Windows Seven on it. Now when loading up Seven, it says the 2nd is installed and working, but its not accessible and doesnt even appear. *FIXED* Finally found the search forum button -.-, sorry for the repost.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:28.
Twitter Facebook Google+