Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: disk not initialized in Disk Management. Device Not Ready.

05 May 2016   #1

Windows 7 Ultimate x64 SP1
disk not initialized in Disk Management. Device Not Ready.

I have a internal 3.5" HDD WD Black 2 TB and try to hook it up in the PC but it doesnt not appear anymore in My Computer. It was working few weeks ago. When opening Disk Management it says the disk is not initialized and it didnt state how many GB available on the hard disk (unallocated). Disk Management tried to initialized the hard disk and it pops out the following errors:
1. Virtual Disk Manager: Incorrect Function
2. Virtual Disk Manager: The device is not ready.

I have also tried using a powered USB cable and also connected in directly to the MoBo via SATA but the problem still persist.

I also ran disk part and it shows Disk 3 and Disk 4 as both online but both having size of 0 B

Below is the screen shot of Disk Management. When i right click on the HDD, there are four functions: Initialize Disk, Offline, Properties and Help however the the Initialize Disk function is greyed out.

I have Partition Wizard 9.1 and the attached picture below is the screenshot of the main GUI. It shows bad disk on the particular hard disk
Click image for larger version.

I tried running Partition Recovery Wizard on the mentioned HDD and it shows a partition of only 512 Bytes but none of my files are visible (no preview)

I just need to retrieve the files in the Hard disk as it contains important files and pictures that havent been backed up. Any help and suggestions are welcomed! Thanks

My System SpecsSystem Spec
05 May 2016   #2

Windows 7 Ultimate x64 SP1

I submitted this post in tenforums and sevenforums on an old thread. Its better to start a new one. THis is the reply from jumanji from the sevenforums thread. I will continue posting replies on this thread instead
disk 1 is unknown, not initialized, unallocated

Quote   Quote: Originally Posted by jumanji View Post
I am still trying to understand your system.

Please furnish the following Information.

1. You have a Windows 10 System. Is it a custom-built one? Built by you?

2.In the Windows Disk Management I see three drives.Disk 0, Disk 1 and Disk 2. All three Internal?

3. You are now trying to plug-in /connect two drives. But both of these cannot be accessed. Right?

Now the crucial question. 4. Where were these drives before? Please give the history of both drives. Both drives data drives? What happened to the system from which they came?

I may not be able to deal with the drives connected to Windows 10 - for I don't know how it will treat alien drives. As I see it both drives are bad ( In Windows 10).

I do understand that you have a SATA to USB adapter. Can you just take one drive - mark it as No 1 --, connect it to a Windows 7 system and post the screenshots of Windows Disk Management and PW screenshot? Always post full screenshots with all information seen and not truncated/cut screenshots.

Mark the other drive as Drive 2, unplug drive No.1 , plug in drive No2 and again repeat the screenshots. We shall not mix drive 1 and drive 2 together. It will lead to confusion. We shall deal with only one at a time.

I would rather prefer to work within a known environment.
My System SpecsSystem Spec
05 May 2016   #3

Windows 7 Ultimate x64 SP1

1. Yes it is a windows 10 system. Custom built by me

2. In Disk management there are three healthy drives. All drives are internal
Disk 1: SSD (where windows is insalled)
Disk 0: WD Black 2TB (one partition)
Disk 3: WD Green 2TB (one partition)

3. I am trying to plug in 1 drive (internal HDD WD 2TB Black) It is not the same as Disk 0. I dont know why it shows two drives in disk management when i plugged in it on the motherboard via Sata. If i were to use an external USB cable it shows 1 drive.

4. This HDD WD 2TB was the primary HDD but few weeks back there was a power shortage/blackout and after that the WD Black 2TB had shown some problems. Sometimes it will not show on My Computer which somehow is a sign that this HDD is going to die. Therefore i bought a new HDD, same brand, model and capacity (which is now Disk 0) and copied some 60% of the files from the old one. Now i wanted to copied 40% of the files and tried plugging it in and this problem occurs. I should've made a clone instead, but due to busy schedule i just managed to copied some files. Lesson learnt!

Im able to connect it to a windows 7 system but can only do that via the SATA to USB cable because i am running Windows 7 on my laptop. No way to connect it directly on Motherboard via SATA cable. I will upload in the next post (need to shutdown pc and remove HDD)
My System SpecsSystem Spec

05 May 2016   #4

Windows 7 Ultimate x64 SP1

Here is the screenshot in disk management when HDD is attached to Windows7 via USB SATA.
The HDD does not show in PW though.

Attached Thumbnails
disk not initialized in Disk Management. Device Not Ready.-disk1.png   disk not initialized in Disk Management. Device Not Ready.-disk2.png  
My System SpecsSystem Spec
05 May 2016   #5

Windows 7 Home Premium 32 bit

OK, your WD 2TB drive was in fact a secondary drive in your Windows 10 system which you have now replaced with another WD 2TB drive.( We normally call the boot drive as the Primary HDD. Any other internally connected HDD is a secondary drive and a data drive.)

Now coming to your present setup, Windows 7 laptop, the WD 2TB drive plugged in with SATA to USB adapter. PW does not recognise it.

Download, install and run Data Lifeguard Diagnostics for Windows. Run as administrator. Software and Firmware Downloads | WD Support

Perform a Quick Test - Only the Quick Test - and post the results. How to test a drive for problems using Data Lifeguard Diagnostics for Windows | WD Support

If the diagnostic software does not recognise the presence of the WD drive - No DIY data recovery is possible. Most probably the electronics PCB in the HDD has failed. WD Data Recovery Partners may have the exact replacement board and be able to recover the data. You may not get the exact replacement PCB.

If the diagnostic software recognises the WD drive and is able to run the test, irrespective of the PASS/Fail status, we may try to run some data recovery software and check whether something clicks. But its only trying your luck. If any such data recovery software fails to recognise the drive, no luck.

That is where we stand now.
My System SpecsSystem Spec
05 May 2016   #6

Windows 7 Ultimate x64 SP1

when i mentioned primary HD it is just because the disk was renamed to the name primary HD. It is actually a a secondary HDD where i store my programs files

Ive ran the quick test. Test results shows pass but with 0.0GB capacity ive attached the screenshot in this post

WD Data Recovery Partners may have the exact replacement board and be able to recover the data. You may not get the exact replacement PCB.
Where can i get such board?

Attached Thumbnails
disk not initialized in Disk Management. Device Not Ready.-disk3.png   disk not initialized in Disk Management. Device Not Ready.-disk4.png  
My System SpecsSystem Spec
05 May 2016   #7

Windows 7 Home Premium 32 bit

It is a false positive. It reads 0 GB - does not read even one single sector - and gives a PASS. If the drive is recognised correctly it should indicate the Model Number, Unit Serial Number, Firmware Number, and Capacity as in the screenshot below.

disk not initialized in Disk Management. Device Not Ready.-05-05-2016-21-39-00.jpg

It is definitely the failure of the PCB in the drive. Look at the PCB very carefully. There should be some sort of part identification number in it. ( It could be in the invisible backside also).You should get exactly the same part number board if you want to replace it. As I said it may well be impossible to get the same part Number board especially if it is a many years old drive. Manufacturers change the chips and/or firmware in the board often. So the board in the same model current drive may or may not work. Lots of uncertainities. The data recovery job is best left to WD Data Recovery Partners, who as I said may have the board in their jig, or even rejig one with the same components, flash the same firmware and recover the data. I do not know exactly what they do but they can do it. If you want to get your data , cost no matter that is the only way to go. You can contact the data recovery partners in your zone and discuss. Telephonic consultation is free. They may also give you a quote.

Data Recovery | WD Support

It is definitely beyond my hands/brains - if I have any left .

My System SpecsSystem Spec
05 May 2016   #8

Windows 7 Home Premium 32 bit

Please read my previous post.

Then google "Changing the PCB in an internal HDD for data recovery" Read and see whether that makes it easy for you to swap the PCB.

Also have a look at this supplier. How to Fix a Hard Drive PCB Board - . You may find other suppliers too.
My System SpecsSystem Spec
05 May 2016   #9

Windows 7 Ultimate x64 SP1

thanks anyways for your help. I know from the beginning it is a gone case. oh well my mistake for not making frequent backups. I will look into swapping the PCB Board and thanks for the info.
My System SpecsSystem Spec

 disk not initialized in Disk Management. Device Not Ready.

Thread Tools

Similar help and support threads
Thread Forum
Disk Management - Unknown / Not Initialized Drive
I ran BIOS diagnostics on a Dell OptiPlex 3010 yesterday and received an error code (2000-0142) - short self test unsuccessful. I pulled the drive and swapped a new SATA drive to get the user back up and running quickly. I'm trying to connect the drive with the error to my laptop using a StarTech...
Hardware & Devices
SSD disappears from Device manager and Disk management
Hello all, I have a Crucial 64gb SSD labeled as the D: drive. It is not the primary drive. IT keeps disappearing from windows. When it does I can not see it in device manager or disk management. So I disconnected and reconnected it to a different port on the motherboard and restarted the...
Hardware & Devices
hard disk changed to dynamic type after using disk management
I am facing problem of unable to shrink c drive in my windows 7 home premium.I have read everyone writing in about not to change the hard disk to dynamic type,but after partitioning one time using disk management now all my partitions are dynamic type & I still have 288gb left in c drive. I need...
General Discussion
Disk management converted only disk to dynamic, will it boot?
Hi, I was going to try dual booting Windows 8 on my laptop following a guide I found, and it said to go onto disk manager and shrink a volume to create another volume. The guide after the shrink only had two disks, and I had 5 disks (A recovery disk, HP tools and a blank one, along with my C disk,...
Hardware & Devices
Need quick help about new hard disk partition on win 7 disk management
Hi to all seven forums. I bought a new 1tb hard disk, and I connected it to my pc as slave, and when I creating the partition in windows seven disk management and right click to creates new partition, it had four option. 1. simple volume 2. spanned volume 3. stripped volume 4. mirrored...
Hardware & Devices
cant see hard drives in disk management or in device manager.
hi few days back i have completely formated my hard disk with the help of seagate seatool.Then i have installed windows xp sp3. i have made 4 partitions at that time ie. c,d,e,f. After that i have installed windows 7 now i cant see my hdd in disk management or in device manager. both device...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App