Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Belkin Network USB hub F5L009

03 Oct 2009   #21

Windows 7 RTM


Are you using version 1.2.0 or version 1.4.0 of the Belkin software.

I have had the same problem with version 1.2.0 and Windows 7 but it worked Ok after I upgraded to version 1.4.0.

Belkin : Support : F5L009 - Software and Drivers for Windows and Mac OS

(This is the uk version)



My System SpecsSystem Spec
03 Oct 2009   #22

Win7 x64 7232

My System SpecsSystem Spec
30 Oct 2009   #23

Something to try...


I could not get my hub to resolve and had given up. Tried running and installing in all forms of compatibility - have it connected to a scansnap which means I need a constant data throughput - the driver is very finicky. I am running it on a separate subnet connected to my main network through an additional wireless network adapter on my main computer. So on top of it all, its via wi-fi.

Point being, I have gotten this to work finally... essentially I had to turn off all forms of autodiscovery and set network communication to manual across the board:

1) Set the DHCP service on the router/switch to supply a static address to the mac address of the USB hub.

2) Go into the web page of the hub and disable DHCP - BUT ALSO add the static address you assigned, subnet and gateway for the hub. If you do not do this you will not be able to get back into the hub - as it will not pull a new address and there is no static to refer to. I thought I bricked my hub when I did this but then discovered a second application on the driver CD that allows you to 'set up' the hub (i.e. re-enable the DHCP seek mode on the USB hub).

3) Running the connect software, under Network > Refresh Options... even if it is not on a subnet, go ahead and add the IP address of the USB Hub...

If you didn't see the hub before (as I did not) you will see it now. I have scanned 200 pages sequentially without disconnect. I have not tried running a movie off a portable drive yet, but will do so if this does not solve the problem for folks.
My System SpecsSystem Spec

02 Dec 2009   #24

Windows 7

If Belkin ever resolves this issue, please update this thread. I'm in the same boat. A useless piece of junk sitting there because Windows 7 isn't supported, and as such, intermittemtly causes "not responding" issues when connected to the hub. I can't believe they won't fix this glaring issue via a firmware or software update.
My System SpecsSystem Spec
17 Jan 2010   #25

belkin sucks

i had both problems you've mentioned on a Windows 7 Pro & Windows 7 Home premium install

For the wmp crashes, my wireless was "too slow" (g network)
Wmp & itunes crashed within a few minutes of playing.
(had plenty of signal & i was the only one on the network)

My fix was to drill two holes in the floor & run a network cable from my router to behind my chair. Works like a champ on a wired connection.

Maybe you'd have better luck on a wireless N setup; free was more appealing to me than $100+ for a new network setup....
I'm sure the real reason behind the issue is because Belkin products suck, not really a slow connection. Now I remember why I don't buy Belkin stuff...

For the control center, check those windows firewall rules. I disabled my firewall & rebooted my computer. It still wouldn't work.
I turned the firewall back on & double checked the firewall rules.
The belkin software totally goofed them up.
Make sure the rules include your private network (the software only enabled the rules to work on public network profiles) & verify there is an outbound rule opening UDP port 19540.
After all that mess I was good to go.
Still don't understand why disabling the firewall didn't work as expected...

My setup runs DHCP without a problem....jag it sounds like your second router/wap isn't configured correctly. Have you considered configuring your second as a switch or is there a specific reason to subnet your network?

You could maintain DHCP on your primary router & disable it on the second.
Change the IP on the second router to match the subnet on your primary router.
Unplug the cable from WAN port on the second router & plug it into one of the standard ports.
My System SpecsSystem Spec
24 Jan 2010   #26

Windows 7
follow up question

Can Jag please expand on how you did the steps you recommended in a little more detail. It would be much appreciated. Thanks
My System SpecsSystem Spec
10 Oct 2010   #27

Windows 7 Professional x64
Found Win 7 Driver for Belkin F5L009!

I've spent way too many hours messing around with this Belkin mess in Win 7. It appears that Belkin is just not that interested in posting an update to this product...however, the company that made the reference design for the Network USB Hub that Belkin used does have Win 7 drivers. Too bad, all Belkin really needs to do is repackage the SXUPTP driver that Silex has updated for Win 7 into their install package...however the Belkin doesn't want to take the 2 minutes it probably would take to do this...soooo, get your Belkin HW working again in Win 7 with the solution that I have found to work flawlessly!

Step-by-step to get the Belkin Network USB Hub working in Win 7
1. Open the Belkin Network USB Hub Control Center
2. Click on "General" in Configure General Control Center Settings
3. Clear the checkbox for "Start Hub Control Center with Windows Starts"
4. Exit the application (Close the window and then right click on the taskbar icon for the control center and select "Exit Belkin Network Control Center." This will prevent the control center from starting on next windows load and terminate the process.
5. Download and unzip file at
6. Run "setup32.exe" or "setup64.exe" as appropriate
7. Go through install prompts and accept all prompts (alter program directory if necessary.)
8. Select the appropriate radio button at the "Auto Connect Default Setting" window. I share a printer with another PC on my network so I wanted the USB devices to be configured manually.
9. Select "Restart" at final window prompt.
10. When Windows starts, click on the Windows Start Button, scroll down and select "SX Virtual Link" folder and then select the program "SX Virtual Link"
11. On my system, my printer was already listed. So I just clicked on the "Wrench" icon and made sure the SX Virtual Link program started with windows. I also made sure the checkbox to hide the main window of SX Virtual Link was selected. I also have my printer only connect when printed to and then release the connection so that other users can print as well.
12. Enjoy worry free use of the Belkin Network USB Hub in Win 7! Oh yeah, you don't need the Belkin Network USB Hub Control Center software anymore...SX Virtual Link replaces that functionality.
My System SpecsSystem Spec
20 Oct 2010   #28

Windows 7 Ultimate x64

I tried to implement the solution proposed by the user Sranta, downloading, activating and configuring the SX Virtual Link files but its operation is quite unstable. The printer connects and disconnects a few seconds, so does the scanner and other devices connected to the Belkin F5L009. This did not happen with the original software that Belkin provided and it worked very well under Windows XP.

I try to keep looking for other solutions, if anyone can fix or have any idea how to configure the Belkin software or the SX Virtual Link to work on Windows 7 64 bit without any problems, please feel free to post the solution here, this is the best Internet forum which is posing the problem. It's a shame that people Belkin does not even bother to explain to their clients whether or not there is a possible solution to this problem.

Thank you very much!
My System SpecsSystem Spec
20 Oct 2010   #29

Windows 7 Professional x64
Piscolabis, try this...

Ok, I have several machines with Win 7 (and Vista and XP) at home and I've seen the problem piscolabis describes on one of my other Win 7 systems. So I tried this:
After installing the SX Virtual Link SW and rebooting, open the Belkin USB Hub Control Center and click on "About Belkin Network USB Hub" and see if the SXUPTP Driver version is updated to ""...if so, then the SXUPTP driver from the SX Virtual did get updated for use with the Belkin software. You can then re-use the Belkin software and see if things are better for you. If you are still having problems....then??? I don't work for Belkin or Silex...I'm just trying to get my machines to work with the F5L009 to work in a Win7 environment as well!

Remember, it's probably not good to have both SX Virtual Link and the Belkin Control Center running at the same time. You'll need to make sure SX Virtual Link doesn't start with windows going forward (set this in SX's config menu) and that the program is exited after you config it. Then re-start the Belkin Control Center and re-configure the SW to start when windows starts (click on "General" on the left hand side of the Control Center interface and click on "Start Hub Control Center when Windows starts".)

Good luck!
My System SpecsSystem Spec
30 Oct 2010   #30

Win 7 Home Premium

I know this is a bit off topic but still on the same hardware, I just purchased a Belkin Hub F5L009 and wanted to get some clarification.

Is the Belkin USB Hub wireless or are they just talking a wireless computer can access this through a wireless router?

I am trying to set up a webcam at my front porch to look outside through the hub and wanted the hub to connect to my network wirelessly. Can I do this without having to run cable outside to my front porch or do I need a repeater to get the signal out to the hub. I checked out all kinds of settings and cannot find anything that relates to wireless setup.

I am assuming that people are talking about wireless with the hub meaning a wireless computer can access the hub through a router on the network, not that the hub connects without wires to the network.

Which way is this, Thanks.

My System SpecsSystem Spec

 Belkin Network USB hub F5L009

Thread Tools

Similar help and support threads
Thread Forum
Cannot Setup Wireless Network (Belkin N1 Network Card)
I'm trying (desperately) to set up my network on Windows 7, but have hit a bump in that it just cannot find my network. I checked Device Manager to see if the card was found - it was with a troubleshoot exclamation point on it. I removed the card, used the installation disc and am not able...
Network & Sharing
How do I get a Windows 7 Driver for Belkin F5L009 USB hub
I have a Belkin F5L009 USB Hub and it is installed and working fine on my laptop running Windows Vista. I want to install it on my wife's new laptop running Windows 7 Home Premium OS. When I install it off the disc it finds the hub's IP address but when I try to install it say it has detected an...
Issues with Belkin USB network hub
Hi. I have a Belkin USB Network hub. Works like a dream on Windows XP. Now I have it on Windows 7 Ultimate 64Bit. Works ok when installed. After reboot it doesn't work anylonger.
Network & Sharing
Issuse with Belkin USB Network HUB.
Hi. I run Windows 7 Ultimate 32bit here. I have a Belkin USB Network HUB f5l009. It has worked before on W7U, but not now. I can see it's IP address in my router, but cannot see the IP address in the HUB itself.
Network & Sharing
Belkin Network
While the Belkin router (F5D8232-4 }seemed to be fine, the Belkin adapter (F5D8055) only arrived yesterday. Since then, I have been trying to get the network operational between my rigs, of which the first is running W7, and the second is running XP MCE (since the W7 drive died). Both OSs are set...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:45.
Twitter Facebook Google+