Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: problem with windows 7 not using correct metric

17 Dec 2009   #1
kmj

Windows 7
 
 
problem with windows 7 not using correct metric

I have had windows 7 for a few weeks and every time the PC is rebooted the Metric for both the Lan (172.17) and Wifi(192.169)goes back to 20, the Lan is set to Automatic and the wifi is set to 10, has anybody seen this problem before?

Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 172.17.96.4 172.17.99.156 20
0.0.0.0 0.0.0.0 192.169.1.1 192.169.1.14 20

Regards




My System SpecsSystem Spec
.
17 Dec 2009   #2
DC187

Windows 7 Ultimate x64
 
 

Sounds quite bizzare, Windows assigns a lower metric to the gateway it can communicate the fastest with, but in this case both have been assigned 20.
If you've manually assigned a gateway and metric you should see that in the list of persistent routes.

I wonder if your issue is similar to that in https://www.sevenforums.com/network-sharing/47280-how-configure-multiple-gateways.html

I'm stumped and have emailed MS as it works as expected in Win XP
My System SpecsSystem Spec
17 Dec 2009   #3
kmj

Windows 7
 
 

Its sounds similar, I have changed the wifi metric to 9, when I do route print I see the metric as changed from 20 to 19. It seems windows is adding 10 to the value I enter, why is it doing this?

Karl
My System SpecsSystem Spec
.

17 Dec 2009   #4
DC187

Windows 7 Ultimate x64
 
 

I wish I could explain it, I've contacted MS for the issue in the other thread, please keep an eye on that, I'll update that thread should I get any useful information back.
My System SpecsSystem Spec
17 Dec 2009   #5
TimStitt

Windows 7 Ultimate 64 bit
 
 

This may provide a little more info Using Windows 7 with Multiple Gateways (Routers), although I'm not completely understanding what changes the author made to solve his issue. I'll post this on the other blog too and cross reference.

kmj - What happens if you add a static metric to both Lan and Wireless routes?
My System SpecsSystem Spec
17 Dec 2009   #6
kmj

Windows 7
 
 

Thanks for the link, the information is quite good.
I have manually set the Lan to a metric of 25 and route print show this is value is being used unaltered, it seems only the wifi link is have its value changed from the manual setting of 9 to 19.

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 172.17.96.4 172.17.99.156 25
0.0.0.0 0.0.0.0 192.169.1.1 192.169.1.14 19
My System SpecsSystem Spec
Reply

 problem with windows 7 not using correct metric




Thread Tools




Similar help and support threads
Thread Forum
Text font question within Windows7; What metric to enlarge type
I have been to the section of Win7 personalization where metrics are stored for text display. If you look at the window options section for borders and such, and select a metric in ("Change Windows colors and metrics" will get you there in the search box) -- everything seems to be in there...
Customization
Can't install Autocad Architecture Metric (US) in Guest account
Hi, I'm new to this forum, and hope to solve my problem with some expert guidance. The problems started with me trying to create a shared file in onenote, which could be edited and viewed by all users of my computer. In the UAC, it asked me about some permission about "INTERACTIVE" and...
Software
How to Disable Search for Bio metric Device on Windows 7 Start up?
When ever I go to log on to my Dell Latitude E7440 with windows 7 Professional x64 I get an error screen saying that windows could not find a bio metric device. This is true because my computer does not have a fingerprint reader on it. I was wondering if anyone could help me so i don't have to sit...
Hardware & Devices
Problem with boxes showing up (Not sure if the correct explanation?)
Hey, I am having an issue where after right-clicking things and then going about my business, the boxes are left hanging and there is nothing I can do to get rid of them. Can anyone explain why this is happening and how to stop it? As of right now, the only way to get rid of these is to open the...
General Discussion
Using 3G Modem, it changes metric value and default gateway, help?
Hey guys, I am using a 3G modem (Virgin Mobile MC760). In short; I have 2 connections; 1 is wired ethernet and the other is this 3G modem. I want to be able to use the 3G modem in a guest Vmware system while still using my regular ethernet for everything else in the host. (Unfortunately this modem...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App