Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: My Book World Edition

21 Mar 2009   #1
Mark Vincett

My Book World Edition

hi just install windows 7 7057 64bit and i cannot get it to see my book world 1TB drive on the network
I think its to do with 128-bit encryption i have not come across this before
thanks for any help

My System SpecsSystem Spec
04 May 2009   #2

Windows 7 / Windows Vista / Windows XP

I am having same problem.

I have a 1 TB MyBookWorld, two Windows Vista machines, a Windows XP and a few other devices on my home network. When I built a 7100 Windows 7 machine (64 bit) this weekend, and added it to my home network, the MyBookWorld NAS drive was no longer visible from any of my computers. To get it to work, I had to shutdown my Windows 7 computer and restart the MyBookWorld NAS. I tried it several times and the same thing happen. I updated the MyBookWorld firmware but still the same behavior. I have not had a chance to change Windows 7 encryption from 128 bit to 40/50 bit, but will try that tonight.

I will post here again if I find a solution.
My System SpecsSystem Spec
04 May 2009   #3

Windows 7 / Windows Vista / Windows XP

As I continue to search for a solution, I found this posted to Windows Vista forum: Vista 64-bit and WD MyBook World edition - Vista Forums

I am seeing the same behavior with Windows 7 64 bit. So would appear that WD MyBookWorld does not work with 64 bit OS.

Very sad!

Still looking for possible solution.
My System SpecsSystem Spec

28 Oct 2009   #4

Windows 7
My Book World 1TB Edition Networked Working

Looked everywhere for something on this topic couldn't find anything helpful. Somehow without really trying I was able to access my data via mapped drive in Windows 7 x86 (cant browse to it though - only mapped). Don't know exactly what does the trick but just letting you guys know to see if it works for anybody else.

First off I always have the same network name for all my home networks. My workgroup name is the same for XP, Win7 and My Book...(if there is a setting for that in My Book I would have set that back in the day) So that never changes for any of my systems or drives, if that makes a diff.

When I checked out the computers in my network via Win7 I could not see My Book as an actual listed computer. I then went into Computer and tried to add a mapped drive. I remembered the name and paths of some of the directories. I added the path that I knew... \\YOURMYBOOKNAME\FOLDER\ANOTHERFOLDER.

Naturally it did not recognize or allow me to map to the drive. So sometime later I went back to map a different drive on another computer and I then saw the name of my My Book with the rest of the other home computers. Waaa? Although when I tried to view it via Network it still did not appear.

Next I just went back to Computer and tried to map the same shared folder from there again and it allowed it. Arrrh? Would also note that I setup my permissions for My Book to allow anybody on the network to access and change the contents. If permissions is a key factor then you should be able to access your My Book by looking up the IP via your router and browser into it to make permisson the changes. Try the other stuff first and if it still does not work then try the permissions bit (just to see whats behind viewing a networked My Book via Windows 7)

Somebody try it out and let me know as I'm very interested to see if it works anybody else. Good luck.
My System SpecsSystem Spec
28 Oct 2009   #5

Windows 7

Also I turned on Network Discovery via the Network and sharing Center> Advanced Sharing settings.
My System SpecsSystem Spec
13 Nov 2009   #6

Windows 7 64bit
any workarounds yet

I too have MBWE II 2tb, trying to install on Win 7 64bit OS. Spoke with WD tech, they said their "might" be fix in future, and just to keep on checking their website. I asked them to notify me, they said they couldn't, I just have to check their website. Thats a crock. Asked them to take back this hard drive and give me something that works w/ Win 7, no dice. However to be fair, they did say they will swap out the same exact Hard Drive for me.
My System SpecsSystem Spec
25 Feb 2010   #7

Win 7

I have even more severe problem with MyBook incompatibility with W7/64 bit --
Initially W7 recognized MyBook fine and I was able to access it without any visible problem. But I started to experience strange problems with W7 not willing to shutdown or go to sleep (I have Lenovo T500 and use it at home and in the office). Finally I noticed that if I physically disconnect MyBook from network, all my "shutdown" problems are gone! So I keep it disconnected and I do not think it is an intended use of this "paper press".

My System SpecsSystem Spec
01 Mar 2010   #8

Windows 7 64 bit
Windows 7 & WD MyBook World Edition II

I had the same problem setting up my husband's new Dell laptop. Windows 7, 64 bit. I personally use a Mac. Couldn't understand why I could see and access files perfectly with my Mac and all of our old PCs running Windows XP. In fact I am running a virtual machine in my Mac with Windows 7 (32 bit) and it works fine.

I got the run around from Dell, told me to call Microsoft. Microsoft told me to call Dell, after trying to blame the router. Long story went nowhere.

Finally with the help of a quick assistance code (eternally grateful to my son-in-law who works at Microsoft) I got some assistance.

First as I kept reviewing all my networking settings in Windows 7 machine I mapped the drive (Z:) changed the encryption from 128 bit to 40//50 bit. I think that is what allowed me to access the WD MyBook World without having to login every time. I could then see and open files. However, I still was not able to save files (access denied) or even create a new one and save it to the drive.

What Microsoft tech did for me was to go to a Dos prompt and grant rights to essentially everything on my Z drive. Didn't get whole command, but it was something like this Z: icacls *.*/grant everyone: f/t/c It successfully processed 23, 163 files and failed to process 4,733. Whole process took probably an hour and a half.

Hope this is helpful to others struggling out there with similar issue.
My System SpecsSystem Spec
21 Mar 2010   #9

Windows 7 (64 bit)
Problem Solved

For me, at least: From reading the various forum discussions on this I surmise that the Win 7 64 shutdown problems are caused by Windows waiting for the hard drive to respond that it is powering-down. Under the Network Tab of Windows Explorer, my Windows 64 setup seems to recognise the MyBook as a "Storage Device" and as a "Computer". The "Storage Device" element doesn't work properly, but the Computer one does (I can access all my MyBook directories from there - I also mapped them to Drive letters just in case...). This means the "Storage Device" is unnecessary, right? So I went to Device Manager and "Disabled" the MyBook as a Hard Drive. Since then everything has worked perfectly: No shutdown problems; constant visibility of the MyBook as a "Computer" on my home network. I guess all the issues were caused by a bad/wrong driver for the MyBook as a *Hard Drive*, and by preventing Windows 64 seeing it as a Hard Drive I have fixed my problems.

Let's see how long before it goes wrong again...

Let me know if this worked for anyone else?
My System SpecsSystem Spec
16 Apr 2010   #10

Windows 7 Pro
Problem solved via Firewall

Hi. Setting up new Dell laptop with Windows 7 Pro 64bit and couldn't see my MyBookWorld (whereas wife's new Dell laptop with Windows 7 Pro 32 bit can. Read this thread but couldn't get it to work. Looked up logs on MyBookWorld administration and saw that my new computer was getting logged on and then very quickly logged off. Made me suspect the firewall.

Opened Trend Micro Internet Security, clicked Home Network & Firewall Controls and then Check Network. Trend searches the network and lists all the "computers" it can find and they are all by default Not Trusted (marked "Do Not Trust"). I found the one that is my MyBookWorld drive (right-click MyBookWorld in Windows Explorer and it's listed in the device homepage) and clicked Trust button. This changes the status to Trust. This didn't work! (even after restarting pc and drive)

SOLUTION: Next I just turned off Trend Micros firewall and turned on Windows firewall. Bingo! All of a sudden I've got my My Book World drive as well as the Windows HomeGroup computers I couldn't get to work!

I wish Dell had offered me the opportunity to get Norton IS which is what I got with my wife's Dell only 3 months prior. NIS seems to work really well as far as I'm concerned. And I bought a 3 year licence with Trend.

Anyway, happy it all works now.
My System SpecsSystem Spec

 My Book World Edition

Thread Tools

Similar help and support threads
Thread Forum
WD My Book 2TB Gone
Greetings to all, My WD external HDD crashed couple of days before. I can't access it and the worst is the I have in it all my important files. Family photos and videos, everything. First opened the box and connect it on the motherboard as internal and started CHKDSK, but it's stucked at...
Hardware & Devices
My Book World
Hi i was just wondering if anyone knows if my book world external 1 TB device can be used as a external hard drive with a usb connection and not an internet one ? My Book World Edition that is the device i have and i want to connect it with a USB cable instead through a router , is it possible...
Hardware & Devices
My Book World Edition 1
my dad installed this on our network and i tried to access it. automatically, windows 7 tried to install the driver for it so that, obviously, it would work. but, it said something like "installation failed. more parts may be required" or something similar. so i decided to forget it. now, whenever...
Hardware & Devices
WD My Book World Edition - does it work in Seven ?
Hi, I can't install Mionet software to access the "blue rings". Has anyone solved it ? Thanks.
WD MY BOOK Premium Edition 1TB External
Above is configured for Raid 0 or stripping and is a 1 TB as opposed to two 500 GB. External works fine on Win 7 but the Raid software that allows you to configure does not work. Anyone else running this external disk?
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:27.
Twitter Facebook Google+