Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problems with atheros L1 ethernet adapter in Win7 x64

19 Sep 2009   #11

Windows 7 Enterprise

Quote   Quote: Originally Posted by Ganju View Post
Hello guys.Sorry for digging up this thread but I have the same problem. My Asus P5K mobo has an Atheros L1 controller. When I start downloading a torrent it appears like the cable is unplugged. i thought the problem was with the router but i recently installed a second PC on it and while my PC shows unplugged,my second PC works fine and has access to Internet. Same when i relog on Win XP. Has anyone come up with a solution?
I have an easy solution!

Buy a new networkcard :P
DidŽnt find any other solution so thats what i did. Now i works perfectly :P

My System SpecsSystem Spec
19 Sep 2009   #12

Windows 7 x64

I got my CD that came with my motherboard (ASUS P5B-MX) and I ran the LAN driver install in compatibility mode with Windows Vista and installed the Vista Attansic LAN controller. Everything seems to be running well, I'll keep you posted.

(was able to watch Netflix on my PS3 using Playon for the first time in a few weeks, since I upgraded to 7)
My System SpecsSystem Spec
22 Sep 2009   #13

win7 32
It works

ok i removed the driver win 7 installed. Reinstalled the updated driver from asus web site in win vista compatability mode. reboot pc and change power settings so pc cannot go to sleep or hibernate and all is working good now. hope this helps someone.

Sorry after a while this stopped working as well
My System SpecsSystem Spec

22 Sep 2009   #14

Windows 7

I'll try setting up the previous drivers in compatibility mode and if this doesn't work I' ll buy a new network card as well.
My System SpecsSystem Spec
22 Sep 2009   #15

Windows 8 Professional

i have same issue with same mb. However i had a win 7 freezing issue with my first driver, microsoft released an updated driver so i installed that. Everything was fine for a few days, now streaming video from NAS thru win7 to xbox flakes out after about 20min of watching. Do we have a definite fix?

by the way im running Windows 7 x64 RTM (7600.win7_rtm.090713-1255),
My System SpecsSystem Spec
23 Sep 2009   #16

win7 32

Well my file transfers started acting up again too. I want to stay with win 7 so i ordered a new gigabit lan card from new egg. they have some on sale for 8$ so i got 2 and a gigabit switch all for 55$. This atheros lan has been problems since asus started using it. Time for it to be disabled.
My System SpecsSystem Spec
20 Oct 2009   #17

Windows 7 RTM

I also got this problem: When transfering large amounts of data over the network the network card would disconnect, requiring a "disable/enable" to fix.

I am running Windows 7 64 bit RTM and the latest Atheros driver (

To resolve, I went into the driver properties, clicked Advanced / Task Offload, and I turned this feature off.

Now, the driver works fine for me
My System SpecsSystem Spec
03 Nov 2009   #18



Thanks for posting, that fixed my problems as well!
My System SpecsSystem Spec
03 Nov 2009   #19

windows 7
Netword adapter atheros L1 gigabit on asus p5b-mx MB

Dies when doing large data transfer. Fails when 250 to 750 meg of data transferred. On cmd line will ping its address, Shows its address with ipconfig /all but no connection to network. Must pwr off - on or disable enable network adapter to restart and then ok. Did the (modify Task offload to off, in Network driver property under advance) found on this board and now have transferred multiple Gig of data from one PC to another which has not worked since up grading to windows 7. If fails again will update this forum message. Now running down level Driver ( from asus. Removed the two driver from windows 7 and updated windows driver to try and resolve problem with no help. Supect that this modify may also make those drivers work correctly.
My System SpecsSystem Spec
04 Nov 2009   #20

Windows 7 Pro 64-bit


I'm having the same problem. I also noticed that ping router works, ping my fileserver works and ping works. BUT ping localhost didnt work. It tried to ping address ::1: (yes, ::1: is correct, not a typo or misunderstading :))

Now have now set this two options differently:

1. Network and Internet > Network sharing center > Advanced sharing settings and from there "File sharing connections". It was set to "Use 128-bit plaa plaa.." and I changed it to "Enable file sharing on devices that use 40- or 56-bit encryption"

2. I went into the driver properties, clicked Advanced / Task Offload, and I turned this feature off. Just like mpowrie told us to do.

I will see if these two help. If it does, I will try to turn those settings back, one at the time to see which one was the killer move. Gonna let you guys know later today o/

After test

Well.. I did perform an operation succesfully without the ::1: bug that kills the network connection.

BUT I still have problem moving with filetransfer from fileserver. The transfer will just... calculate :<
My System SpecsSystem Spec

 Problems with atheros L1 ethernet adapter in Win7 x64

Thread Tools

Similar help and support threads
Thread Forum
Looking for a USB Ethernet adapter for Win7 64 bit
Just like the title says - I upgraded to Windows 7 pro 64-bit, and I can't find working drivers for my Trendnet TU-ET100C. Is anyone using a USB to Ethernet device under Win7 64 that works well, or has anyone found Trendnet drivers that work? Thanks in advance!
Hardware & Devices
Atheros Ethernet driver BSOD
Im having issues with my Atheros Ethernet driver, my computer intermittently crashes when using OpenVPN . I tried two Atheros drivers and got the same result, I will try one more driver. If that does not fix the issue I will most likely get a PCI Ethernet card. I just need a second opinion on the...
BSOD Help and Support
Atheros Ethernet Controller drivers won't/can't install
Hi all I am having wireless connection issues and hoping someone here can help me After resent issues I had with my Gateway laptop (ID59C) I reformated and reinstalled windows. All has gone well all drivers and windows updates have been completed When I tried to get my wireless internet...
Possible problem with Atheros Network Adapter
Hi, I posted a topic about the same computer back in April - I am a novice compared to almost everyone here. So when I didn't get any real assistance with my previous post, I felt I had...
Network & Sharing
Atheros wired ethernet connection problem
Every time I connect my laptop with the Atheros wired ethernet adaptor at my work at my university (but it works home), I am forced to uninstall the driver from the device manager and then restarting windows 7 to get it to connect (it automatically installs the driver in this case). This happens...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:34.
Twitter Facebook Google+