Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problems with atheros L1 ethernet adapter in Win7 x64

18 Nov 2009   #21

Windows 7 64bit
PS3 Media Streaming DLNA Error

Quote   Quote: Originally Posted by mpowrie View Post
I also got this problem: When transfering large amounts of data over the network the network card would disconnect, requiring a "disable/enable" to fix.

I am running Windows 7 64 bit RTM and the latest Atheros driver (

To resolve, I went into the driver properties, clicked Advanced / Task Offload, and I turned this feature off.

Now, the driver works fine for me
I had a problem with PS3 media streaming from Windows 7 64bit from my Asus P5K motherboard. It worked fine with Vista 32bit but kept giving me DLNA errors 2103 and causing my PC to freeze ! (I had to switch off and on again). I have a Gigabit LAN connected to my 120 GB PS3.

After much searching I found mpowrie's fix and it now works fine - thank you !

My System SpecsSystem Spec
29 Nov 2009   #22


I have tried it too and it worked for the network. However I am loosing a SATA driver while streaming with PS3 media Server. I have a garbage Asus P5KC with Windows 7 64. I had no problem on Vista 64 but it seems that this board can't work correctly with Windows 7 64....

Anyone has the issue with the SATA? I just re-installed the OS and same problem. When booting on Vista it works so it's not a new HW issue...
My System SpecsSystem Spec
07 Dec 2009   #23

Windows 7
Fixed: Atheros on P5Q stops after sleep & hybernate

I had a similar problem:
The computer would go into hybrid sleep and when it wakes up I would get a yellow exclamation on the Network icon in the system tray. When I right click and click Troubleshoot problems it fixes the problem with saying something like no valid IP was registered -- Fixed. I installed the Beta driver from ASUS and the problem seems to have gone away.

Hope this helps someone!
My System SpecsSystem Spec

29 Dec 2009   #24

Windows XP

Is there still no fix for this? I have an Atheros L1 Gigabit Ethernet 10/100/1000 Base-T Controller onboard on my motherboard. Never had any problems until installing Windows 7. Now surfing internet, FTP etc is all fine but running a torrent and trying to access stuff over the netwrok from my laptop causes the computer to lose it's connection.

Running the windows network diagnostics alsways fixes the problem and gives the same error every time "The default gateway was not available".

It seems this problem only happens when transmitting data but not when receiving it.

There must be a fix by now surely, there's loads of people with this problem so it's obviously an issue.
My System SpecsSystem Spec
30 Dec 2009   #25

Windows XP

Just done a quick test and installed a PCI Realtek network card into my PC and managed to copy a 5GB file to my laptop without a single interruption. Although not conclusive proof it would appear that the problem lies with the driver for the Atheros controller.

What are the chances of seeing a fix though seeing as people seem to have been having problems since the beta days and it's still not fixed? Looks like I'll have to stick with a network card using up a PCI slot which I should really have free.
My System SpecsSystem Spec
30 Dec 2009   #26


on my side with the updated drivers and changes in the configuration the problem with the network is gone. (see this site to get the drivers ASUSTeK Computer Inc.-Forum- P5KC not ready for Windows 7 )

however the board is still total garbage. If I try to use the firewire port and transfer data to external firewire HD it hangs. I tried to add a old PCI firewire card to see if problem is still there and same problem. So as soon as there is a lot of I/O the board sucks big time with Windows 7... and the problem is not the HD as it works perfectly fine on other machine...
My System SpecsSystem Spec
30 Dec 2009   #27

Windows XP

Thanks for that link. I have a P5B SE board though and updated the drivers via windows update, would this not be enough to ensure I had working drivers? I appreciate that I may need to update the BIOS though.
My System SpecsSystem Spec
10 Jan 2010   #28

win 7 x64

1. That download link (for Atheros) does not work any more.
2. Atheros L1 gigabit completely freezes my windows 7 x64 system (an asus laptop GS1) whenever I try to copy a large file (250 MB) to any network destination (standard windows workgroup using netbios). no bluescreen--just frozen solid.
3. mobrie's suggestion does not solve the problem.
4. I am using the latest windows 7 x64 drivers available from microsoft (windows update) for the atheros:
5. also sometimes freezes on printing to a networked printer (netbios again).

Thanks for any help.
My System SpecsSystem Spec
10 Jan 2010   #29

win 7 x64

Newer drivers from seem to have solved the problem. these drivers (version, 10/13/2009) are slightly newer than the windows 7 official drivers (
however, to be on the safe side, I've kept mpowrie's fix also.
My System SpecsSystem Spec
10 Jan 2010   #30

win 7 x64

the exact link is:
Atheros & Zidas drivers
My System SpecsSystem Spec

 Problems with atheros L1 ethernet adapter in Win7 x64

Thread Tools

Similar help and support threads
Thread Forum
Looking for a USB Ethernet adapter for Win7 64 bit
Just like the title says - I upgraded to Windows 7 pro 64-bit, and I can't find working drivers for my Trendnet TU-ET100C. Is anyone using a USB to Ethernet device under Win7 64 that works well, or has anyone found Trendnet drivers that work? Thanks in advance!
Hardware & Devices
Atheros Ethernet driver BSOD
Im having issues with my Atheros Ethernet driver, my computer intermittently crashes when using OpenVPN . I tried two Atheros drivers and got the same result, I will try one more driver. If that does not fix the issue I will most likely get a PCI Ethernet card. I just need a second opinion on the...
BSOD Help and Support
Atheros Ethernet Controller drivers won't/can't install
Hi all I am having wireless connection issues and hoping someone here can help me After resent issues I had with my Gateway laptop (ID59C) I reformated and reinstalled windows. All has gone well all drivers and windows updates have been completed When I tried to get my wireless internet...
Possible problem with Atheros Network Adapter
Hi, I posted a topic about the same computer back in April - I am a novice compared to almost everyone here. So when I didn't get any real assistance with my previous post, I felt I had...
Network & Sharing
Atheros wired ethernet connection problem
Every time I connect my laptop with the Atheros wired ethernet adaptor at my work at my university (but it works home), I am forced to uninstall the driver from the device manager and then restarting windows 7 to get it to connect (it automatically installs the driver in this case). This happens...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:37.
Twitter Facebook Google+