Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Odd Task Scheduler Issues

05 Jun 2009   #11

Win 7 RC x64

OK so tried erasing those registry keys and worked fine. Did of course check the Viper page first for services, and they were all running as supposed.

I donīt use system restore so donīt think I will have a problem with that. Well lets see what happens if I try the tab... Well the system protection tab appear to work as it should. All protection is off according to mine and to be honest donīt want to activate it to see if any issues...

Try using the back-up tool with system image instead. I do it every 2nd / 3rd week. Works great, and have used it a few times mostly to try it, an awesome feature! (especially when you have an nVidia MB and GPU)


My System SpecsSystem Spec
05 Jun 2009   #12

Windows 7 Build 7600|16384- 64bit

Another program that is nice to have is called SyncToy version 2. It is more along the lines of files and things since it does not do registry backups.
My System SpecsSystem Spec
05 Jun 2009   #13

Win 7 RC x64

Quote   Quote: Originally Posted by msun View Post
Out of desperation, I tried the following process which fixed this issue for me:-

Use regedit and delete all entries under the following key:-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache]

You may wish to backup/export that key before deleting.

Upon reboot, the task scheduler issues were resolved for me.

However, not all related issues were fixed. For instance, disabling or enabling system restore points (right-click "My Computer" - properties) resulted in this popup message:-

"Could not create the scheduled task for the following reason:
Cannot create a file when that file already exists. (0x800700B7)"

Hope this is of some help to resolve the issue - any comments would be most welcome.

Cheers from Mike :)

How on earth did you find that key, and thought about deleting it?
My System SpecsSystem Spec

05 Jun 2009   #14

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Hi Habu,

I think that solution was proposed by Rick Rogers quite some time ago.

It is on several sites - you can find it by googling.
My System SpecsSystem Spec
15 Jun 2009   #15

WIndows 7

Still had the same problem even after deleting the registry keys and rebooting. It appeared to work at first, but then came back again as soon as another task was scheduled.

Found a fix at the following URL under Windows 7 and CCleaner Issue:
Adventures in Life - Windows Live
My System SpecsSystem Spec
30 Jun 2009   #16

Build 7100

I tried the reg fix but I keep getting an error: "Unable to delete specified values." I tried fixes for this as well with no success. I have CCleaner installed but i haven't used it yet.
My System SpecsSystem Spec
14 Dec 2009   #17

Windows 7 Home Premium 64-bit

I had the same error on a fresh install. I have installed CCleaner but have never run it. I got desperate and went off half-cocked and started deleting scheduled tasks which were not installed by me (Microsoft folders in the Library). When I got down to Defrag I got the same "{0}" error. I had defragged! By chance the error has now disappeared.

So I think possibly defrag may be involved in creating this error. But I don't know for sure.

I am now regretting having deleted those Microsoft (and Apple and something like WDN at the bottom) tasks as I have no idea how they can be restored.
My System SpecsSystem Spec
14 Mar 2010   #18

Win7 task scheduler

If your problem relates to:-

the selected task "{0}" no longer exists

Have you set your defrag schedule to MONTHLY if so set it to Daily or Weekly.
This solved the problem for me.

I have placed various messages on different boards but no one
has rereplied. If you would like to see the message go to url below

Hope this helps


My System SpecsSystem Spec
02 May 2010   #19

windows seven

I ran CCleaner, and I had the error. I keep all of the removed entries every time I run it tho. I just put them back, and the error was gone. It seems CCleaner does have something to do with this. I am going to try the latest version, and see if it continues to break it. BRB...
My System SpecsSystem Spec
02 May 2010   #20

windows seven

I believe the part that broke it, was the registry fixer. I did run an older version, and was able to re-register the saved entries to fix the issue. I installed latest version, and ran it, both the registry fixer, and the cleaner part. and all is well. It does pay to keep those registry backups of the removed entries. I hope this helps!
My System SpecsSystem Spec

 Odd Task Scheduler Issues

Thread Tools

Similar help and support threads
Thread Forum
Need help creating a task scheduler task to move files over a network.
Hello everyone, I need to have a task run that will move the contents of a folder from one computer to another over my home LAN. Files get downloaded during the night on one computer and then need to be transfered to another. Usually I am doing this by hand, but then though maybe I could get...
General Discussion
Task Scheduler - Create Task to Display a Message Reminder
How to Display a Message Reminder in Windows with Task Scheduler This will show you how to create yourself, or another user or group, a message reminder scheduled to display for when and how often you like in Windows 7 or Vista using Task Scheduler. All users on the computer will be able to...
Task Scheduler error 2147944309 when I change task from
I have a simple task (cmd batch file). Whenever I try to change the settings I get a dialog box that reads as follows:"An error has occurred for task RemoteBk. Error message: The following error was reported: 2147944309". My computer is part of a domain.
Installation & Setup
Task scheduler unable to load task status/active tasks at startup.
My task manager is unable to load task status/active tasks at startup. I get the message: "The selected task "{0}" no longer exists. To see the current tasks, click Refresh." When I refresh I get the same message. I checked and found that under Microsoft the problem was in the defrag...
Performance & Maintenance
Task Scheduler failing to start task with merged network locations
I have two routers I usually connect to (work and home) and each have wireless access. That means there are essentially 4 network locations I have listed. I have merged each respective network location (wired and wireless) into their own singular network location - "Work" and "Home". I also...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 16:35.
Twitter Facebook Google+