Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Startup Repair Infinite Loop Recovery

30 Jan 2015   #440

Windows 7 64 bit

I followed that tutorial and still can't seem to bypass the system recovery. The computer I have is a custom built one and the hard drive was used before by me and it had viruses before I put it in storage becuse my gpu was blown. I'm trying to get it to start with said HD because it's all I have and desperately need this computer up and running. I can't seem to find my Win7 Disc so can't do a full restore or I'd have done so already.

How can I get this to start up properly? Pressing F8 doesn't do anything either since it just says it failed to startup recovery and restarts instantly. What is wrong?
My System SpecsSystem Spec
11 Feb 2015   #441

Windows 7 ultimate x64
It worked!

Joined in just to say "thanks"! I followed each step of your tutorial and everything went back to normal. The fact that complete Windows reinstallation isn't required is so nice. You saved my day, thank you!

P. S. In my case the whole problem was caused by an unfortunate BSOD which happened during Antivirus instalation.
My System SpecsSystem Spec
21 Feb 2015   #442

Windows 7 Home Premium 32-bit
Many, many thanks!!

I had the infinite loop problem and this tutorial has fixed my laptop and restored my sanity!!

My System SpecsSystem Spec
23 Mar 2015   #443

PA - Pennsylvania

Thanks for the excellent tutorial. BUT, I'm very sorry to report that I got stuck on step 13:
When I navigate to the regback folder, it is empty. The tutorial just says:

The file sizes presented here ... may vary depending on your system. If any one of them are 0 bytes, then you should stop what you're doing now and seek an alternative method of recovering your system, because Windows cannot function with a 0-byte size registry hive.

Please HELP -- I have been googling and experimenting for many hours -- what 'alternative methods' can I try ? Are there other restore points somewhere ? (I tried several in startup repair, none succeeded). This is a Dell Latitude E6510 Win7 Pro, MS Office Starter.

Any suggestions are welcome -- no, I don't have an install disk, yes I have backed-up user files (laptop belongs to my friend, but she bought it second-hand on my recommendation ... sigh). The Dell pre-boot diagnostics (lengthy -- quite thorough ?) indicate hardware is all ok.

Thanks for your help !
My System SpecsSystem Spec

25 Mar 2015   #444

Windows 7 Ultimate

Hello, I'm stuck on step 8! When I do a DIR on c:, I get file not found (just like your first screen shot on your c: drive). C: is my system drive though. It is a Crucial M4 SSD.
Any ideas?
I got stuck in this startup infinite loop after trying to flash my BIOS. The bios supposedly flashed correctly, but something when wrong upon first startup after the flash I guess. I flashed back to the previous bios, but no luck; the damage was done I guess.

Any help greatly appreciated!
My System SpecsSystem Spec
29 Mar 2015   #445

Win 7 64
OP You are a god amongst gods


I dont normally take the time to do this, but I have been fumbling around on the interwebz trying to find a fix to this issue.

THANK YOU for knowing what you are talking about

Rogue from New Zealand
My System SpecsSystem Spec
04 May 2015   #446

Windows 7 Ultimate 64 bit

just join in to reply to this thread.... going thru this problem hour ago ,follow op's method.. since i dont have any windows repair disc and no empty disc available to burn one at that moment, i create one using usb stick (googled for the method).. followed thru the step until it gives error on step 12. after i typed "copy *.* mybackup" , it stops on 'SAM' for a couple minutes and give error "data error (cyclic redundancy check)" . googled for it again and found out i need to run the chkdsk command.. knowing it will take some time, i go thru this thread again to check if theres any other way. on page 1 post #4,

Quote   Quote: Originally Posted by wigwam View Post
You do know doing a chkdsk normally repairs this or if you go to F8 and disable automatic restarts on system failure.

work on a help desk and this normally resolves the issue
tried the f8 method, it stopped looping ,instead give blue screen with an error "C:\Windows\System32\api-mx32.dll is either not designed to run on windows or it contains an error" . after that i boot in safe mode, go to the specified path and delete the dll, restart, and it boot like normal again. lol. after the hassle of creating the windows recovery disc.. just one simple solution -.-
My System SpecsSystem Spec
27 May 2015   #447

Windows 7&XP Pro x64/x32

Trying to revive a Dell Optiplex 580 - Win 7 Pro x32 stuck in the repair boot loop.
I've worked through this tutorial up to step 10. I get a "File Not Found" error when checking the /config dir. - It might be worth noting that it takes several minutes (>10) for the DIR command to run.
Confirmed user profiles and files are intact by plugging HDD into an external. Any suggestions? Kill it with fire?
My System SpecsSystem Spec
08 Jun 2015   #448

windows 7 Ultimate 32bit
Other Possible Solution

I did everything yet still im in the loop.ive been following everthing got no error but the startup repair still appearing and I cant fix it help me please!!
My System SpecsSystem Spec
08 Jul 2015   #449
Jonny 2K

Windows 10 Technical Preview

What do you do if the files are all 0 bytes?
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Startup Repair Infinite Loop Recovery
Help Guys, i did a startup repair infinite loop recovery, because my desktop hard disk wont boot normally so after the successfully of the repair, all my files in partition drive "D" is also back on the earlier files. how to get back to the previous windows registry. please help, ...
General Discussion
startup repair infinite loop after BIOS update, recovery not working
Hello, I recently attempted to update my BIOS (Gigabyte F8 to F10) so that I could upgrade my CPU from a sandy bridge to an ivy bridge. I did not do the cpu upgrade, yet, just the BIOS flash. The flash, using Gigabyte's q-flash) went fine, according to the flash results screen. I then rebooted,...
General Discussion
Startup Repair Infinite Loop Recovery
I now hope I am in the right spot to get some help. I am new at this stuff and I couldn't figure out how and where to post my problem. Now I implemented the tutorial about my problem and it worked just great except that whenever I start or restart, the problem is still there and I have to use...
Performance & Maintenance
Startup Repair Infinite Loop
Im having problems and am stuck in the infinite loop on startup repair. I have followed the tutorial i'm getting down to point 10 10) Type DIR and press <ENTER>, and verify that the following files and folders...
Performance & Maintenance
Startup Repair Infinite Loop
Hi, New to the forum here, hope to get some help :confused: Running windows 7 ultimate 32 bit on my computer, which ran fine until recently, where the taskbar will stop responding after I booted my computer, which eventually leads to the entire system freezing. Usually a reboot solves the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:01.
Twitter Facebook