Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Mail

17 Dec 2016   #1760
prukeyhi

98SE/XP/windows7 ultimate 32bit
 
 

Thanks endeavor for your answer,
you know sometimes small things can drive you mad when there is no explanation ...
i just wanted to be sure i'm doing things fine.
thanks for patience as well.


My System SpecsSystem Spec
.
23 Jan 2017   #1761
endeavor

Vista/Win7/Win8/Win10 (x86/x64)
 
 

Quote   Quote: Originally Posted by prukeyhi View Post
Windows mail is missing/blank from Open With window
Hi all
after reinstate windows mail into 2 machine (all works fine now )
i noticed in one machine that windows mail is absent from "open with" window,
even though it is present in default program->associate file types or protocol....
How can i fix that?
i think its a registry key but its only a guess
*windows mail is default mail
i really want to avoid reinstate windows mail again...
Thanks!
I want to answer that question this long way around please, just so you will get used to where to post and where to look for answers for WinMail problems on Windows 7
On Page1 of the very First Post in this thread, and up on top one of the very first lines it says:
Please see the Errata post...
Click that Errata link please - which brings to the Errata (Bugs List) post, and scroll down about half the page to where it says:
<~ If for some reason your right click on a file and.....>
...now right after that you will see where it says Screenshot 1 or Screenshot 2 - I think your issue is Screenshot 2 and so click it and follow the detail of what it suggests... ...and then post back here with how you made out.
My System SpecsSystem Spec
24 Jan 2017   #1762
prukeyhi

98SE/XP/windows7 ultimate 32bit
 
 

Thanks for detailed checkup!
-right click on a file and ''SendTo: Mail Recipient'' is working fine
-
WinMail is set as the default email client via the Control Panel as shown exactly as in this Screenshot 1 and Screenshot 2
-windows mail is still absent from "open with" window (as my photo show)
again, i do think its a registry key but its only a guess since in other win 7 pc there is no such issue.

*sfc /verifyonly show no violation


Attached Images
Windows Mail-untitled.jpg 
My System SpecsSystem Spec
24 Jan 2017   #1763
endeavor

Vista/Win7/Win8/Win10 (x86/x64)
 
 

Just curious, did you try and install another email application on that pc?

Anyway all of your your MailTo protocol associations should have been already set when the re-instate process merged the winmailedit.reg file . . . in the proper order of events.

Anyway for now, d-click to merge just the reg file: 'WinMailEdit.reg' again, reboot, and report back.
(hopefully that will re-set the ....\WindowsMail.Url.Mailto\DefaultIcon icon)

PS,
Besides the fact that your 'Associate File Type' screenshot does not have the WinMail icon showing in its 'selection box' ...I can still see importantly that you have WinMail set as default, as I circled in red Here..

...and so besides that small issue of the missing icon in that box, more importantly, please tell me exactly what is not working on your WM Client itself ? ? ?
My System SpecsSystem Spec
.

24 Jan 2017   #1764
prukeyhi

98SE/XP/windows7 ultimate 32bit
 
 

-i did not install another email application.
-merged the winmailedit.reg did not help...
- i do have have WinMail set as default
-All works fine besides the missing icon in that box (small issue but annoying)
If you'll come up with something pleas e let me know
Thanks for your help
i appreciate it !
My System SpecsSystem Spec
24 Jan 2017   #1765
endeavor

Vista/Win7/Win8/Win10 (x86/x64)
 
 

~fwiw, a lot if various parameters are set upon first use, I've seen (actually tracked) dozens (sometimes hundreds) of entries get set as each function of WinMail is used for the 'first time' after setup ..and so please just for gp, follow through completely with using the Send To: Mail Recipient
..send to: a file to yourself in an email, but just follow though using the function to see if that position sets.

~Also for gp, take a screenshot on what your pc shows, of what yours shows compared to what the 'bottom' of my 'screenshot 2' shows with those three boxes check marks set (I just want to see it is all)

~Also for gp, do this to check, right click in the open on your Desktop, create New> Text Document ...and rename it something like test.txt, and now rename the extension of it to txt.eml, then if not immediately or about 15 seconds it should now change and show itself with the WM icon, and then when you right click it, and up in the column list, select "Open With" and see if you have WinMail listed in there? ...if it is (or browse it there) and select it, and click OK - I just want to go through with the process to set inner workings .. (no need to open it after since it's not a real email file, but if/when you actually file>save a particular email out of WM to your desktop, is when at that time it will open and you can read it normally (I use that function a lot))

...I can't think of anything else right now, but the answer is simple in this case; however again, and Importantly, if everything is working fine is what matters! ..with this WinMail re-instated on Win7 process, and you can just file this small issue of yours as another one for your post #1762 list ...LoL
My System SpecsSystem Spec
24 Jan 2017   #1766
prukeyhi

98SE/XP/windows7 ultimate 32bit
 
 
man what a mess...

screen 1 - upon renaming to .eml the icon is changing.
right click show no menu ,when i hit the line "open with.." from the menu there is no recommended program and i get the list of programs not including windows mail. (So it's the 2nd place where windows mail is not shown in the program box )
in my second win 7 machine -right click show no menu,but upon hit the line "open with.." windows mail is the chosen marked recommended program.
screen 2 - you asked for three boxes check.
screen 3- if i hit twice the icon .eml it opens a mail window as you see.
screen 4 - something totally weird
after right click the .eml i got the list of programs (as in screen 1)i choose "browse" and selected "WinMail.exe" .when i hit it Anydvd was chosen, i tried again to re select WinMail.exe but Anydvd was chosen instead...
* .eml - does not appear in "associate a file type or protocol with a program" in both win7 machine.
At this point i did a system restore back to the point i started .
-i think that WinMail.exe or other component of windows mail is not register as it should be, and i have no clue why Anydvd was chosen....


Attached Thumbnails
Windows Mail-1.jpg   Windows Mail-2.jpg   Windows Mail-3.jpg  
Attached Images
Windows Mail-4.jpg 
My System SpecsSystem Spec
24 Jan 2017   #1767
endeavor

Vista/Win7/Win8/Win10 (x86/x64)
 
 

(..just a fyi, sometimes (but not always) with big or many screenshots, for the forum rendering sake you can just put a link in like i did, and that's why i did it like that..)

Quote   Quote: Originally Posted by prukeyhi View Post
screen 4 - something totally weird
after right click the .eml i got the list of programs (as in screen 1)i choose "browse" and selected "WinMail.exe" .when i hit it Anydvd was chosen, i tried again to re select WinMail.exe but Anydvd was chosen instead...
* .eml - does not appear in "associate a file type or protocol with a program" in both win7 machine.

At this point i did a system restore back to the point i started.

Okay to your screenshots, and that's why I had you go through those motions of different things and screenshots so we could visually see what anomalies show up, just like we see there, which is your answer.

Now, that's an old version of SlyFox AnyDVD and not the new RedFox version which is certainly fine! ...but my point is, depending on what version and most importantly where you got it from (it's not my business) ..but my point is that there are versions of SlyFox installers out there that do not 'hash check' or verify to the original, or patches, etc, that have viruses in them that will cause all kinds of havoc. Otherwise if everything is legit well then you have other issues, which are not WinMail thread related.

Anyway you did the right thing to do a restore for sure, but what kind of restore?
Hopefully you have a complete OS backup partition image restore that's old enough to get back to a point Before the offending problems were introduced that will set you free, especially if it's a virus or trojan not identifiable by current methods, then going back is imperative! ..imho
My System SpecsSystem Spec
24 Jan 2017   #1768
prukeyhi

98SE/XP/windows7 ultimate 32bit
 
 

thanks for your screen shot advice,
-Anydvd is fine, the same version is on my 2nd machine so i do not think that's the issue.
- i did system restore(windows build in) and i use backup constantly on ext . hard drive.
-virus or trojan malware are out of the question - i use constantly MBAM, MSE, ESET online 1/month.
so we could not solve the issue unfortunately
though i do wonder why program box (open with) does not including windows mail
maybe it'll fix by itself somehow...
Thanks again for your dedicated help!
Cheers
My System SpecsSystem Spec
24 Jan 2017   #1769
endeavor

Vista/Win7/Win8/Win10 (x86/x64)
 
 

As for your AV I said not currently identifiable no matter what you have installed, but if your sure it's not that then okay good. Anyway you have something wrong, and so you can not rule anything out so easily.
Your issue is not going to fix itself though. Hopefully it's simple.

A full OS partition backup to a point in time, I'd guess to before you installed AnyDVD, will fix it.

(fwiw to your previous message .eml is not listed in my association list either, but it's Not the problem anyway)

I doubt it, but you also could have corrupted icons fixable by Options 1 on this tutorial:
Icon Cache - Rebuild
..or icons association could be corrupted, but you would think that many would be off.

When I previously said merge the WinMailEdit.reg, I specifically meant the current one dated 6/1/2015 out of the TutReWinMail folder - I'll assume that's the one you did.

I've said this before and I'll say it again that re-instating WinMail is really simple and takes just a few minutes, and when it's done on a fresh install of Windows 7 (or method for 8 or 10) it will Not have any of these problems!
It actually takes longer to type this message than it does to re-instate WinMail

These problems you are having are not caused by WinMail. It's something you inadvertently did as evidenced by what's showing on your last screenshot.
My System SpecsSystem Spec
Reply

 Windows Mail




Thread Tools




Similar help and support threads
Thread Forum
Windows Live Mail not receiving calendar info from Outlook mail
Our Windows Live Mail accounts receive blank messages when someone sends a calendar appointment request from an Outlook account. The same message arrives correctly in a gmail account or in my Outlook account at work. Is this a Live Mail Configuration issue?
Browsers & Mail
Export mail and contacts from Outlook 2007 to Windows live mail 2012?
I have an Windows (Vista) notebook with outlook 2007, and now I have an new notebook with Windows 8.1. Where I want to export my mail & contact to Windows live mail, how can I import this in WLM on my other notebook? I already have configure my mail on WLM where I can receive and send messages....
Browsers & Mail
Windows Live Mail password request to recieve my ATT/Yahoo mail
In recent days I was asked by ATT.net Yahoo to change my password and did. Windows Live Mail will not allow a password (anything..?) change... and simply reverts to what was. I need to correct the password each time it opens and am able to receive receive mail, but.. WLM will not change...???
Browsers & Mail
How can I make Windows Mail message store work in Windows Live Mail
My sister-in-law’s Window Mail is now inoperative and now wants to use Windows Live Mail instead. I have installed a Windows Live Mail POP account for her on my computer which is working satisfactory but she wants her old Windows Mail messages. I managed to have save her Windows Mail message...
Browsers & Mail
windows 7 32bit live mail with time warner wi rr/ sending e-mail
I can receive mail and send mail but the target does not receive it, I get no error message but my sent box says it was sent, this has been going on now for about at least three weeks, I have sent mail out of roadrunner direct with no problem, I have been using this program for about three years...
Browsers & Mail
Can no longer send e-mail with Windows Live Mail, error 0x800ccc78
Hi, I have been using WLM for some years. Yesterday, it stopped sending emails and now just leaves them in the Outbox. Here is most of what appears in the error box: The message could not be sent because the server rejected the sender's email address. The sender's email address was...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App