Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Active X will not install

15 Feb 2010   #1

Windows 7
Active X will not install

I have Windows 7 64 bit using IE8. I am trying to open a Tekla web model but get an error message "Error: WebVeiwer active-x control could not be loaded. You might not have the needed permissions to install the component". I do have this working multiple machines but I have two that I get this error with.

I have checked all internet security setting.
I am a domain admin.
There are no active x policies on the network.

Please help.

My System SpecsSystem Spec
15 Feb 2010   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Welcome to the Forum

Did you to tools (top of IE)>internet options>security>custom level and make sure all the proper boxes are checked for Active X.

I did read your post where you mentioned security, but it is good to be sure we are on the same page.
My System SpecsSystem Spec
16 Feb 2010   #3

Windows 7

Thank you for the reply. I think I have a good lead on whats going on. For some reason when I try to open a Tekla Web Model the computer blocks the installation of "zkitlib.dll" into the the Downloaded Program Files. I did notice by accident though when I installed my Roxio CD Creator the .dll was installed and I was able to run my web model with no problems.

So I believe that the system is not trusting my web model to install the .dll and somehow the Roxio is trusted and installed. Please let me know if I am on the right track.

this is a test box so I am not worried about messing anything up. I tried lowering all of my security settings and making myself the admin on the box (already network admin) but it still will not work.

Forgot to mention that the firewall is shut off and nothing is being block on the net.
My System SpecsSystem Spec

16 Feb 2010   #4
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Try the instructions here:
Powered by Google Docs
My System SpecsSystem Spec
07 Jul 2011   #5

Windows 7 Pro X64


I am a Tekla user too, and I have the same problem.

Did you figure out the solution?
My System SpecsSystem Spec
04 Jan 2013   #6

window 7 Professional 64 bit

On my PC this problem arised with a (first) model I recieved by email.
active-x did not install because the file was blocked by the OS.
Go to the \dll subfolder, right-click on "zkitlib.dll" and choose properties.
click on unblock (first tab, lower right)
repeat for the other dll and the index.htm files

Should work then
My System SpecsSystem Spec
08 Jul 2013   #7

Windows 7 Home Premium 64 bit

Dear maartenvdl,
Thanks a ton for the solution..i was on a wild goose chase for 3 weeks. I had to download a file and then run it in my system windows 7 home premium ie8 the active x were not installing..i followed ur advice and right clicked on each file in the downloaded folder ( dll and others) and unblocked it and then there was no issue..i was on the verge of buying a new machine for this..
thanks again.. you rock..
My System SpecsSystem Spec

 Active X will not install

Thread Tools

Similar help and support threads
Thread Forum
C: not marked as active after clean install.
Should i mark it as active?
Hardware & Devices
Active Partition Question on new Win7 Install
I recently upgraded from winXP x64 to win7 Ultimate. I added a 128 GB SSD drive (C) and have one 2 tb (D & E) and one 1 tb (F) hard drive. I've been installing most of my applications on the D partition and data on E and a data backup on F. Everything was fine until I temporarily added another...
Installation & Setup
Safely marking new Win7 install as active
So, basically, after salvaging an old laptop that had Vista preinstalled, and without thinking, I shrinked the 70GB partition, and used the free space to install Windows 7. Now, I'm not saying it's broken, but I want to get rid of the Vista partition, and I want to do it without the installation...
General Discussion
Cannot install active x control
I'm trying to download and install an active x control to enable me to watch internet tv from my ISP, but I keep getting this I've tried turning off the firewall and UAC but to no avail. I've also tried turning off security settings in IE, and adding the website as trusted, but still no joy....
System Security
active sync 4.0 won't install on w7
Does anyone know why I can't install active sync on my windows 7? I'm running 64-bit. I just got an HP ipaq HX2795 pda and need to install the software on my computer, but it won't take it--even after going to the properties and selecting compatibility mode. Thanks!

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App