Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Frequent system hangs, "atapi Event ID 11" in Event Viewer

31 Aug 2015   #1

Windows 7 Home Premium 64-bit
Frequent system hangs, "atapi Event ID 11" in Event Viewer

Hi, I recently made some upgrades to a (previously fine) PC - they were

- Installing 4GB extra RAM, of the same variety
- Reinstalling windows on a new SSD (a Samsung SSD 850 EVO 500GB)

I previously also upgraded to Windows 10, but a bunch of blue screens and other issues later I reinstalled 7. I'm still having problems though - the current symptoms are that every so often (1-3 times a day) the computer will hang for ~1-2 minutes on the 'starting windows' screen. When it finally loads, it will often hang for further extended periods before settling down. I checked in these event log and during these periods there will be many 'atapi' errors, with Event ID 11 "The driver detected a controller error on \Device\Ide\IdePort0." (I have attached a screenshot).

There will sometimes be other errors, usually relating to the timeout of certain things, but the previously mentioned error is by far the most prolific. On rare occasions there have been more serious errors - never blue screens since going back to windows 7, but once I booted to a black screen with just a mouse (was able to shut down via task manager then following a restart seemed ok).

Through some investigation, it does seem to be that the root cause of the problem is the SSD; I identified this a while ago and have tried various fixes, including:

  • Ensuring my Motherboard (a M4A78LT-M) SATA ports are configured in AHCI mode (they were previously IDE). This also led me to completely re-installing windows in an effort to make sure the correct drivers were installed (though more on those drivers in a second).
  • Updating my motherboard's BIOS.
  • Running MemTest to check my RAM wasn't causing the problem.
  • Changing the SATA cable and port of my SSD.
  • Updating various drivers from ASUSTeK Computer Inc. -Support- Drivers and Download M4A78LT-M for my motherboard, including the chipset. I saw another driver for "AMD AHCI Compatible RAID Controller Driver V3.1.1540.127", but when I try and updating this windows just says that the most up to date driver is already installed.
  • I've also tried running various checks for disk errors, including the Windows built-in drive checker and HD tune pro.
  • I just tried unplugging my DVD drive as well, which is the only other thing connected to the SATA ports.
On a side note, I do not have the 6Gb/s SATA 3 ports, only 3Gb/s SATA 2, though I don't see why this should be a problem.
I've of course looked online and have found many people with similar issues, but often they seem unresolved, or their fixes unfortunately don't work for me. Any help would be massively appreciated as this has been plaguing me for weeks!

Attached Images
Frequent system hangs, "atapi Event ID 11" in Event Viewer-atapi-error.png 
My System SpecsSystem Spec
01 Sep 2015   #2

Microsoft Windows 7 Home Premium SP1 64-bit Build 7600 / Microsoft Windows XP Professional SP3

Do got any SATA drivers installed on this machine? I see this machine has an AMD chipset, which commonly has issues with AHCI, I had similar issues with mine (not the same board, but AMD chipset too), I see this is SB710 chipset, I would reccomend you to go to AMD and download their latest package:
This includes AHCI drivers, which I'm almost sure are the only ones needed.

Either run the installer, or, when downloaded, use Universal extractor to extract the drivers, in there, find the "amd_sata.msi" file under W764A folder and run it, it should update your ACHI drivers, and those errors should be gone.

Hope this helps :)
My System SpecsSystem Spec
02 Sep 2015   #3

Windows 7 Home Premium 64-bit


thanks for the response - though I did actually see that link at the top of the forums after posting. I updated the chipset, and when doing so the catalyst install manager said there was no AHCI driver installed. So I installed it, along with the other recommended drivers. I restarted and a driver was installed for my SSD. Restarted a couple more times and no problems.

The following day however my system again hung for a long time on the 'starting windows' screen, only this time with a different error message was displayed in event manager (similar to the one I mentioned previously):

amd_sata, event ID 129:
"Reset to device, /Device/RaidPort0, was issued"
(plus it was only a warning rather than an error).
Other than that, no major issues on that day.

The following day however (today), things have taken a turn for the worse - I blue-screened, with the error "System Service Exception" (Crash report attached, will also create a post in the BSoD help section)

Upon restarting, the screen was stuck on 'Starting Windows' for a good 5 minutes or so. Once loaded, The system continued to hang for a while, and I was greeted with the following error message:

"WerFault.exe - Application Error

The exception Illegal Instruction
An attempt was made to execute and illegal instruction
(0xc000001d) occurred in the application at location 0xf484a784."

I then tried to open event viewer, which gave the previous error, followed by another. I tried to load up my browser (firefox) to go here and get the crash report made, but that didn't work either.In the end Internet explorer worked though, and I created the file, attached.

When I restarted again checkdisk ran (let it do its thing). Another restart and it hung again, though this time things seem to be going ok when I reached desktop.

Any further advice would be greatly appreciated. I might try reinstalling the AHCI driver, but I don't really have any other ideas of what I could do!

Attached Files
File Type: zip (786.4 KB, 1 views)
My System SpecsSystem Spec

15 Dec 2015   #4

Windows 7 Ultimate x32

SOLVED! Windows 7 For all those persons trying to track down the Event Viewer "atapi error ID11" without success read on:
I encountered this problem 6 weeks ago with a lot of BSOD's, hang ups and getting more and more desperate as I tried almost every "cure" I could find on the internet. I was about to give in when I carefully thought about what I was doing at the time event viewer first showed this error, which always continued to occur every 20 seconds until the system collapsed. I realised that was about the time when Windows 10 icon was popping up on my PC. I recalled exploring how much capacity I had on an external USB caddy hard drive (removed from an old PC) which I had plugged into my PC, when we had a brief power cut. I subsequently disconnected that USB connection whilst the PC was still powered down and did not use it again. On a hunch I decided to try plugging the USB back into the PC, restarted AND NO MORE ATAPI ERRORS SINCE for nearly 2 weeks since!
This may not be a solution for many people but it was the only one I found that worked.
My System SpecsSystem Spec
14 Jan 2016   #5

Windows 7 Professional SP1 64 Bit

Hi petrolstatus4, My problems are VERY similar to what you have described. Disaster day for me was 10/20/2015 when a bunch of MS Updates occurred (related to the Windows 10 Ad being shoved on everyone). I have spent SO much time getting my laptop to where it even functions again mainly getting rid of whatever I could find that happened on disaster day and turning OFF any ability to get automatic updates for now. Beyond the atapi Event ID 11 error, I have also noticed Service Control Manager Event ID 7001 and Server SMB1xxx Driver which seems to point to a corrupted/missing Driver. Have you noticed this as well? Has your problem been solved? If so, please share. Thanks! TAM125
My System SpecsSystem Spec

 Frequent system hangs, "atapi Event ID 11" in Event Viewer

Thread Tools

Similar help and support threads
Thread Forum
cannot start event viewer "Error code 1899"
Hi All, I've had an issue with Event viewer unable to start due to "endpoint mapper database entry could not be created" Error 1899. I have done a SFC and have had some but not all issues fixed, I have a log of the result and maybe could post if needed. I've also done a system restore to a...
Performance & Maintenance
Atapi errors in event viewer help plz
hi guys, i am getting atapi errors in event viewer, the other day my monitor would not come out of power save mode. i have tester bother my hard drives and they pass. i have also checked my cables and they are fitted ok. i have never had this before and do not know what to do. any help please?
Hardware & Devices
Windows 7 x64 "Event Viewer has stopped working"
Whenever I launch Event Viewer, I get this message. Ditto when I try launching Computer Management. I sometimes get a message about Adding a snap-in to console. But it never works. I ran SFC SCANNOW and it fix some stuff requiring a restart and is running clean now. No improvement. I tried...
General Discussion
New system, no BSOD, but frequent "___is not responding' Event ID 10.
My sys: Win7 64 bit Prem. Home Ed., AMD Phenom II X6, ASUS M4A88T-M socket AM3 mobo, 2X 4GB Corsair memory, 2TB Seagate Barracuda Green HDD, built Aug. 2012 by little ol' me. My problem: Screen will freeze right after logging into user account, it will also freeze when we are in the middle of...
BSOD Help and Support
"Disk error" invisible except to event viewer, when imaging hard drive
My Windows 7 configuration is relatively bullet proof (ha ha, nervous laughter). My OS and programs are on C, which I image using RDriveImage every month after Patch Tuesday. My data is on software-mirrored D/F drives. So as long as I don't have a catastrophic event affecting my computer,...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:46.
Twitter Facebook Google+