Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Game Compatibility List

02 Jun 2010   #361

Windows 7 Home Premium 64-bit
My games - working/not

Win7, HP, x64

Working - admin/XP-SP3 switch


NOT working, tried admin/compatibility switches - apps crash
- future pinball (Future Pinball)
- visual pinball ( Home Page)

apps crash with "app has stopped working" - no explanation

My System SpecsSystem Spec
12 Jun 2010   #362
Carl Lawrence

Dual-boot: Windows 7 HP 32-bit SP1 & Windows XP Pro 32-bit SP2.

Here are some old games at work or not work with Windows 7:


Monster Truck Madness 1

Needs patching:

Insane (you need to install patch, just google it.)

Doesn't work at all:
Speedbusters (error: Wrong Windows error.)
My System SpecsSystem Spec
13 Jun 2010   #363

Windows 7 Professional 64 bits
Warlords Battlecry III...

...currently running on my Seven 64bits.

1. To upgrade from 1.00 to 1.03, use the patch found on
Patches and Fixes: Warlords Battlecry 3 v1.03 Full Patch - Demo Movie Patch Download Section -
The other patchs don't run on Seven 64bits.

2. Use Windows XP SP3 compatibility.
My System SpecsSystem Spec

25 Jun 2010   #364

Windows 7 x64 Ultimate
Some more to add

The following have been tested on Win 7 Ultimate (32-bit/x86), Ver. 6.1 Build 7600 - with the latest 'windows updates' (as of today )

Alot of small-time games, that are pretty much obsolete now.

Network Q Rally Championship
Late nineties 3D rally game. Doesnt install, due to its age it uses a 16-bit DOS installer. If you do start INSTALL.EXE, cmd opens and you get:
This system does not support fullscreen mode. Choose 'Close' to terminate the application
(for anyone interested, this plays perfectly on XP SP3)

Classic Car Racing (1C Company)

Harry Potter & The Half-Blood Prince

Sabrina The Teenage Witch: Brat Attack (1999, Simon & Schuster/Knowledge Adventure)
[Amazingly, but im sure no one really cares all that much]

Street Legal

[i dont own this game any more, but i am 100% certain it installed and played out of the box.]

Worms 2
(Team17, 1997)
REQUIRES WORK-AROUND: Installs fine (if using a more modern distro, i.e. Sold Out Software), but will not run properly (you will get colour corruption, i.e. everything goes an awful pink or green colour.) unless you end the process "explorer.exe" before playing. Other than that, works fine.

As a side note, when will we be seeing this 'google doc' ?
If and when its up and running, im very happy to contriubte or even help with the upkeep.
Also do you want compability for those 'shareware' games you get on games compilation discs (i.e. Daisy's Garden)?

Got more games to come, going through my library now!
My System SpecsSystem Spec
25 Jun 2010   #365

Windows 7 x64 Ultimate

Empire Earth Gold - does not work. Installs fine, then the .exe runs and then closes itself. Tried compability settings and the stop explorer.exe trick - still no luck.
My System SpecsSystem Spec
29 Jun 2010   #366

Windows 7 Ultimate 64 bit

here's my share its Important to read this before reading my games list.. i ran tested this games with this OS and GPU

NOTE: All major games in listed here None of it that brought in STEAM or any online like Direct2Drive but most of it are came from the retail BOX


OS: Windows 7 32bit 7600
CPU: Intel Core2Duo E7500 2.93Ghz
Motherboard: Asus P5KPL-AM
GPU:Geforce 9500GT



OS: Windows 7 64 bit 7600
CPU: Intel Core2Duo E7500 2.932Ghz
Motherboard: Asus P5KPL-AM/SE
GPU: Geforce 9800GT

my both Windows are 7600 version

Worked without any huge issue, the colored blue titles it means its still existed in my hard drive so if you have a doubt about it you can ask me i could send you some screen shot for prof... without colored titles are not in my hard drive anymore but if its possible we can talk about it so i can tested it for you, i added some version as i remembered others i can't remember the version but i can guarantee you all this game are tested and running accordingly

as you can see there's (Unpatched) and some are patched version as i remember others i really don't remember the version and i don't know if that certain game has newer patch to make it work or fix the any problem yet its still work..


The Simpsons Hit & Run (Unpatched) - 32bit / 64bit
Gothic II Gold - 32bit / 64bit
Gothic III - 32bit / 64bit
Gothic III Forsaken Gods Stand Alone Expansion Pack - 32bit / 64bit
AVATAR The Game (Unpatched) - 32bit / 64bit
Bionic Commando (Unpatched) - 32bit / 64bit
The Movies (Unpatched) - 32bit / 64bit
Timeshift (1.01) - 32bit / 64bit
Splinter Cell Double Agent (1.2) - 32bit / 64bit
Splinter Cell Chaos Theory (Unpatched) - 32bit / 64bit
RollerCoaster Tycoon 2 (Unpatched) - 32bit / i haven't tried on my PC2/64bit
RollerCoaster Tycoon 3 with Soaked/Wild Expansion - 32bit / 64bit
Stalker Call of Pripyat - 32bit / 64bit
Stalker Clear Sky - 32bit / 64bit
Operation Flashpoint Resistance (1.96) - 64bit / i haven't tried on PC1/32bit

The Sims, with Livin' Large,House Party,Hot Date,Vacation,Unleashed,Superstar,Makin' Magic
Expansion Pack
- 32bit / 64bit

Boiling Point Road To Hell (2.0) - 32bit / 64bit

Hitman Blood Money (1.2) - 32bit / 64bit there's a slight issue here this game works with random OS Compatibilities if i use XP(SP3) it works but then again when i play it again im receiving a "Not Responding" pop up so i need to tested other OS Compatibility to make it work again its just random or its just me?

Teenage Ninja Turtles 2 Battle Nexus (Unpatched) - 32bit / haven't tried on PC2/64bit
The Suffering Ties That Binds (Unpatched) - 32bit / i haven't tried on PC2/64bit , but it needs XP Compatibilities
The Suffering (Unpatched) - 32bit , it needs XP Compatibilities

Dynasty Warriors Orochi (Unpatched) - 32bit / 64bit , a slight issue which sometimes gives a fully throttle that can run the game into highest frame rate like over 100FPS but sometimes when exit the game and played it again it backs to normal sometimes you need to ALT+TAB minimize and maximize the game Window in order to solve the unstable framerate problem

Mass Effect (Unpatched) - 32bit / 64bit
Prison Tycoon 3 (Unpatched) - 32bit / 64bit you need XP Compatibility to run it
Final Fantasy 7 (Unpatched) - 32bit / 64bit sometimes it needs to set to XP Compatibility mode

Half-Life, Tested MODS Earth Special Force,Counter-Strike 1.6 - 32bit / 64bit , but im having a random exit when i use MODS like Firearms and The Specialist i haven't tested the other MODS

Counter-Strike Condition Zero - P32bit / 64bit
SimCity 4 Deluxe (Unpatched) - 32bit / 64bit
Car Tycoon (Unpatched) - 32bit / 64bit
Stronghold Crusaders (Unpatched) - 32bit / 64bit

Thief 3 (Unpatched) - 32bit / 64bit , the game runs fine on normal version but as soon as i patch it im getting a random crash

Deux Ex Invisible Wars (Unpatched) - 32bit / 64bit
Indego Prophecy a.k.a Fahrenheit (Unpatched) - 64bit
Mall Tycoon (Unpatched) - 64bit
The Settlers IV - 32bit / 64bit
Enter The Matrix - 32bit / 64bit
The Matrix Path of Neo (1.2) - 32bit / 64bit
Plant Vs Zombies(Unpatched) - 32bit / 64bit
Penumbra Black Plague(Unpatched) - 64bit
Zombie Shooter(Unpatched)- 32bit / 64bit
Zombie Driver(Unpatched) - 32bit / 64bit
Fort Zombie(Unpatched) - im getting Not Responding message so i haven't played it but i don't if the new patch work now
Still Life 2(Unpatched) - 64bit / i haven't tried on 32bit
Harry Potter and The Order of Phoenix(Unpatched) - 64bit
Neverwinter Nights 2 (1.23.1763) - 32bit / 64bit
Elven Legacy(Unpatched) - 32bit
NBA2K10(Unpatched) - 32bit / 64bit
Juiced 2 Hot Imports Night(Unpatched) - 64bit
Starwars Force Unleashed (1.2) - 32bit / 64bit
Tomb Raider Underworld (1.1) - 32bit / 64bit
Half-Life 2 Orange Box(Unpatched) - 32bit / 64bit
Condemned Criminal Origins(Unpatched) - 32bit / 64bit
Watch Men The End is Nigh Part 2(Unpatched) - 32bit / 64bitPC1/PC2
Dark Sector(Unpatched) - 32bit / 64bit
Saints Row 2(Unpatched) - 32bit / 64bit , but there was a throttle problem the frame rate is incredibly x3 faster but i don't know if there's a new patch for unstable framerate fix

Red Faction Guerrilla (1.2) - 32bit / 64bit , it has throttle problem or unstable of framrate but since i patch it to latest patch it backs to normal

Bully Scholarship Edition(Unpatched) - 32bit / 64bit
Batman Arkham Asylum(1.1) - 32bit / 64bit
Alone in the Dark(Unpatched) - 64bit
ARMA Armed Assault (1.14) - 32bit / 64bit
ARMA 2 (1.5) - 32bit / 64bit
Lost Planet Extreme Condition(Unpatched) - 32bit / 64bit
Solder of Fortune Payback (Unpatched) - 32bit , but it has a sound problem seconds later it crashed
The Godfather II(Unpatched) - 32bit / 64bit
Overlord(1.4) - 32bit / 64bit
Assassins Creed 2(1.1) - 32bit / 64bit
Velvet Assassin(Unpatched) - 32bit / 64bit
Dawn of War Dark Crusade(Unpatched) - 32bit / 64bit
Stormrise(Unpatched) - 32bit / 64bit
Killing Floor(10.25.2009) - 32bit / 64bit
Death Track(Unpatched) - 32bit / 64bit
Onimusha(Unpatched) - 32bit / 64bit
Devil May Cry 3(Unpatched) - 32bit / 64bit
Escape from Paradise City( - 32bit / 64bit
Men of War(Unpatched) - 32bit / 64bit
Daemon Vector(Unpatched) - 64bit
GTA 4( - 32bit / 64bit
Wanted Weapons of Fate(Unpatched) - 32bit / 64bit
Rise of the Argonauts(Unpatched) - 32bit / 64bit
Fuel(Unpatched)-32bit / 64bit
Dark Horizon(Unpatched) - 32bit / 64bit
Resident Evil 5(Unpatched) - 32bit / 64bit
WALL-E(Unpatched) - 64bit
Guitar Hero World Tour(Unpatched) - 32bit / 64bit
Saw the video game(Unpatched) - 32bit / 64bit
Majesty 2(Unpatched)- 32bit / 64bit
Divinity II Ego Dragonis(1.03) - 64bit
F.E.A.R(Unpatched)- 32bit / 64bit
You Are Empty(Unpatched) - 64bit , XP/Vista Mode

Silver Fall Earth Awakening(Unpatched) - 32bit , i got some pinky glitches all over the screen i mean everywhere but i dont know if its related to W7 and i don't know either if there's newer patch for W7 fix or the glitch

Rainbow Six Vegas 2(Unpatched) - 32bit / 64bit
Legendary(Unpatched) - 32bit / 64bit

Bioshock(Unpatched) - 32bit / 64bit , you need a XP mode to play it otherwise you well experiencing a unstable sound even crashes

Bioshock 2(Unpatched) - 64bit
Prey - 32bit / 64bit
El Matador(Unpatched) - 32bit / 64bit
L.A Rush(Unpatched) - 32bit / 64bit
Lord of the Rings Conquest(Unpatched) - 32bit / 64bit
Empire Earth 2(Unpatched) - 32bit / 64bit
Mercenaries 2(Unpatched) - 32bit / 64bit
FarCry 2(Unpatched) - 32bit / 64bit

most of it here are haven't tested on both PC's architecture either 32bit or 64bit but most of them are working perfectly i still have many games unlisted and untested i may can't update my list frequently so just ask me i may can help you with it
My System SpecsSystem Spec
30 Jun 2010   #367

Windows XP

My System SpecsSystem Spec
01 Jul 2010   #368

Windows 7 Retail

W7 Ultimate 64

I posted a thread on the Allods website about the issue I'm having:
Allods Online - A Completely Free To Play Online Game! • View topic - Allods Online blocked by Windows Firewall

Basically, it installs fine. Shortcut is set to launch from the "launcher.exe" file. But when I try to launch it, I get this weird error. After lots of troubleshooting, I tried launching it from another file in the program folder. "AOgame.exe". It launched fine. However, it crashes after about half an hour of game play. So I have to keep relogging in.
My System SpecsSystem Spec
07 Jul 2010   #369

7 Ultimate x64 SP1

The Elder Scrolls IV: Oblivion (x64)
The Elder Scrolls IV: Knights of the Nine (x64)
The Elder Scrolls IV: Shivering Isles (x64)

The Elder Scrolls IV: Oblivion GOTY Edition

Should all be added/placed under the 'Working' category, because all install and play and everything (even the Official DLC add-on contents). No idea about (x86), sorry.
My System SpecsSystem Spec
09 Jul 2010   #370

windows 7 64bit on both

Quote   Quote: Originally Posted by kuliddar View Post
Jane's Fleet Command does not work at all with Win7 x86 (didn't work with Vista either). The game won't even install. You need DosBox to make this work as many other DOS/Win95 games.

i'm thinking of purchasing jane's fleet command again since i got a newer and better desktop. Problem is, i remember it wouldnt work when i had windows vista and i'm concerned about it not working with windows 7. is there any way or are there any programs out there that would be best to make old games work on windows 7? it says it originally worked on windows 95, 98, 2000, and XP.

thanks for any help

i've checked out the dosbox website kuliddar mentioned, but im unsure as to which version i should download. any help here would be appreciated too
My System SpecsSystem Spec

 Windows 7 Game Compatibility List

Thread Tools

Similar help and support threads
Thread Forum
Fresh install Windows 7 and game compatibility
Hi, I would like to ask - I have two partitions on HDD C: for system and programs and D: for games and my files, if I ever want to install fresh Windows 7 x64 Home Premium (right now have exact same system) and format this C: partioin before install, do all insalled games on D: would still work on...
Windows 7 game compatibility issue
Alright, I got an issue. I want to play Age of Empires II: Age of Kings. I'm running Windows 7 64bit. Only thing is, when I put it in to install it, it says "Windows cannot access this disc......This disc might be corrupt, make sure that the disc uses a format that Windows recognizes. Only...
Microsoft Windows 7 Software Compatibility List
Official Microsoft Windows 7 Software Compatibility List is now available for those who want it I have attached a zipped XLSx format file This is obviously a work in progress - latest version should always be available from :ar: Here Latest version ....

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:42.
Twitter Facebook Google+