Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Left 4 Dead Won't Run With Windows 7 Home on Mac *help*

06 Nov 2009   #1
nightfire

os x snow leopard and windows 7 home premium 64-bit through bootcamp
 
 
Left 4 Dead Won't Run With Windows 7 Home on Mac *help*

Hey everybody, I have a little problem here.

Today I just installed windows 7 home premium on my macbook pro, the install went smoothly and I got everything running well. I installed all the drivers for the mac from the mac OS X cd once windows 7 was installed so that the sound and everything else works. I then installed Left 4 Dead and steam and signed in on my steam account. Left 4 Dead updated, then I tried running it only for it to never open.. When I click launch it just says that it's loading, then the little box goes away, and nothing happens. I even tried loading it using admin and using XP and Vista emulations both with service pack 2 and 3. I know I definitely meet the minimum requirements for the game (brand new fully loaded macbook pro) so I'm not getting why the game won't run? Does it have to do with windows 7 or that i'm running it through sandbox on a mac? Although everyone says they are running it just fine. Any help would be greatly appreciated!


My System SpecsSystem Spec
.
06 Nov 2009   #2
gilbo

Windows 7 Professional 64-bit / Vista 32-bit Home Premium Dual Boot
 
 

Have you tried compatability mode?
My System SpecsSystem Spec
06 Nov 2009   #3
Lebon14

Windows 7 Home Premium x64 SP1
 
 

@gilbo : he tried. He just told so.
Have you tried to delete the game and redownload it?
My System SpecsSystem Spec
.

06 Nov 2009   #4
nightfire

os x snow leopard and windows 7 home premium 64-bit through bootcamp
 
 

I haven't tried uninstalling/reinstalling it, I'll do that now and let you know if it works. I have it on disk but the updates were downloaded so I'll just try deleting everything and reinstalling by downloading it instead of from the disk.
My System SpecsSystem Spec
06 Nov 2009   #5
gilbo

Windows 7 Professional 64-bit / Vista 32-bit Home Premium Dual Boot
 
 

Quote   Quote: Originally Posted by Lebon14 View Post
@gilbo : he tried. He just told so.
I didn't realise he meant that by 'emulation' sorry....
My System SpecsSystem Spec
06 Nov 2009   #6
nightfire

os x snow leopard and windows 7 home premium 64-bit through bootcamp
 
 

It didn't work. Once again it said it was preparing to launch with the little box and the screen went black for a second then just back to the normal windows background. Same as last time. Any ideas?
My System SpecsSystem Spec
06 Nov 2009   #7
DarkXeno

Windows 7 Ultimate x64 SP1
 
 

right click the game in steam and defrag the game in there then reboot windows and open steam again to see if there are anymore updates just let it sit for a few minutes then try to run the game again.
My System SpecsSystem Spec
06 Nov 2009   #8
nightfire

os x snow leopard and windows 7 home premium 64-bit through bootcamp
 
 

Can it be something having to do with my video card? I don't know if it needs and update or something but while trying to get a screen saver running in the control panel all it says is "the screen saver can't run because it requires a newer video card or one that's compatible with Direct3D". Is there anyway to check all these settings to make sure everything's running ok?
My System SpecsSystem Spec
06 Nov 2009   #9
nightfire

os x snow leopard and windows 7 home premium 64-bit through bootcamp
 
 

Quote   Quote: Originally Posted by DarkXeno View Post
right click the game in steam and defrag the game in there then reboot windows and open steam again to see if there are anymore updates just let it sit for a few minutes then try to run the game again.
I can't find anything about defraging the game when I right click. When I go to the properties of the game it says there is 0% fragmentation. I've tried restarting and all that several times.
My System SpecsSystem Spec
06 Nov 2009   #10
Xzaviar

6@Win XP 1@Vista (1@Win 7 (Mine))
 
 

Sorry! Have you tried a PC? Games arn't paticullarly Mac friendly.
My System SpecsSystem Spec
Reply

 Left 4 Dead Won't Run With Windows 7 Home on Mac *help*




Thread Tools




Similar help and support threads
Thread Forum
left 4 dead 2
does any 1 play this on steam? i think much people cant play it (say if im wrong) but i heard you need a verry good videocard (i got NVIDEA GTX550)
Gaming
left 4 dead 2 won't run
My problem sounds similar to the guy w/ the mac. I bought a new HP gaming system. Specs: HPE-170f 9GB Memory Processor: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz Video Card: GeForce GTX 260, Memory 1.75 GB Installed steam and L4D2. Won't boot, but doesn't crash. Completely reloaded...
Gaming
Left 4 Dead and CS2 lag
Hi, I have been experiencing lags on my Laptop for Left 4 Dead and CS2. Specs: ACER Aspire 4715 Pentium Dual Core 1GB RAM m965 chipset Windows7 Ultimate I did not have problems with CS2 when I had WinXP but with Windows7, I have some lagging issues. I cannot compare that of left 4 dead...
Gaming
Left 4 Dead on Win 7
Hi SevenForums. In vista I had L4D 1 running perfectly fine. In windows 7 it lags very much, also in singleplayer. I have windows 7 home premium 32 bit. Please help me
Gaming
Left 4 Dead 1 and Windows 7...
Hi, I want to download and buy Left 4 Dead 1 from Steam. I was just wondering if it should work fine on my 7600 Build Windows 7. Here is the link to my setup as well. Newegg.com - HP Pavilion DV6-2144NR NoteBook AMD Turion II M520(2.3GHz) 15.6" 4GB Memory 320GB HDD 7200rpm DVD Super Multi ATI...
Gaming
left 4 dead help pls
worked great with vista , just upgraded to win7. installed all latest win7 drivers from asus homepage, all seems great.. run l4d and after vids in beginning it crashes right away and i have no clue what to do now.. tryed to re-install l4d once still the same..:shock:
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App