Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Privileges problem after clean re-install

10 Jun 2011   #1

Windows 7 Ultimate 64bit
Privileges problem after clean re-install


Several days ago I did a clean reinstall of mi Windows 7 Ultimate x64 OS. I did such an operation several times before, on my PC and on some other computers, and I have never encountered such a problem.

My HDD has two partitions - C, on which the OS is installed, and D where I keep all my programs, photos, etc.

The problem is that after I have reinstalled Windows on the C: partition formatting the drive during the process. Installation went fine, but some folders on t he D: drive are not accessible for me to write/delete in them, and selection of them is quite random e.g. "downloads" or "photos" and also RecycleBin. However I think it may be related to my old network shares - they were shared for my homegroup as far as I remember.

I tried advanced security tab where I wanted to set full control flag on the D:\ for my profile (kuki - administrator level which is actually the same as in my old system) including all subfolders and files (box checked). During that procedure I get the message on folders mentioned before (photos,downloads,recycle bin) - "windows can not read security settings for specified folder".

How can I handle that? I do not like to use my C drive as download and temp folder, so I have a DOWNLOADS folder on D: drive but now I can't use it.. i mean i can make downloads2 etc... but I would like to know the solution if that ever happens again to me.

Any help apprecieted.

My System SpecsSystem Spec
10 Jun 2011   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Try using the built in adminstrator
Built-in Administrator Account - Enable or Disable[2]=User Accounts
Your just the owner hes the boss
My System SpecsSystem Spec
10 Jun 2011   #3

Windows 7 Ultimate 64bit

Will try, but can you tell whether a drive, like my D: partition, connected to the system, like mine, is recognized? if that is NTFS who is the owner of the files if they were not created by that particular system?
That is not working. Using "da boss" account I gave to D: privileges to Administrators (full)(kuki belongs to that group), Users (r&e). Operation finished with no errors, but I still can't save files from web in Downloads nor save edited photos, UNLESS I elevate program I am using to Administrator level.
I have a drive I use for backups. I have connected it and my D: settings are the same as my newly connected drive, but now I have to confirm administrator proviliges for every change, delete or creation in any place in the D: drive... that did not work.
My System SpecsSystem Spec

10 Jun 2011   #4
James Colbert


The drive, having permissions from your other install, may take exception to the new install (perhaps ownership not being exactly the same on all counts...)

If no luck with enabling the hidden admin, you could try TakeOwnership. But do take serious note of the warning not to use it on your system drive or user files.

If that doesn't work (and you have the free space and time), you could copy all of the data on the drive to another partitition or drive, delete the original and paste the files back (hat tip to Boohbah), which, in my experience, is almost guaranteed to return ownership to you.

My System SpecsSystem Spec
10 Jun 2011   #5

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu

This issue has applied to every re-install since the inception of the NTFS file system back in the last century ....

Although we see user names as the same on re-installs the system sees users as numbers that are set for certain system accounts but are variable for user generated users. This results in the administrators group and things such as system account working fine but user accounts borking as you describe.

The way around this problem is at least a two part one and is further complicated in recent Microsoft operating system due to the additional security provided by the UAC and the dual token system.

First thing to do is to take ownership of the root of the Data,(D), drive, using either the available right click option mentioned above or manually - right click on the drive and open the security tab - select advanced and then ownership.

At this point I normally set the owner to my user name from the list available as this circumvents possible UAC glitches in future, also ensure that the option to apply the changes to sub-folders and files is ticked, and statrt the process with apply or OK.

In some cases you may see error messages make a note of these locations for later.

When the process is complete manually navigate to the root of any problem folders noted above and repeat the process until all items are owned correctly.

At this point go back to the permissions tab in the advanced screen at the root of the drive and remove any unknown accounts ( I have seen 10 or more of these on multi-user systems which have been re-installed ), and add your own user account to the list with full rights - if you wish others to be able to access these files over a network it is a good idea to add the permissions for these users or the everyone user also at this time - ensure that the apply to subfolders and files is checked and again make note of and manually change any problem areas.

This can take some time to complete depending on the complexity of the file structure and number of problem areas - it may of course work straight through first time .

sorry for the long explanation but it can be rather involved, which is the price we pay for security
My System SpecsSystem Spec
11 Jun 2011   #6

Windows 7 Ultimate 64bit

Thank you for explanation. That is good. What you are describing is something, I think I have already done.
I have enabled Administrator account, and using it, I took ownership of the root of the partition D: (there were some items with no owner at all - they are problematic - however I think Windows 7 during reinstall should take ownership of the files from every installed drive, at least I never have had such an issue before SP1 for W7).Afterwards I have changed owner to Kuki. Then in security tab I gave a full control permission to Administrators group and to my account (which is also in Administrators group actually). I have switched to Kuki (my account) - and I do not see permissions for account "Kuki" at all!!! When I want to copy a file - I have to elevate, torrent - access denied, batch photo processing - access denied. Now the whole D: is like that, before that were only locations that were shared for the network in my previous windows installation.
My System SpecsSystem Spec
11 Jun 2011   #7

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu

Ok it appears that something is amiss.

what I would suggest is completely removing all permissions on the drive and re-setting them to how you want them ....

Log in as the built in administrator (takes UAC out of the loop), at the root of the drive in the advanced permissions screen

Privileges problem after clean re-install-perms.jpg

make sure that the two check boxes are not checked, remove all permissions and then set the permissions you want for the drive. this just sets the permissions on the root

Remember that due to the way that UAC works, giving permissions to the administrators group, will not give permissions to your user for normal use, so both needs to be added

now go to each folder in the level directly beneath the top level and in the Advanced permissions check the both boxes and apply - agree to the warning box and let the system set the permissions - this will take a while depending on the number of files

My System SpecsSystem Spec
11 Jun 2011   #8

Windows 7 Ultimate 64bit

Thanks a lot! It seems to be working. However for the root D: I had only one check box available, for the 1st level dirs - both of them. I have also removed the read only flag. Recycle bin reports it is corrupt. I think now it is OK.
How should I treat "system volume information" dir?

UPdate: I usually delete with shift+del, so I do not use recycle bin, but sometimes my apps use it and now every time a file is moved to a recycle bin, it reports it is corrupted. How can I fix this?
My System SpecsSystem Spec
11 Jun 2011   #9

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu

If you are logged in as the hidden administrator you should be able to take ownership of the recycle bin tree (show hidden and system files ), you will not be able to delete the root level of the recycle bin but should be able to delete the recycle bins that are nested beneath this level, (these normally show a SID S.....)

you may be able to remove some of the system information entries but the easiest way is to tempraraly switch off the system protection and swapfile entries for the drive concerned (system advanced options)
My System SpecsSystem Spec
11 Jun 2011   #10

Windows 7 Ultimate 64bit

ok, so the best way is to switch off system protection ( which i do not use at all) and pagefile on the drive, then delete system volume information & recycle bin, enable the options above, and i will get a standard working situation under Windows OS?

OK, problem solved - I did not realize if I do not see the folder because it is hidden, UAC does not see it as well.
Recycle bin fixed.

Thanks a lot again.
My System SpecsSystem Spec

 Privileges problem after clean re-install

Thread Tools

Similar help and support threads
Thread Forum
Lenovo Clean Install Wireless Problem
I recently got a Lenovo V570 laptop. I was going to do a Clean Install of Win 7 to get the crapware off of the C: drive. I have ran across many threads about when doing a clean install the wifi doesn't work. I have searched for a lot of hours to find the solution and finally have found it but do...
Installation & Setup
Revisiting 'Doing clean install....' with a return of old problem
In my last post to my original thread "Doing a clean install and need advice" I spoke prematurely as all had gone perfectly yesterday. This morning I started it up and was greeted with it "installing 100 updates" or something like that. That done it restarted and all was fine for an hour or so....
General Discussion
Clean Install Problem
Hi, A couple days ago I wanted to try doing a 'super' clean install I suppose, and had heard briefly about DBAN (Boot and Nuke). It sounded good, so I set that to run and went away for about 2 hours and came back to find it at about 15% and it said I had 9 hours to go or something. I had no...
Installation & Setup
Codec Problem w/ Clean install
I'm using Windows 7 Ultimate x64 I've had a lot of problems with my computer due to me being a nut so I decided to do a complete clean install. It's completely clean. So I needed a codec. I installed K-Lite Codec Pack. But it's not working. My audio and video both sound and look horrible....
Installation & Setup
clean install hd audio problem
Hi just wondering if any one has seen anything like this . upgraded a friends computer from xp to win7 home edition computer is a asus main board intel cpu. after installing codecs and drivers using dvbdream (dvb tv software) the system sound works fine and the sound in dvbdream works fine on...
Sound & Audio
Problem with clean install: constant rebooting
I've got a problem with my recently bought (retail) Windows 7 home premium, which fails to install correctly (I've read the tutorial). I had XP and want a clean install. I booted via the dvd using the 64-bit version, chose languages etc. (step 3 in the tutorial) and custom install (step 6). I...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App