Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How to fix MBR through command prompt?

25 Jul 2009   #11

Windows® 8 Pro (64-bit)

Quote   Quote: Originally Posted by Tepid View Post
Just a little warning to those who may not know....

Playing with the MBR is a risky thing.
If you don't know how to recover data and haven't done/or don't know how to do a backup.
Then you shouldn't be messing with the MBR at all.

Simply running /fixmbr can and has corrupted it for me several times in the past.
This is not something that a simple windows repair can usually fix, usually.
Appreciate that thought but there's no other option to fix the above mentioned problem hence we had to dig the MBR.

My System SpecsSystem Spec
25 Jul 2009   #12

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Did you try setting H hard drive as the first HD in bios boot order - mark the 7 partition Active - run startup repair 4 or 5 times.
My System SpecsSystem Spec
25 Jul 2009   #13

Win 7 Ultimate 32bit

I don't want to send this off in the wrong direction or give bad info.
But I can tell you what I would try personally in this situation.

If the MBR is toast, then you may have no other choice than to nuke and reload

I do not know if these will work or be compatible with Win7 in anyway shape or form, or if OS version even matters...This could make things better or worse.. So, use at your own risk...

You can however try MBRFix and/or MBRWiz

You can also possibly try TestDisk, which is a data recovery program.
And has save my butt a few times.

I do believe both are a part of the UBCD4Win (however you would also need to upgrade some tools plugins as they may be out dated), which you may find very handy in this or many other situations. Every Tech should be aware of it and BartPE (which UBCD4Win is a derivative of).

With all that said.....

You can try DiskPart assign the drive letter you want.

I would start with building a UBCD4Win (or BartPE) and boot to it, see if the drive shows up in Drive manager.

If it does, I might try changing the drive letter there, then set as active.
Then if needed run some of the 7 boot option fixes to see if this will repair any BCD problems.

I say might, because I have never had to do this, this would just be a way I would go if all else was failing.

If the drive is not showing up at all in there, then the MBR is toast and you can try the MBRFix or MBRWiz to try and repair it if possible. If these fail, then you can try TestDisk, this may work, but is not likely, however, it may allow you to recover data id it finds it.

If all this fails, with all else you have tried, Personally, I would give up the ghost and nuke and reload.

Once the MBR is toast, there is almost no way to fix it.

Although, someone may know something I don't.
My System SpecsSystem Spec

26 Jul 2009   #14

Windows 7 RC 7100

Quote   Quote: Originally Posted by Tepid View Post
Just a little warning to those who may not know....

Playing with the MBR is a risky thing.
If you don't know how to recover data and haven't done/or don't know how to do a backup.
Then you shouldn't be messing with the MBR at all.

Simply running /fixmbr can and has corrupted it for me several times in the past.
This is not something that a simple windows repair can usually fix, usually.
I had a backup so I just decided to re-install. Windows 7 is fast to install I backup & running within 1 hour.

thanks everyone.
My System SpecsSystem Spec
08 Jul 2012   #15

Windows 7 Enterprise i386
A note about Bootrec

I was working on an Acer Iconia Tab W500 (tablet PC) this evening, which runs Windows 7 Enterprise (Ultimate) and Ubuntu 12.04. My intentions were to remove Ubuntu, restore the Windows 7 boot loader, and then remove the Ext3 partition containing Ubuntu 12.04.

I use a Sandisk 4GB USB drive as my installation media.
The tablet uses a built in 32GB SSD, and a separate 32GB SDXC card (45MBps).

I found that booting from the actual installation media would not repair the drive. I'm not sure exactly what caused it's confusion, but since Bootrec.exe does not allow you to target the operation to be performed on a specific drive, it's sorta a shot in the dark.

So, I copied the tool to my local drive, and booted up, first triggering my Drive selector, then immediately hitting F8 to trigger the boot-selector menu. This was all while grub was still installed. I was able to locally select the repair mode, and then open a command prompt, and run bootrec against the local drives without using a boot disc. This successfully removed grub, and I can now proceed to removing the ext3 partition and then spanning out the NTFS partition to reclaim the space on that drive, which is tiny to begin with.

If I *do* put another alternative OS on this machine, it'll be Android x86 v4.x or newer. I'll continue to use Windows 7 as it's primary OS until I can update it to Windows 8 Enterprise, and for now I'll continue to use USB drives for running Linux Distributions, which works well anyway. I just need to get a few lower-profile-drives since this *is* a tablet afterall. But I'll give it this, Windows 7 runs like a scalded dog on this Tablet, and Diablo 3 looks pretty sweet on it too! :)

Share and Enjoy,
My System SpecsSystem Spec
12 Jun 2013   #16

windows 7

I am just reading so many different questions and answers. thanks to all.
My System SpecsSystem Spec
05 Aug 2015   #17

Windows 7 64 bits
FixMbr or FixBoot ?


One of my computers does not want to start or restart but only SOMETIMES.

Do you think that FixMbr or FixBoot could help ?

Or because this computer often starts without problem it should not be of any help ?

Thank you.
My System SpecsSystem Spec
06 Aug 2015   #18

Windows 7 Enterprise i386

no. its not likely.

Download a copy of CCleaner, install it, configure it, then run its drive cleanup and registry cleanup tools. It'll likely cure the issues you've dealt with. If it doesn't, then its likely that your system needs to be reloaded, with fresh drivers for everything on it.

If you can do that yourself, you'll save a lot of money vs taking it to a shop.

(also, I've long since done away with Windows on my tablet. I'm now running Ubuntu-Mate 14.04-LTS, which I use mostly for work)
My System SpecsSystem Spec
20 Sep 2015   #19

Windows 7 Home Premium x64

Quote   Quote: Originally Posted by Dinesh View Post
Or you could've just tried bootrec /fixboot and bootrec /fixmbr.
Exactly what I was looking for.


Deployed from the Command Prompt found in "Repair Your PC" on the installation media, works like a charm.

Had to use it to repair my MBR after an Ubuntu removal.

So simple, a caveman could do it.
My System SpecsSystem Spec
06 Oct 2015   #20

Windows 7 Home Premium x64
bootrec /scanos = 0 installations found

If getting the "Total identified Windows installations: 0" when running bootrec /scanos, eg:

X:\windows\system32>bootsect.exe /scanos
Scanning all disks for Windows installations.

Please wait, since this may take a while...

Successfully scanned Windows installations.
Total identified Windows installations: 0
The operation completed successfully
You'll need to clean the MBR then create a new MBR and tell Windows to use it. To do this, simply run these two commands:

bootrec /fixmbr

bootsect.exe /nt60 all /force

You should see a message that says your "Bootcode was successfully updated on all targeted Volumes"

This helped me when i had to delete my linux partition and the separate MBR partition due to not enough space on windows. After extending the windows partition to the newly formatted NTFS partitions I obviously did not have an MBR anymore. The "fix problems preventing windows from starting" did not work and none of the commands in this forum worked. I used a bootcd to get into command prompt and ran this & it fixed it right away. Hope this helps you if you're having the same problem

Attached Images
How to fix MBR through command prompt?-bootrec-found-0-windows-installations.png How to fix MBR through command prompt?-bootrec-fix-mbr-all-voumes-command.png 
My System SpecsSystem Spec

 How to fix MBR through command prompt?

Thread Tools

Similar help and support threads
Thread Forum
Command Prompt command <ipconfig> not working
when I open up my command prompt and type 'ipconfig' without the ' and press enter it returns the line: 'ipconfig' is nto recognized as an internal or external command, operable program, or batch file I am trying to find out the information I need in order to set up a static IP Address for port...
Network & Sharing
Command Prompt: Repeat del command continuosly
Hi All, I'm running a program that parses .csv files and then changes them into ._OK files. This process takes longer when there are a large number of *.OK files in the folder where the files being converted are located. To remedy this I occasionally manually run this command: del *._OK ...
General Discussion
"Copy" command in command prompt generates 0x1a artifact?
Hello Everybody! I don't know if this is a real issue, or just one of those "What the . . . .!!" situations. You judge. Situation: I was working on a batch file that combines two .txt (ASCII?) files created in Notepad to create a composite file, and I noticed something really interesting. ...
command prompt
Hi all i need you help me a thing :cry: I went to use autosave all text on command prompt (CMD), how can i do or use what command prompt cade for mark it autosave when i used command prompt. Example : Color 0a
General Discussion
Run administrative command prompt from command prompt
Ok So I got myself into a unique bind here. I was trying to install some custom system files (for a theme) and I did it wrong and now I cant open explorer.exe . I dont want to goto a backup because this is a easy fix. (in my view). So I need to know how to run command prompt with administrative...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:37.
Twitter Facebook Google+