Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Installer - can't install ANY msi package

18 Jan 2009   #41

Windows 7

Thanks for the confirmation.

My System SpecsSystem Spec
19 Jan 2009   #42


my error was slightly different but the solution was the same.

while installing office enterprise 2007 i received "microsoft setup bootstrapper has stopped working"

it's still just an msi behind the fancy installer graphics but just so people who google that error might find the solution.
My System SpecsSystem Spec
19 Jan 2009   #43

Windows 7

THX it fixed for me.
My System SpecsSystem Spec

19 Jan 2009   #44

Windows 7 Build 7000 x86

start regedit
navigate to HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions
rename MachineThrottling to _MachineThrottling
It worked for me, finally java...
My System SpecsSystem Spec
19 Jan 2009   #45

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)

hello everyone

this is more a permanent solution...

Many users have started experiencing random crashing of explorer and msiexec.exe when trying to start Windows Update or install anything that uses an MSI based installer. This issue is bad enough that some people have even formatted because of it, only to have it come back again.
Rafael has discovered that the fault lies with the SQM Client which is part of the Customer Experience Improvement Program. It seems that ANY process that calls WinSqmStartSession in ntdll.dll will start crashing when MachineThrottling is enabled in the registry, which seems to happen as a result of CEIP running.
There are two workarounds for this issue. One may only be temporary, while the other should be permanent. I will list the permanent method here so everyone can cure the issue once and for all.

1. Delete the string values (Except for (Default)) in HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions
2. Start gpedit.msc
3. Expand Computer Configuration, expand Administrative Templates, expand System, expand Internet Communication Management, and then click Internet Communication settings.
4. In the details pane, double-click Turn off Windows Customer Experience Improvement Program, and then click Enabled.

Yes, doing the above WILL disable the anonymous usage data (CEIP), but until Microsoft fixes the issue and issues a hotfix or a new build I don’t see any other options to ensure the issue does not occur again.
SQM Client Causing Crashing in Windows 7 at Chris123NT’s Blog
My System SpecsSystem Spec
19 Jan 2009   #46

Windows 7 64bit Ultimate

I believe this happens when you change Windows Features.
EDIT: I didn't read everything, nevermind :P
My System SpecsSystem Spec
19 Jan 2009   #47

Windows 7 Beta

haha glad i posted in this thread so it got active again, MANY THANKS FOR THE SOLUTION!!!!! funny thing microsoft cannot even put that tiny underscore in the registry. thnx a lot really, save myself from reinstalling 7 over again. many thnx!!!! ^_^

Still a long way to perfection.
My System SpecsSystem Spec
19 Jan 2009   #48

Vista 32-bit / Windows 7 32-bit (Dual-Boot)

Fix confirmed working :)
My System SpecsSystem Spec
19 Jan 2009   #49

Windows 7 64bit beta

Does this need to be renamed and made into a sticky after 3000 views in 3 days?
My System SpecsSystem Spec
19 Jan 2009   #50

Windows 7 Build 7000 x86

this problem is just on x86. I'm with x64 now and i'm not having this problem. I had it on x86.
My System SpecsSystem Spec

 Windows Installer - can't install ANY msi package

Thread Tools

Similar help and support threads
Thread Forum
Cannot install Cisco AnyConnect-problem with Windows Installer package
I am trying to upgrade my VPN software to Cisco AnyConnect but I cannot get the software to install on my laptop. The installation process seems to make a fair amount of progress, but then it stops and says: "There is a problem with this Windows Installer package. A program run as part of the...
BSOD after presumably after Install of Fonts package using GPO
Hi, I have been deploying out fonts to our Windows 7 machines to Install a new font via MSI software roll out and registry setting via GPO: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Fonts\(Font name) Since the Install we have noticed a few machines BSOD with: STOP: 0x0000008E
BSOD Help and Support
Itunes wont download because of issue with Windows Installer Package.
I've tried to download the newest addition of Itunes and it won't let me because of an issue with Windows Installer Package. What do I do to fix this?
How to install Language Package
I have an English version of windows home premium, and want to intall a dutch language package, but when I go to "control panel" and "clock, language and region" I can't find the place to install the language packages. It is supposed to be below "keyboard and other input methods" but it is empty...
Installation & Setup
Windows 7 x86 and x64 installer package folders and files- Diferrence
I am working on automation project in which we are installing the Windows OS on client machine with the help of different OS packages available on server. While installing Windows XP/2003 we are checking for the OS installer packages to get the difference between x86 and x64 architectures. ...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:48.
Twitter Facebook Google+