Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Access is denied!

22 Oct 2017   #1

Windows 7 Professional 64 bit
Access is denied!

Even now in the 21st century, we have hundreds of people still having problems accessing their 'OWN' files in Windows 7! I am the ONLY user of my PC and as such should be able to disable ALL restrictions to any files on it! I do not use UAC...."Why would I?" I only use the internet when I need to and only then do I activate my Anti-Virus software.

If I could run my Flight Simulators without a computer I would! I think computers are a right pain in the a,.e to be honest. Particularly when you have Big Brother Microsoft trying to control your life and telling you...."YOU DO NOT HAVE PERMISSION TO OPEN YOUR FILES!" I have tried most of the so called solutions put forward by well meaning people, but still can't edit my files! I even made myself an 'ELEVATED ADMINISTRATOR' but to no avail.

I am retired and spend most evenings in my den on my Simulators (FSX & P3D) for which I have spent thousands of pounds on hardware and software. I am an addicted aviator, I was a PPL until my heart attack in 2000 which put an abrupt halt to my flying. Hence the simulator in a spare room.

My question is simple and straight forward!

Can anyone out there please tell me how to DISABLE ALL RESTRICTIONS TO MY FILES? I edit configuration files all the time, as I am always adding or removing aircraft, scenery, airports etc. I must add however, I have the same problem in Windows 10! NEVER HAD THIS PROBLEM IN VISTA.

I really hope someone can tell me how to solve this problem!



My System SpecsSystem Spec
22 Oct 2017   #2

win 8 32 bit

What files are you trying to edit in what folder? Ms has locked a lot of system files which will be owned by system so you can't destroy your system the idea is if you get a virus it will run on your account so it couldn't alter system files thus keep you safe
My System SpecsSystem Spec
22 Oct 2017   #3

Windows 7 Professional 64 bit

At the end of the day it is MY COMPUTER! When I (rarely) connect to the 'Net' I activate an expensive protection program. However, it is no big deal to me if my system somehow got destroyed! Both my operating systems are on their own SSD drives. Both my Flight Sims are also on their own SSD. I have everything backed up (once a week) on External drives. In the event of a system crash, I just call on a Backup or re-install from the installation disc. The files I need to edit are my Flt Sim Configuration files.

What I can't understand is: I've been using WIN 7 for the past 3 or 4 years with no such problems. I wonder if it's anything to do with the new computer I've just built?

Old PC: CPU Intel i7 3770K 4.5ghz - MOBO Gigabyte GA-Z77X-D3H (2013 TO 2017)

New PC: CPU Intel i7 7700K 4.2ghz -MOBO Gigabyte GA-Z270-GAMING K3 (2017......?)

It does seem strange that I didn't have this problem before?
My System SpecsSystem Spec

22 Oct 2017   #4

win 8 32 bit

What are the security properties on the folder and file your trying to edit
My System SpecsSystem Spec
22 Oct 2017   #5

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by psvpilot59 View Post
My question is simple and straight forward!

Can anyone out there please tell me how to DISABLE ALL RESTRICTIONS TO MY FILES? I edit configuration files all the time, as I am always adding or removing aircraft, scenery, airports etc. I must add however, I have the same problem in Windows 10! NEVER HAD THIS PROBLEM IN VISTA.

I really hope someone can tell me how to solve this problem!
If you could provide some actual details and specifics, someone might be able to help you. Also, a picture's worth 1000 words, so a well-picked screenshot or two might convey your setup and situation quite well.

What program are you trying to run or function that are you trying to perform, which is giving you "access is denied"? Windows Explorer? Some other program?

Are you having problems when trying to open a folder? Or when trying to trying to simply open some file in a folder "for edit" (e.g. by Windows Explorer)? Or is some program trying to read the file as a normal "data" file that it works with all the time?

"Access is denied" usually comes when a file is currently open and in-use by Windows or some other running process that has it locked. Perhaps that still-running process didn't shut down correctly and is actually still unexpectedly running. Very often re-booting and then trying to get to that file again will work, since the culprit task has now not been started and is thus now no longer holding on to that file.

If you look at the list of running processes using Task Manager -> Resource Monitor -> DISK tab -> "processes with disk activity" (sorted into alphabetical sequence by clicking on the "image" column heading) and also open the "disk activity" category below it, you will be able to see all the running tasks which have some type of disk connection active and to what files. By checking only those tasks in the "processes with disk activity" list that you might really be interested in, the list in the "disk activity" group below is reduced and it might be easier for you to be a detective and spot the problem file you are unable to access because "access is denied".

If you repeat the process after a re-boot when now you CAN get to the problem file, and you spot that some previously running task which had been accessing that file is no longer running (thus now allowing you to open the file), you will at least have found the culprit task which for some reason is failing to release its lock on that file when you think it should be done with it.

I'm just suggesting you use Task Manager -> Resource Monitor to try and gather some clues as to where the locked file is currently still being used in what looks like a non-shared way.
My System SpecsSystem Spec
24 Oct 2017   #6

Windows 7 Ultimate, SP1, x86

I don't have a lot of problems with Win-7 (my everyday OS) but Win-10 is something else.

Just doing the setup on W-10 requires that I have to do some gymnastics to get full permission to do what I need to do.

First I install "Grant Admin Full Control", and then I Right click on the file that I need to modify and from the drop-down menu, I select "Grant Admin Full Control" and that makes me the 'Owner' of that file.

Even after that, I might still have to look at the 'Properties' of that file and take off the "Read Only" attribute. Finally after all that, I can, without fail, rename or even delete the file.

I shut down 'Cortana' in Win-10 by changing her Core.dll file to a .zzz file.

Having to go through all that for multiple files is a real pain in the hind quarter, but it's indeed DO'Able.
It just depends on my level of tolerance.

Just installing "Grant Admin Full Control" as soon as the initial OS setup is complete, makes my life so much more pleasant.

Good Luck and Happy Computing,
My System SpecsSystem Spec
25 Oct 2017   #7

Windows 7 Professional 64 bit
Access Denied

Hi Guys,

I think I've managed to upload a couple of screenshots showing the files I'm having trouble with! Let me know if you don't get them and I'll check the tutorial again.


ScreenHunter_11 Oct. 26 00.19.jpg
ScreenHunter_12 Oct. 26 00.26.jpg

Attached Thumbnails
Access is denied!-screenhunter_11-oct.-26-00.19.jpg   Access is denied!-screenhunter_12-oct.-26-00.26.jpg  
My System SpecsSystem Spec
26 Oct 2017   #8

Windows 10 Pro x64 x3, Ubuntu

First "rule" is never change access permissions to any files or Folders in the Windows Area, They are specially protected due to the vast amount of malware loose in the wild, this applies even to systems which are not connected to the internet, the protections you see are there as a default if programs do not set-up according to the guidelines for using windows. It even applies to some older designed Microsoft games and programs which were designed in the XP era which had virtually no security

Looking at your screenshots it looks like the issue is with the file structure of an external drive L: (Data Drive), what you need to do is choose a view of your system in file explorer where you can see your various Drives at root level ...
  1. Right Click on the entry for L: drive
  2. Choose Properties
  3. Choose security Tab
  4. Click Advanced
  5. Click Edit
  6. Make sure that the "replace all child object permissions entries with inherited permissions from this object" is checked
  7. From the list select your user name and click on edit
  8. Check the "Full Control Checkbox and OK - the system will then spend a while applying changes - OK any pop-up boxes produced, and note where they occurred.

When completed you should have control of your drive If you still have issue you may have to re do the procedure starting at any points where messages were produced earlier ( these points are where there were slight errors introduced during use of the software.

This is the manual way of applying permissions that should be applied by the installer software when installing software.

there is a shortcut to achieve a similar ( but in some ways more dangerous way with some software ) and that is to
Change the owner at line 7 in the list

there are ways to add the take ownership to the right click of files and folders ) but I prefer the " correct way shown

Take Ownership Shortcut - Windows 7 Help Forums

Also in your case I've shown how to "correct" the permissions on the whole drive - If you are only interested in the actual config files you show in the screenshot you could just apply the corrections to the actual files or containing folder or even take ownership of the files using the right click option which would be a lot quicker

These type of permissions errors can often happen if you move an external drive between computers, or to a new system, as what we see as a username is not what the computer sees - User Fred on system one is not the same user Fred on system 2 to computers so when looking at the permissions lists or ownership do not worry if you see a long string of numbers starting with S as the owner or in the list as these are the names that the systms actually use
My System SpecsSystem Spec
31 Oct 2017   #9

Windows 7 Professional 64 bit

Hello Nigel,

I've tried everything you said over the past week and still can't get into the required files! I think you hit the nail on the head, when you mentioned moving external drives from one computer to another. That is exactly what I have just done! I moved drives from my old machine to my new one, including the external USB drive! At the end of the day, it's not the end of the world. I can manage without those files, but it would have saved me a considerable amount of time setting up my flight sim!

Thankyou for taking the time to try and help me with this, I do appreciate it.

Also: Thankyou to everyone else who tried to help.

My System SpecsSystem Spec
04 Nov 2017   #10

Win 7 Ultimate 64-bit

(I just want to comment on your experience, because Win 7 has driven me nuts more than a few time while observing the rules of the UAC. I acquired this Win 7 machine almost a year ago. It took me 8 months (not continuously, of course) to figure out how to trick the system into installing Inquisit, an optional program that I need for some tasks at work. I've given up on installing a few others, finding similar substitutes instead.)
My System SpecsSystem Spec

 Access is denied!

Thread Tools

Similar help and support threads
Thread Forum
i can't access gpedit.msc ACCESS IS DENIED
i can't access gpedit.msc ACCESS IS DENIED pls help me
General Discussion
Import Pictures to NAS "Access Denied" Error Though User Has Access
Hi, All. I've got an interesting situation that I'm hoping can be resolved. I built a server using FreeNAS 8.2 to store family pictures, videos, music, and Windows backups. In my home we have Windows 7 Home Premium 64bit and Windows 7 Professional 64bit. The server is setup with 3 Windows (CIFS)...
Network & Sharing
Access denied
:confused: Using Windows7 professional 64bit I am unable to access any files within Documents and Settings. Notification: "Access denied" I have identified a lock attached D&S using Windows explorer. I have not knowingly made any changes. Could someone please advise me how I should proceed...
Can access Vista shares from XP but not from Windows 7 (access denied)
Hi, everyone, I'm mostly a Linux guy these days, so I'm no longer clued up about even simple Windows issues. Bear with me. :D I have one PC running Vista (home basic), one running XP (professional) and one running Windows 7 (home basic). There is a printer connected to the Vista box, which is...
Network & Sharing
"Access denied:" How to overcome denied access to a folder
I'd like to put a .cmd file in my c:\Documents and Settings\All Users\Start Menu\Programs\Startup directory, but \Documents and Settings has a lock on it and tells me "Access denied" when I click on it. Is this a job for "Take Ownership" or is there another way? The instructions for "Take...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:16.
Twitter Facebook Google+