Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows can't stop your 'Generic volume' device

01 Jul 2015   #31

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Ccleaner - it's okay but doesn't show all entries for shell extensions. It's a good place to start though. It offers disable and dlete options.

Re: My earlier post on write caching.

Take a look at the post here from member WHS (note the number of forum posts - he knows what he is talking about)

I couldn't "safely remove" my USB external drive

If you are worried about loosing data - backup a drive that you want to test before going ahead.

Also see:

HTG Explains: Do You Really Need to Safely Remove USB Sticks?

Apparently enabling write caching does increase the chance of data corruption.

My System SpecsSystem Spec
01 Jul 2015   #32

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

More tests:

Do you have ProcessExplorer? If so does entering the drive letter in the find handle or DLL search box reveal anything other than those System processes?

If so - I've found that if you close any file handles the drive can still be ejected.


Explorer locking external drive F

Windows can't stop your 'Generic volume' device-process-explorer.jpg

From the PID - close handle

Windows can't stop your 'Generic volume' device-process-explorer-4.jpg

Windows can't stop your 'Generic volume' device-process-explorer-2.jpg

You can see that Windows Photo Viewer is still displaying the image (file that was opened from drive F) but since the handle has been closed it's possible to eject the drive.

Of course none of that helps if there are no non system processes or Dll's showing up!

Attached Thumbnails
Windows can't stop your 'Generic volume' device-process-explorer-3.jpg  
My System SpecsSystem Spec
08 Jul 2015   #33

Windows 7 Ultimate x64

I'll give this a try tomorrow and report back. Thanks for the suggestion.

EDIT: Gave it a quick try, but I don't have an option for "offline". I opened Computer Management, then selected disk management. On the right pane I have the different drives listed. When I right-click on the part to the left that says "Disk 2 - Basic - Online" I get a few different options (convert to dynamic disk, properties, help) but the other 3 options are all greyed out, and none of them is "offline". Am I doing something wrong?[/QUOTE]

In that case, your device is cannot be recognized properly to do this.
Try following:

1) Go to Device Manager
2) Extend Disk drives and right-click on the USB device
3) Select Properties
4) Go to the Policies tab of the newly open window.
5) Check the option ‘Quick removal'
My System SpecsSystem Spec

09 Jul 2015   #34

Windows 7 32bit Home Premium

I still haven't had any luck with this. My "computer management" doesn't have that "offline" option when I click on it.
My System SpecsSystem Spec
17 Jul 2015   #35

Windows 7 32bit Home Premium

Well I'm at my wit's end with this issue.

Since I bought additional USB 3.0 external drive bays for storage it's been a nightmare for me. I never had these issues with eSATA but eSATA cards are much more expensive than USB 3.0 cards. I never know when it's going to eject the drives okay and when it's going to fail, and every time it fails I have to stop what I'm doing to reboot my PC to turn off my external boxes. Ridiculous. I cannot believe Microsoft hasn't come up with a solution for this.
My System SpecsSystem Spec
17 Jul 2015   #36

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Perhaps you could try disabling all non-microsoft shell extensions and non-microsoft context menu items of explorer before rebooting and testing to see if you can then eject drives.

ShellMenuView - Disable/enable context menu items of Explorer

ShellExView - Shell Extension Manager For Windows

What you would be most interested in is non-microsoft context menu items for drives:


Windows can't stop your 'Generic volume' device-shellmenuview.jpg

But you can also disable only non-microsoft shell extensions perhaps in small groups using ShellExView.

My System SpecsSystem Spec
17 Jul 2015   #37

Windows 7 32bit Home Premium

Something weird happened just 5 minutes ago. I went to detach one of my external USB 3 enclosures, and as usual, it wouldn't allow me to. I also had my Mede8er external media player attached via USB 3.0 for file transfer to it's internal HDD. To detach that player, the tech support team strongly advises using the USB Disk Ejector:

The International House of Mojo

due to the Mede8er using Linux. They strongly advise not using the regular Windows USB eject method. So I use that, but it often has the same issue - sometimes it will eject the Mede8er player, sometimes it can't because it's "in use" by the same process that gives me trouble with my external enclosures. Well after Windows failed to eject my enclosure today, I then clicked on the USB Disk Ejector icon to try and eject the Mede8er, and that actually ejected fine this time. For the heck of it, I tried again to eject my enclosure using the standard Windows "Safely remove hardware and eject media" icon, and this time, it ejected the enclosure.

So it failed to eject the enclosure, I then used USB disk ejector to eject my external media player, then tried again to eject my enclosure and it ejected. I have no idea why it ejected the enclosure fine the second time. It must have been something to do with the USB disk ejector, but that doesn't work for my enclosure, only my media player - when I try to use it on my enclosure, it appears to eject but immediately pops right back up again in the list of drives.

I actually have ShellExView already - I use it to keep my right-click options under control. I'm still convinced this is caused by a Windows process.
My System SpecsSystem Spec
18 Jul 2015   #38

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Well you may be correct but I remember having the same problem around two years ago - too long ago to remember exact details but it was a software issue (for me) and fully removing the software solved the problem!

Try ShellMenuView anyway and see what shows up for drives?
My System SpecsSystem Spec

 Windows can't stop your 'Generic volume' device

Thread Tools

Similar help and support threads
Thread Forum
How to remove the generic sound volume controls/mixer?
I have just installed the Realtek HD Audio driver from Gigabytes's website after formatting my PC. However, the generic sound volume controls/mixer is still visible, and when I mute the sound on the Realtek HD Audio manager, the mute sign appears on the generic sound controls icon, instead on the...
Sound & Audio
Generic volume shadow copy reliability monitor question
I recently did a clean install of Windows 7-64bit and the computer has been running very smooth for the last week. Last night (08/18/2016) I installed a couple of updates and while checking the reliability monitor in the action center after installing the updates I noticed a new entry "Generic...
Backup and Restore
Generic volume shadowcopy driver keeps installing
Hi All, I have an issue where the Generic volume shadowcopy driver installs at least once every time I do a windows backup. This suddenly started happening last saturday but I just noticed it yesterday. I thought that it must be connected with the install of Malwarebytes (paid version) on Friday...
"Can't stop generic volume device because a program is still using it"
I've got an external hard drive...actually this has happened on my other external hard drive too, and i've never been able to solve this problem most of the time i can eject without a problem and make sure nothing is going to and from the external, but after copying files for a long time in one...
Hardware & Devices
Flash Drive Showing Up As Itself & Generic Volume
I'm not sure if this goes here or in the hardware & devices area. I'm not sure if it's a driver issue or something else. My 8GB SanDisk Cruzer Micro is not working properly(default FAT32) on all four USB 2.0 ports. My other flash drives work fine, also FAT32. I recently upgraded my laptop from...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:03.
Twitter Facebook Google+