Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Access 97 in Win 7 64 bit

04 Jan 2010   #1

Win 7 64 bit
Access 97 in Win 7 64 bit

I attempted to install Access 97 ( have to use it due to the applications written in it) in Windows 7 64 bit and apparently because it can't write to the c:\windows\system32 folder the installation fails. I also tried installing it with administrative privileges and it didn't work. I installed it in XP Mode and got the same results.

Initially the installation said that ctl3d32.dll couldn't be installed, then an error saying system.mdw wasn't installed. When I try to create system.mdw using the Workgroup Administrator it fails, probably because it can't write to the /windows/system32 folder.

I am sure this is a common problem but I can't find a solution.

I am a developer so I have a ton of apps to install, but this is the only problem I have with running applications in the 64 bit Windows 7.

Any ideas?

Thanks for your help...

My System SpecsSystem Spec
05 Jan 2010   #2

Windows 10 Pro (x64)

Quote   Quote: Originally Posted by RockyMtnHi View Post
...I am sure this is a common problem but I can't find a solution....
Probably cannot find a solution cause it is not a common problem. Not many people are going to install an application from 1997 on a modern day OS. What you are probably going have to do is create a new virtual machine, not the one that came installed as XP Mode. Might want to use Windows 2000 or even Windows 98...
My System SpecsSystem Spec
05 Jan 2010   #3

Win 7 64 bit

Other than this I have been able to install literally all of my applications in 64 bit Win 7 and have them work like clockwork. I hate to have one app that needs a virtual machine.

If anyone has solved this please pipe in. In the meantime I'm installing Win 98 SE in a virtual machine...

My System SpecsSystem Spec

05 Jan 2010   #4

Win 7 64 bit

I solved it (without the VM)! Access 97 is now running in 64 bit Win 7.

I did this Google search:
install windows inside virtual machine
and clicked on the Windows Virtual PC home page. Then I clicked Help and How To: Windows 7. Next I clicked Make older programs run in Windows 7. I viewed the video on Windows 7 Help & How-to - Microsoft Windows and went the troubleshooting route. Its running fine now.

I ran the troubleshooter on the Workgroup Administrator which allowed me to create the system.mdw that wasn't created on initial install.

What fixed it was allowing permission changes to the /Windows/System32 folder.

So far Windows 7 is a dream. The 8Gb of RAM and quad CPU certainly helps.
My System SpecsSystem Spec
05 Mar 2010   #5

windows 7

I have the same issue! How did you change the permissions on the system32 folder?
My System SpecsSystem Spec
08 Apr 2010   #6

win 7 64 bit

I have the same issue here. I tried copying files and changing owners & permissions. Still no luck.

Anyone who has solved this issue please provide detailed steps. Thanks.
My System SpecsSystem Spec
14 Apr 2010   #7

Windows 7
Me too

Methinks RockyMtnHI is a bit too high I am having the same issue and wonder if he/she really did what was claimed.
My System SpecsSystem Spec
26 May 2010   #8

windows 7 prof 64 bits

My problem regarding this issue:

a) Trying install without troubleshooting: Windows 7 says not compatible application, and don't let me install

b) With compatibility troubleshooting: Start program button doesn't do anything

My windows version is Windows 7 professional 64 bits. SO, I cannot install office 97 (SR1) in my windows 7 64 bits
My System SpecsSystem Spec
26 May 2010   #9

64-bit Windows 8.1 Pro

That program is 13 years out of date and is not compatible with a 64bit OS... You need to get a later version ... Office 2010 ...
My System SpecsSystem Spec
31 May 2010   #10


I am all for getting a new version of office, but with access its not that simple. You have to convert the db to go from version to version. With one that out of date, you'd be better off starting from scratch and just importing the data.
My System SpecsSystem Spec

 Access 97 in Win 7 64 bit

Thread Tools

Similar help and support threads
Thread Forum
Can't access wireless adapter (shows disabled) but can access internet
This just started this morning. My wireless icon keeps having the loading circle, which changes to an x when I click it. I am unable to load my network options, also. But internet connects fine and I am able to surf (and come here, begging for help). Also, other devices like my tablet and phone...
Network & Sharing
Asus Laptop keeps getting random limited access. No internet Access
When I am on my computer at random times my asus laptop would drop my internet. I am using a wireless connection and my connection is not bad. Just wondering if there is a quick fix to this. I am not the most knowledgeable computer guy but I could follow directions if you guys need addition info of...
Network & Sharing
Dial Up ICS Error:Access Type No Internet Access With Yellow Triangle
Hi, i am a newbie when it comes to Windows networking particularly Internet Connection Sharing (ICS). A week ago i turned my Win 7 HP Laptop into wireless router which is on EVDO 3G dial up using the windows (ICS) to connect my second Win 7 Dell laptop which was successful. Unfortunately, i...
Network & Sharing
Download Windows Access Panel For Easy Access To Window
Download Windows Access Panel For Easy Access To Windows Utilities Many Windows users might not like the default settings that come automatically but tend to customise or make changes to the default settings. Users who are familiar with control panel or other system utilities shouldn’t have...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App