Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Won't Shut Down Normally on Wireless-n

15 Jan 2011   #1

Win 7 Pro x64
Won't Shut Down Normally on Wireless-n

I am bringing this issue over to Network & Sharing on the recommendation of CarlTR6.

Win Pro 7 x64
HP 8540w (Core i7 M620, nVidia Quadro FX 880M, 8 GB RAM, 320 GB HD w/66 GB Free)

Here is the link to the beginning of the thread:

Following are two posts from that thread which lay out my issue

"I am still having USB/shutdown issues at home.

HP advised me to update the docking station drivers which had no effect.

I then began a series of tests where I booted up adding or deleting one item at a time from the following list: AC power, USB mouse, VGA monitor, ethernet, wireless.
I would then insert a flash drive into the USB port and see if it recognized by the system, unmount the flash drive, put the system into hibernation, resume from hibernation, and finally shutdown.

I ran these tests at my office and then at home.

At the office everything worked in all configurations although I did experience a 0xf4 crash while connected via wireless and viewing a youtube video inside Firefox.

I then turned on Virtualization Technology and set Num Lock on at boot via the BIOS and restarted.

All tests succeeded while wireless at the office.

I packed up and drove home. A couple of hours later I booted the computer with only wireless (no ac power, usb mouse, external monitor) and the flash drive was recognized on insertion but it would not unmount. I tried hibernation and the screen went blank but the wireless LED remained lit and the hard drive activity LED flashed every 0.5 seconds. When I attempted to resume from hibernation the screen remained blank and the system was unresponsive. I had to use the power button to force shutdown.

In BIOS I turned off Virt Tech, HP QuickWeb, and HP QuickLook.

I rebooted with a USB mouse and wireless. The flash drive was recognized upon insertion. I uninstalled all USB drivers (to allow Windows to reload them on the next boot) and the system shutdown normally.

Upon reboot Windows reloaded the USB drivers from the existing files. The system recognized the flash drive but would not unmount. Shutdown required the power button.

The next morning I came into my office and booted up the system with no devices installed other than wireless. Everything works and the system shut down normally.

At the office I have a LinkSys WRT54G router and at home a Netgear WNDR3400. The computer and system are otherwise exactly the same. Could it be some weird wireless-g vs. wireless-n conflict?

My head hurts..."

"It gets better, I can CONSISTENTLY repair or break the USB/Shutdown issue!

While at home (with wireless-n) if wireless is connected nothing works (USB will not unmount, cannot create restore points, no hibernation, shutdown won't complete).

However, if I change the wireless network key which breaks the network connection and reboot the system, upon reboot, everything works including normal shutdown.

I then restore the wireless network and nothing works. I break the network and everything works. It's as consistent as an On/Off switch.

In Safe Mode with Networking everything functions normally so this must be a driver issue of some kind."

Thank you for your patience with this long post. I am running the latest network drivers from HP. I'll try disabling wireless-n on the router and report back.


My System SpecsSystem Spec
15 Jan 2011   #2

Win 7 Pro x64

I disabled the 5.0 GHz antenna in the Netgear WNDR3400 router. I rebooted the notebook but it did not resolve the issue. I inserted a flash drive into a USB port and it was recognized, however, the system would not unmount it.

Could this be a hardware issue with the Intel Centrino Ultimate-N 630 AGN wireless adapter?
My System SpecsSystem Spec
17 Jan 2011   #3

Windows 7 x64

I have exactly the same problem with totally different hardware.
At home, I have 3 laptops. One Toshiba Tecra R10 with Win7 Pro x64, one Toshiba Satellite A505 with Win7 Home x64, and the last a Toshiba Satellite Pro U300 with Vista Business 32bit.
Both Win7 x64 are having this same problem and not the Vista machine.
The bugcheck was: 0x0000009f (0x0000000000000004, 0x0000000000000258, 0x…, 0x…) on both machines with the first 2 parameters the same (0x4, 0x258)
The Tecra has a Toshiba F3507g Mobile Broadband Network Adapter, while the Satellite a Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC.
My home router is a Linksys WRT610Nv2 while at the office it’s a Linksys WRT54G.
If I boot up the machine with the wireless button off, everything works fine. I can Hibernate and wake up many times. When I turn on the wireless, the HDD led flashes every .5 seconds and the hibernate crashes.
It doesn’t seem to be a hardware issue as the hardware is very different, but it seems to be related to the Windows wireless network security since after the WiFi is disconnect due to changing the WPA2 key, the system hibernates properly.
I noticed the problem about a week ago on both systems and there were no common installations on these machines except maybe windows updates that happen automatically.
What I’m doing now, before shutting down or hibernating, I delete my home network from “Manage Wireless Networks”, and upon restart I reconnect to it again.
My System SpecsSystem Spec

17 Jan 2011   #4

Windows 7 x64

Quick update.
I just noticed that after Iíve deleted the Wireless network and recreated it, the problem has been solved.
Can you confirm it Greg?
My System SpecsSystem Spec
17 Jan 2011   #5

Win 7 Pro x64

No joy, Pat.
I removed the network, rebooted, and added the network but USB devices are still not recognized.
I do have two other networks setup. I'll delete all of them and see what happens.
Back soon...
My System SpecsSystem Spec
17 Jan 2011   #6

Win 7 Pro x64

No go. When the network connects my USB still seemingly disconnects, or at least the ability to recognize new USB devices disconnects.
...And it won't hibernate
...And it won't create Restore Points
...And it won't shutdown normally.
My System SpecsSystem Spec
19 Jan 2011   #7

Windows 7 x64

Hi Greg,
I confirm that the USB is working fine, and so are the Hibernate, sleep, and shutdown.
After you mentioned that changing the network key on your router solved the problem, I tried it and it worked for me too. So In order not to disconnect all the other computers on the network, I decided to delete the wireless network configuration from my laptop, which I thought might have a similar effect. So I went to “Control Panel - Network and Internet - Network and Sharing Center - Manage Wireless Networks” and deleted my home network configuration and managed to hibernate successfully. On the next restart, I reconnected to my home network and soon afterward I noticed that the USB was working fine and so was the hibernation.
For the last couple of days, the problem did not reoccur.
I can’t see the logic behind this resolution, but it did solve my problem.
Is changing the WPA key on the router still working for you? And does deleting the network configuration has the same effect for you?
My System SpecsSystem Spec
19 Jan 2011   #8

Win 7 Pro x64

Removing or disabling works for me. However, when I recreate the wireless-n network the USB/Hibernate/Shutdown issue reoccurs.

I have been testing, keeping notes, and sending those notes into an ongoing support chat at HP and they've recently promoted this issue up to a supervisor for research.

It's funny because I actually feel better now that I can at least reproduce the error condition. It had been driving me batty before I discovered this wireless-n connection.
My System SpecsSystem Spec
19 Jan 2011   #9

Windows 7 x64

I know. It drove me crazy for a whole week too.
I had the exact same symptoms as you did; USB not working, power led blinking every .5 seconds on hibernate/shutdown, etc...
Did you try changing the encryption on your router from WPA2 to WPA or WEP? I have it on WPA2.
My System SpecsSystem Spec
19 Jan 2011   #10

Win 7 Pro x64

I had not tried changing the encryption (from WPA2) since my office wireless g is using WPA2. I'll give it a shot.
My System SpecsSystem Spec

 Won't Shut Down Normally on Wireless-n

Thread Tools

Similar help and support threads
Thread Forum
BSOD - Occurs during Shut Down Process. Shut Down hangs then crashes
Hey there, Lenovo E440 that ran excellent until recently. About a week or two ago I got an error message about a power surge on a USB port. Didn't really seem to effect much so I moved on. Lately, when shutting down, it hangs for a few minutes... just sitting at the final "Shutting Down"...
BSOD Help and Support
Shut Down - Enable or Disable Shut Down without Logging On
How to Enable or Disable Shut Down without Having to Log On This will show you how to enable or disable all users to be able to shut down the computer without having to log on in Windows 7. This will add or remove the red shut down menu box in all Log on and Switch user screens. You will...
Shut Down Windows - Change "Install Updates and Shut Down" as Default
How to Change "Install Updates and Shut Down" as Default Choice in Shut Down Windows Dialog This will show you how to manage whether the Install Updates and Shut Down option is allowed to be the default choice in the ALT+F4 Shut Down Windows dialog and Start Menu "Shut Down" power button...
Screen shut-off requires hard shut down
I work on my Gateway while sitting on the couch. I surf the Internet and then watch TV. I surf a little more, and then I watch more TV. Some nights, when I slide the computer near me because I've shifted in my seat, the screen will go black and I have to push the On/Off switch until the computer...
General Discussion
lose wireless when lid is shut and re-opened
I just bought a Toshiba Satellite and whenever I shut my laptop, when I re-open it I am unable to connect. My network shows up, but I am just unable to connect. It also then causes my other toshiba laptop to be unable to connect. I had never had a problem like this with my first toshiba, but it is...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:28.
Twitter Facebook Google+