A Solution to Could not reconnect all network drives


  1. Posts : 4
    Windows 7 Professional
       #1

    A Solution to Could not reconnect all network drives


    After reading exhaustively on this subject, I pieced together a workaround that works for me:


    After installing ESET Smart Security 4 on my PC, I started getting an error at logon..."Could not reconnect all network drives". If I went into Windows Explorer, drives X,Y and Z all had red X's on them. If I double-clicked them, they opened up just fine and the red X's went away. I also discovered that if I connected via wire to the network instead of wireless, I didn't get the error at all. It was just when I was using the D-Link USB Wireless Adapter that it happened.

    I tried various things in ESET, like preventing doing a signature update right at that moment. It didn't matter what I did. Something in ESET was running first thing and causing this problem. But I like ESET and wanted to find another solution, rather than changing security packages or going wired. It wasn't just my problem...sooner or later, it would be someone else's problem in my shop.

    Also, it just made matters worse to not run the logon script from the Windows server. I would lose the drives altogether. And although I could manually run the logon.bat file on my PC, that was not a solution for other users.

    The problem is really a bug in Windows 7 that they are not going to fix before Windows 8, if at all.

    So, I did find a solution.

    1. Continue running the logon.bat script that is located on the Windows Server. That contines to fail, leaving the red X's on the drives, but at least the drives are there.

    2. Download MapDrive.exe from Zorn Software. This is a free program. I created a directory called C:\Zorn and put MapDrive.exe in that folder.

    3. Create logon scripts in GPEDIT.EXE.
    a. User Configuration --> Windows Settings --> Scripts
    b. Doubleclick on Logon
    c. Use Add button to add scripts:
    Script Name: C:\Zorn\MapDrive.exe
    Script Parameters:
    X: "\\ServerName\%username%" 20
    Y: "\\ServerName\usershares" 20
    Z: "\\ServerName\shared" 20

    After each script is keyed, then press APPLY
    ...when you are done, you should have a script
    for drive X, drive Y and drive Z. The 20 says that
    MapDrive will keep on trying up to 20 seconds
    to connect to the drive before it gives up.

    4. So now the drives get correctly connected, but the error message still appears. There is a registry hack to fix that. Using Regedit:
    HKLM->System->CurrentControlSet->Control->NetworkProvider
    Add a DWORD value of RestoreConnection = 0 (zero).

    Now, even though the initial attempt to map the drives still fails, I no longer have to see that it is failing. MapDrive finishes mapping the drives and the registry hack prevents the error message from appearing in the first place. All fixed.
      My Computer


  2. Posts : 1,426
    7 Pro
       #2

    Your wireless driver/service is loading after the explorer service, thus your error.


    to add a bit: Delay connections to your network drives:

    http://answers.microsoft.com/en-us/w...3-3f8ba2e9bf75
      My Computer


  3. Posts : 4
    Windows 7 Professional
    Thread Starter
       #3

    I had already tried that solution and it didn't work for me. What I put together works...no delays.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:46.
Find Us