Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: FTP Problem

11 Jan 2009   #1
Wind7

Windows 7 Build 7000
 
 
FTP Problem

I have an FTP server running on an XP machine. Can't access it from Windows Explorer in Windows 7, I get a permission error or some such. FTP from the command prompt works fine though, no issues. Didn't have this problem under Vista. Any ideas? Thanks for any info!


My System SpecsSystem Spec
.
11 Jan 2009   #2
johngalt

 

Firewall?
My System SpecsSystem Spec
11 Jan 2009   #3
Wind7

Windows 7 Build 7000
 
 

On the XP machine I do run ZoneAlarm but I was able to FTP in from the command prompt, shouldn't that have been blocked too? But I'll check it out anyway thanks!
My System SpecsSystem Spec
.

11 Jan 2009   #4
johngalt

 

Well, to be honest, I am not sure if IE uses the FTP protocol correctly. Try a true FTP program - I personally recommend FileZilla - The free FTP solution
My System SpecsSystem Spec
12 Jan 2009   #5
milhouse

Dual Boot - Windows Vista Ulitmate 64x and Windows 7 64x
 
 
FileZilla solved the problem

I guess IE 8 doesn't use FTP proper at this time?

FileZilla def works fine though.
My System SpecsSystem Spec
13 Jan 2009   #6
johngalt

 

IE 8 is still in a beta phase through out the rest of the OSs that it supports, so it is not surprising that some things still don't work.
My System SpecsSystem Spec
26 Jan 2009   #7
rvonder

Windows 7 Build 7000; Vista Ultimate
 
 

I am having exactly the same problem with FTP. I don't think it has anything to do with IE 8, because I'm connecting to my Linux website host via a mapped network location in Windows Explorer. This always worked perfectly in Vista on this same machine - in fact, I did an upgrade-in-place from Vista to Win 7 so I'm even using the same pre-existing mapped location.

I now get this popup error dialog from Win Explorer when I try to open the FTP location:

"An error occurred opening that folder on the FTP Server. Make sure you have permission to access that folder.
Details: The handle is invalid."

For what it's worth, I receive exactly the same popup error if I try to access the FTP URL via Internet Explorer. I am not running any antivirus; and turning off the Windows Firewall also makes no difference.

Rob
My System SpecsSystem Spec
27 Jan 2009   #8
taniwha

Windows 7
 
 
Did work now not

Im not sure why this happened but FTP was working in Windows 7. lastnight my lady accidently unplugged the router. W7 didnt like that one bit.
I then later tried connecting to my FTP "mapped drive" and got the same error
Still looking into it...
cheers
My System SpecsSystem Spec
30 Jan 2009   #9
Darzil

Windows 7
 
 

What I've found is this.

If I go into IE and go to an ftp site that requires authentication, I get the errror.

If I put ftp://username@ftp.site.com then it prompts for a password and displays correctly.

If I then choose to open it in Windows Explorer I get the error again.

On Windows Vista, it is then in the folder pane, and I can right click it, select Login As, and it'll work. On Windows 7 it doesn't appear in the folder pane. I can get it to appear by using the "Add as network location" wizard, but I get the error even when using Login As.

Hope that helps,
Darzil
My System SpecsSystem Spec
30 Jan 2009   #10
reinisb

Windows 7
 
 
Same problem

Just in case someone at MS is watching. Same problem here with the invalid handle error.

Doesn't work in Windows Explorer, Internet Explorer 8 just tells me to open the ftp in Windows Explorer (which of course doesn't work). Opened ok in Firefox, although I don't think you can upload with FF. Works with SmartFTP.
My System SpecsSystem Spec
Reply

 FTP Problem




Thread Tools




Similar help and support threads
Thread Forum
Intel Rapid Storage Technology problem : Empty port problem
Windows 7 Home Premium, 64 bit Gateway Laptop NV55C (I would upgrade ut currently not working so a major hardware upgrade is gonna have to wait :( I've got the latest SATA AHCI Driver for my system according to Gateway. As for the latest Intel RST software/drivers, I have version 9.6.2.1001 on...
Hardware & Devices
Blurry Text problem, EDID and registry editing problem on an AMD card.
EDIT:I have found a solution, using a DVI to HDMI cable on an amd card will fix this problem, this thread can now die, hopefully someone else will find it if they have this problem. Basically, i know what the problem is, but not how to rectify it. My tv (Sceptre X235BV-FHD, a rebranded sony...
Graphic Cards
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Cute Html problem and Video full screen problem
Hi I recently made a mistake and I did a full HP system restore and lost alot of my programs and have had to reinstall them. Some programs are there still but just seem messed up somewhat, like my Cute Html editor program. Suddenly, where there used to be the tabs you clicked on that would...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:15.
Twitter Facebook Google+