Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't start Peer Name Resolution Protocol

19 Dec 2012   #31

Windows 7 Ultimate x64


1.unshare everything you have shared.

2.delete "idstore.sst" and ""

3.rename "" TO ""

4.disable you network card.

5. restart your PC.

6. try leaving homegroup NOW.

7. DONE........ :)

My System SpecsSystem Spec
27 Feb 2013   #32

error: 0x806320a1

Solution Addition:
IF you are like me and tried manually starting the services as a different account etc, i.e. you probably changed the default settings for the account user info, that was a mistake, you will get this error: 0x806320a1

There is not a lot of information out there for this specifically, but the solution is really simple.

1) Delete idstore.sst

2) You want to go back to each service and change the Log On As options and log on user to "Local Service" (no quotes) and then edit the password so its blank. You will want to do this on ALL 3 services (don't forget to apply before closing). Then you should start them in the order 1,2,3 above. At his point you should be good to go, to run the HomeGroup self-diagnostics and then choose Refresh HomeGroup.
My System SpecsSystem Spec
01 Apr 2013   #33

Win 7 Pro 64 bit SP1
The last one worked for me

I know this is an older forum posting but it worked out well for me. I tried all the fixes suggested here except the deleting or renaming MachineKeys file as I was unsure what that would do and no information was given.

The post preceding mine worked perfectly, I was now able to start all the services and leave the homegroup, for which I don''t have much use for right now.

Thank you all
My System SpecsSystem Spec

08 May 2013   #34

Windows 7 Professional x64

Yes! For all which can not start Peer Name Resolution Protocol - see Eugenecist advice. Check carefully Log On tab. Make sure all 3 services (Peer ...) are set to Local Service. Enter your Log on Windows password and... voilà! You can start services.
(Btw, there is an advice here that these services should run in Local System Account, not as Local Service. I do not know the difference, in case of future problems will investigate more.)
Restart computer. Home group is here and errors in the event log gone away.
But why this happened, as Home Group worked yesterday I do not know also.
My System SpecsSystem Spec
22 Mar 2014   #35

Windows 7 Home Premium x64

I joined this forum just to say thank you!! This helped me as well. I shared it (with a link to here) on techspot, where I had first asked for help.
My System SpecsSystem Spec
05 Apr 2014   #36

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1

I have been frustrated with this error for several days, and have researched many threads in this forum and others. I tried the delete *.sst files and that did not work. I tried resetting the login name and that did not work. Then I found a reference to the page link below -- did it (changing permissions on RSA files) and have been without the error for 8 hours now, instead of getting it every 10 or 15 minutes.

Event ID 102 ? PNRP Protocol

And just to give credit -- this was in a post by Streetwolf
My System SpecsSystem Spec
06 Apr 2014   #37

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1

Quote   Quote: Originally Posted by streetwolf View Post
Event ID 102 — PNRP Protocol

I tried what they outlined (it's for Vista) but to no avail. I have no idea what the connection is between RSA and P2P.
I want to thank you directly for the reference to that article. It led me to the fix for me. What it took was the resetting of permissions on LOCAL USER as was suggested there. I'd tried all of the other things in this thread and other threads without success.

These error messages have now gone away.
My System SpecsSystem Spec
07 Jan 2016   #38

win 7 ultimate x64

Quote   Quote: Originally Posted by streetwolf View Post
researched the problem and found the solution. A file was corrupted and deleting it got the pnrp service running. The file was recreated correctly when the pnrp service started up. Here's the file for future reference:


this worked like a charm.

Thanks thanks thanks:d:d:d:d:d:d:d
My System SpecsSystem Spec
20 Apr 2016   #39

Windows 7 ultra 64 bit

Sorry to necro this post. I have the same problems, but..
I can't find \PeerNetworking\idstore.sst
My files go to Roaming, but that is as far as I can go.
My System SpecsSystem Spec

 Can't start Peer Name Resolution Protocol

Thread Tools

Similar help and support threads
Thread Forum
Either the Peer name Resolution protocol Service(PNRPsvc)....
Hello all, and if can someone please help me, a virus or malware was downloaded into my computer(bunch of Chinese ads), I used malware bytes to cleaned it; however, I went into the registry and deleted some files(thinking that it was virus residue), and to this day I am having some issues with my...
Network & Sharing
Peer to Peer Connection not working Win7 x64 to win vista
Hi, I am trying to connect my win 7 x64 to win vista but it's not working. When I am trying to ping from win vista its showing succesfull but reverse is not. I have tried all options and troubleshooted it but all efforts are in vain. Also troubleshooting does not shows any problem and...
Network & Sharing
Trouble creating a peer to peer network
Hello, I'm trying to link two computers together (both on Windows 7 Pro) in a network for a small business environment. My software program is installed on both computers and I need for it to be able to be used simultaneously on both machines. Setting up a homegroup doesn't seem to allow this...
Network & Sharing
Peer-peer ethernet wire sharing internet wont work
Hey, i have 2 window 7 computers and i wish to share the internet with my other one via an Ethernet wire, ive searched the web and ive found nothing!:cry: ive tryed to get the sharing tab in my local networks properties, but its not nere! see the attachment to get a better idea i would...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App