Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Realtek PCIe GBE doesn't see DHCP server

14 Feb 2016   #1

Win-7 64bit
Realtek PCIe GBE doesn't see DHCP server

This may be more of a symptom so I'll explain what I've done.
This is a new build:
MB GA-F2A88XM-D3H ver 3.1
AMD A10 5800k
Fresh Win-7 install, added SP1.
When I boot and the NIC is set to DHCP it shows a 162.254.x.x address. As I understand it that's a default address if the NIC can't find a DHCP server. It also shows only 100Mb as the speed.
I've disabled both "energy efficient Ethernet" and "green Ethernet" options. No dice
I have a Lynksys E4200 as my wireless router and DHCP server. All the other computers can access, both wired and wireless, no problem.
I've confirmed the cable works, I have made sure I've got the most up-to-date driver. 7.88.617.2014
When I set a static IP, Default GW, and set the DNS to the same as the other computers on my network, sometimes it looks like I can connect, but only till I try with a browser or system update, then the connection fails. Also I noticed I don't see a Connection-specific DNS Suffix. See attached.
I seen a lot of other post about issues with this NIC and have tried most of the other suggestions, Uninstall the driver, reinstall....
Any help would be appreciated.

Attached Images
Realtek PCIe GBE doesn't see DHCP server-net-config-dhcp.png Realtek PCIe GBE doesn't see DHCP server-net-config-manual.png 
My System SpecsSystem Spec
14 Feb 2016   #2

Win-7 64bit

Quick update, I did the following, thank you @Johnathin79. Seems to be working now.

  1. Click Start, [click Run], type regedit, and then press ENTER.
  2. Locate and then click the following registry subkey:
  3. Right-click this subkey, click Export , and then save the selected branch in a file.
  4. Click the Network subkey again, and then delete the Config entry. Do not delete the >Network subkey. The Config entry will be reconstructed when you restart the computer.
  5. Restart the computer. You may have to manually turn off the computer.
  6. The config key is re-created on the next boot up.

I also set the Network Location Awareness to Automatic-Delay. I think this was the key.
The NIC speed even shows 1Gbps.
Thank you
My System SpecsSystem Spec

 Realtek PCIe GBE doesn't see DHCP server

Thread Tools

Similar help and support threads
Thread Forum
Realtek PCIe FE Family Controller
Need to replace Realtek PCIe FE Family Controller on my Compaq CQ5715F with AMD Athlon II. FOXCONN mother board 2 AB7. However, I cannot connect to the internet where can I get a driver for a replacement?
Realtek 1xGigabit LAN Controller vs Realtek PCIe GBE Family Controller
What is the difference between these two -Realtek 1x Gigabit LAN Controller -Realtek PCIe GBE Family Controller asus m5a88v-evo
realtek PCIE card reader
what is Realtek PCIE card reader?
Hardware & Devices
realtek pcie gbe wont install
I have finally got windows 7 install and now i can now it will not install the following drivers realtek pcie gbe family controller wan miniport (ip) wan miniport (ipv6) wan miniport (network Monitor) i have a gigbyte motherboard h67m-ud2h-b3 i have tryed the following downloading...
unable to contact your DHCP server
I just replaced my XP desktop with a W7 laptop. I have had constant network issues. I have a home network with a Linksys WRT54G running DD-WRT. My old XP computer worked fine as do another laptop running XP and three other networked devices: Tivo (wireless), WD TV Live Hub (wireless), WD NAS...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:18.
Twitter Facebook Google+