Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installing .Net 1.1 in Windows 7 Pro fails

04 Sep 2013   #1

Windows 7 Pro 32-bit
Installing .Net 1.1 in Windows 7 Pro fails

To solve various problems for which I sought help earlier (thanks to those who tried) I recently did a clean reinstall of Win 7 Pro + SP1 (and all updates) and, of course, a whole bunch of apps. So far so good, and it did solve a lot of nagging issues of the kind that do build up in Windows over time.

However, an Excel application that uses DDE to access real time data from a remote server needs .Net Framework 1.1 (so says the service provider). The Win 7 reinstall included only .Net 4.0 (not 4.5). So far the .Net 1.1 downloads from Microsoft have failed to install - the setup process goes almost to completion, then says it "ended prematurely" and rolls back. There are no error codes or other indication as to why it failed. Here are the two files that I tried, both with the same result:

dotnetfx.exe NDP1.1sp1-KB867460-X86.exe both from the MS Download Center

How can I install .Net 1.1 and get it working on my machine? Do I need to uninstall 4.0 first, then do 1.1 and then 4.0?

Thanks for any words of wisdom on this matter.

My System SpecsSystem Spec
05 Sep 2013   #2

Win7 Pro 32bit

Windows 7 does not support .NET Framework 1.1.
Microsoft: .NET Framework 1.1 Not Supported on Windows 7
My System SpecsSystem Spec
08 Sep 2013   #3
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

.NET 1.1 should still work on Windows 7 however. Try the steps in this article:

My Thoughts: Installing Dotnet Framework 1.1 on Windows 7 beta edition

A Guy
My System SpecsSystem Spec

27 Sep 2013   #4

Windows 7 Pro 32-bit

A Guy: my apologies for responding so late - I was away for about two weeks.

The procedure you cite shows up on several websites, so it must be valid. I need to get .Net 1.1 back onto my system after doing a clean re-install of Win 7 Pro SP1 (just a few weeks ago - it and all updates went well).

The 1.1 sequence, using new c:\DotNet folder as recommended, seemed to work flawlessly. There were no error, unhandled exceptions, or other failure reports. But .Net 1.1 isn't there! Netfx_Setupverifier.exe doesn't even list it to be verified (2.0, 3.0, 3.5 and 4.0 are listed and verified); and it doesn't show up in Control Panel > Programs and Features where, unlike 2.0 thru 3.5, I would expect it to be separately listed as it was before I reinstalled Win 7. I had also run sfc /scannow, which reported no issues.

What's missing? Is there another service that needs to be running? Is there some other Windows feature that needs to be turned on to let .Net 1.1 fully install? Is there a registry key that I can fix? I should also note that, when running netfix.msi (the final step in the procedure), at the very end the progress bar appeared to run backwards, as though a rollback were taking place. That lasted only a second or two, and there were no messages of any kind.

Can you (or anyone) anyone shed some light on this problem? I know that many people in the past have appealed to this and other forums for help regarding .Net 1.1 on Win 7. I'm also aware that Microsoft no longer supports 1.1 on Win 7. But there must be a way to make it happen.

Thanks in advance for any help and words of wisdom.
My System SpecsSystem Spec
27 Sep 2013   #5
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Sorry, sorting through some PC issues myself at the moment. I'll post to the Gurus and see if I can't get you some more help. A Guy
My System SpecsSystem Spec
28 Sep 2013   #6
Microsoft MVP


Have you run all arounds of Important and Optional Windows Updates, after enabling Automatically deliver drivers via Windows Update (Step 3)?

This should deliver the latest Net Frameworks which are backwards compatible as well as other performance and security updates which may also be needed to give full functionality.

If you're saying however that you have a program that only can use such an old version of Net Framework and isn't backwards compatible with newer ones then the program may need to be installed in Compatibility Mode for XP SP2 or the OS it was written for.
My System SpecsSystem Spec
28 Sep 2013   #7

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Suggest: Method 2: Repair the .NET Framework
Follow these steps if you are running WindowsXP, Windows Vista and Windows 7


PS. ever hear of Exton?
My System SpecsSystem Spec
28 Sep 2013   #8

W7 Pro SP1 64bit

Quote   Quote: Originally Posted by rcdunbar View Post
How can I install .Net 1.1 and get it working on my machine? Do I need to uninstall 4.0 first, then do 1.1 and then 4.0?

Thanks for any words of wisdom on this matter.
You have been given some good tips in the posts above. This post is to address your question about uninstalling 4.0 first. I did not have to do that... but I'm testing in W7 pro 64bit. Maybe W7 pro 32 bit has different issues with this 1.1 install.

There were no problems after the restart - but I don't have a way to test Excel and DDE for you.
My System SpecsSystem Spec
28 Sep 2013   #9

Windows 7 Pro 32-bit

Thanks gregrocker,
According to Windows Update, all available updates have been successfully installed, except for a few minor optionals. I do have my system set for auto-updating. For drivers I also use Raxco Perfect Updater, which says that all drivers are current.

The program that needs .Net 1.1 is Sterling Trader Pro, a commercially available stock market trading application. It's free to download but, as you might expect, you pay to trade. This app provides linkage into Excel via DDE and the included Excel add-in. This is the part that that needs .Net 1.1. I have developed an Excel trading application (with extensive VBA content) that gets a real time market data feed from the Sterling servers via Trader Pro. This Excel app worked fine before I re-installed Win 7 Pro (a necessary last resort due to other accumulated system issues); and it works fine on a partner's PC. So I'm assuming that if I can just get 1.1 back onto my system I'll be back up and trading.

Thanks Slartybart,
I'm studying the instructions in the link you provided; I will try them very soon and let you know the results.

Question: I assume that .Net 1.1, when correctly installed, will show up in Programs and Features as a separate line item, unlike 2.0, 3.0 and 3.5, which are built into 4.0. Is this a correct assumption?

Exton PA is a town approximately 25 miles due west of Philadelphia. Has a lot of office parks. I live just north of Philly.
My System SpecsSystem Spec
28 Sep 2013   #10
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I don't know much about your problem but I do have a couple of thoughts.

1. Check your partners computer and see if it shows Net Framework 1.1 or any other Net Framework that you don't have.

2. Check your partners computer and see if the version of this Sterling Trader Pro program is the same as your version.
My System SpecsSystem Spec

 Installing .Net 1.1 in Windows 7 Pro fails

Thread Tools

Similar help and support threads
Thread Forum
Windows Experience Index fails/winsat formal fails invalid character
So you try to run the 'rate my computer' and it fails showing this error message: You are then advised to run a command prompt (old dos screen) as administrator and key in and run winsat formal. ...
Performance & Maintenance
Installing IE 10 Fails on my Windows 7 64bit machine
I am unable to get upgraded to IE 10 and I ran accross a post via google where you fixed it what appears to be the same for someone else, and I'm hoping for the same. It goes through the installation process, then reads "restarting programs" before getting the installation failed message, the...
Windows Updates & Activation
32 bit prg not installing - PSP setup fails
On WIN7 system. Ini-info is in a flie I stored separate years ago. program Ini file says: Title: Paint Shop Pro Setup - Licensed Version 3.12 16 and 32 bit Setup opens error window, recommends using 32 bit version (which it is) I tried Win XPh modus as offered in Win7. MS simply says it...
Virtually every update fails installing.
Hey everyone, I reinstalled Windows 7 on my computer a week ago when I bought an SSD, and then 8 came out, and I got it for super cheap so I decided to try it out. Well, I'm back to 7. ANYWAY, my issue is that virtually all of my updates are failing. I saw this problem before I "upgraded" to...
Windows Updates & Activation
Programs missing, Windows repair fails, and Windows upgrade fails
Hello and thanks for reading. Let me begin by saying I've been trying to figure this problem out for hours and hours now, and every solution I find that looks promising, just leads me in circles. I'm trying my best to avoid a clean install. The problem started while playing a game, causing a...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:30.
Twitter Facebook Google+