Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with Avira Free Antivirus after update

30 Aug 2017   #1
ThisIsMadness91

Windows 7 Home Premium 64bit (Service Pack 1)
 
 
Problems with Avira Free Antivirus after update

At about 4:45 AM today, my Avira antivirus updated from 15.0.29.32 to 15.0.30.29. I switched my computer off afterwards, then switched it back on at about 6:00 AM. I received a "load main resource failed" message (see first attachment), followed by a "avgnt.exe bad image" message (see second attachment) that repeated itself about fifteen times. When I tried to open Avira antivirus, I received an " avcenter.exe bad image" message (see third attachment).

My first attempt to fix the problem was to uninstall Avira antivirus, restart my computer, then reinstall it. Unfortunately, that didn't help. I tried uninstalling both that and Avira Connect, restarting, then reinstalling both of them. That didn't help either. I decided to try using System Restore to go back to the previous version of both programs, but that only resulted in them getting corrupted, so I undid the restoration and reinstalled them.

Right now, I have Avira Antivirus 15.0.3.29 and Avira Connect (now listed simply as "Avira" in my programs list) 1.2.95.14694 installed. I've looked for download links to the previous versions of both programs, but could only find the latest version. I'm still receiving these message when I start my computer and try to open Avira Antivirus, and I haven't yet found anyone online who's having this problem, so I don't know if the problem is on my end or Avira's. I'll see if Avira Antivirus is able to download and install any update files in six hours like it normally does. I'll also keep checking to see if anyone else has encountered this problem, and perhaps either make a post on Avira's forum or contact Avira themselves later. In the meantime, any help you can provide would be greatly appreciated.

Update
: I tried opening Avira Antivirus once more before switching off my computer, and noticed the the file mention in the "bad image" message was different. It changed again when I tried to open it a second time, then nothing happened. I neglected to take screenshots, but I'll see if I can get them to appear again when I get back.




Attached Images
Problems with Avira Free Antivirus after update-avira1.jpg Problems with Avira Free Antivirus after update-avira2.jpg Problems with Avira Free Antivirus after update-avira3.jpg 
My System SpecsSystem Spec
.
30 Aug 2017   #2
samuria

win 8 32 bit
 
 

It could be you have a virus that's disabling AV so use an online scanner or another product. If it is corrupted the uninstall doesn't full remove it go-to the website they have a tool to remove what's left. I would also check the disk for errors
My System SpecsSystem Spec
30 Aug 2017   #3
ThisIsMadness91

Windows 7 Home Premium 64bit (Service Pack 1)
 
 

Thanks for the reply, and sorry it took a while for me to get back to you. I ran scans with both ESET's online scanner and the free version of Malwarebytes Anti-Malware, but neither of them detected anything. Strangely, the antivirus still check for updates every six hours like it's supposed to, and Avira Connect says that my system is protected. How should I proceed?

Also, I've attached a couple more of the "bad image" messages.


Attached Images
Problems with Avira Free Antivirus after update-avira4.jpg Problems with Avira Free Antivirus after update-avira5.jpg 
My System SpecsSystem Spec
.

30 Aug 2017   #4
samuria

win 8 32 bit
 
 

I would totally remove it and try again Instructions for manual uninstallation
My System SpecsSystem Spec
31 Aug 2017   #5
ThisIsMadness91

Windows 7 Home Premium 64bit (Service Pack 1)
 
 

Thanks for the suggestion. I'll give it a try later today and let you know how it goes.

Update: I carried out the manual uninstallation, then reinstalled both programs. Unfortunately, I'm still having the same problems. What should I try next?

Update 2: I looked at Avira's answers page, and it seems at least two other people are experiencing the same problem as me. While no solutions have been found, at least I'm not alone.
My System SpecsSystem Spec
05 Sep 2017   #6
Kloiner

Windows 7 Professional x64
 
 

Hi,
I also use the Free AV on my Win7 PC. I received version 15.0.30.29 some days ago and had no problems.
If something went wrong I am normally try to find some logfiles and searching for errors.
For Avira I have found the logfiles doing the following. Open Avira Antivirus UI going to Reports on the left side.
There I can see all reports. Double clicking on it opens a new dialog with also a report button. Clicking it the selected report opens in notepad editor.
Check the logfile when you first received Update 30 for error. May be there is an indication available.
My System SpecsSystem Spec
05 Sep 2017   #7
ThisIsMadness91

Windows 7 Home Premium 64bit (Service Pack 1)
 
 

Thanks for the reply. Unfortunately, I can't access the antivirus' UI. All I get are the error messages above.
My System SpecsSystem Spec
05 Sep 2017   #8
Kloiner

Windows 7 Professional x64
 
 

Hm check "C:\ProgramData\Avira\Antivirus\LOGFILES" and the Upd-xxxx-xx-xx-xx-xx-xx.log when you got update 30.
My System SpecsSystem Spec
05 Sep 2017   #9
ThisIsMadness91

Windows 7 Home Premium 64bit (Service Pack 1)
 
 

I found the directory, but since I did a complete manual uninstallation last Thursday, the log files from before then are gone.
My System SpecsSystem Spec
Reply

 Problems with Avira Free Antivirus after update




Thread Tools




Similar help and support threads
Thread Forum
BDOD Error c0000135, after Avira Free Antivirus quarantined a .DLL fil
I was watching some movie on VLC, and in background I had ran Avira scan for Windows installed drive, ie in my case C drive. After a prompt for a Potentially unwanted program msg, it says have to quarantine this .DLL file, so I did without almost reading it's name I know....it's my bad but I...
BSOD Help and Support
Avira free antivirus with Windows 7 firewall
I use a third-party firewall that allows full control. But some of my friends use the firewall built in to Window 7. To each their own. I've taken a look at that firewall, and it's actually fairly flexible. It has quite of bit of incoming traffic blocked by default, but leaves outgoing...
System Security
Avira Antivirus and UAC Prompts
Asking this for a friend: Does anyone here use Avira Antivirus? When you perform a scan using Avira's Windows Explorer shell extension (context menu), do you get a UAC prompt each time?
System Security
Windows 7 Avira Free Antivirus saying System not secure
Hey guys,I'm new here,my sis laptop is giving problem,it's saying that System not secured. Please help me.
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:56.
Twitter Facebook Google+