Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Applying update operation 217 0f 217

16 Sep 2010   #1

Window 7 Ultimate
Applying update operation 217 0f 217

When I shut down last night there were three updates being installed. The second one took over four minutes.

This morning I had :
'Applying update operation 217 0f 217'
My box froze so, after some 15 minutes, I hit the hardware restart. I then had nearly two hours of fun and games. The Windows repair utility gave up and I finally found a restore point which worked. This was the restore point before the Windows updates had been applied so I suspect that, if I shut down now, I may hit the sqame problem. I have manually created a restore point that should take me back to this iteration. Hope so !

'HKEY_LOCAL_MACHINE' doesn't have any 'COMPONENTS' so I've no idea where these updates are being applied

But I don't want to miss out on critical updates so has anyone had this problem and found a way through ?

(My box is running Windows 7 Ultimate 64 bit on an AMD Phenom II X 4 955. I have 6 GB of installed RAM and over 400 GB of free space on my C Drive)



My System SpecsSystem Spec
16 Sep 2010   #2

Windows 7 Professional x64 PL

Quote   Quote: Originally Posted by Radegaonde View Post

'HKEY_LOCAL_MACHINE' doesn't have any 'COMPONENTS' so I've no idea where these updates are being applied...
To COMPONENTS hive only Windows 7 never defaultly load this file to registry (opposite to Vista).OS load this file only if using is Windows Update or "Turn Windows Features On or Off"
Of course don't touch this file.

Install updates one at time (not all at once) to diagnose which one cause your problem...
My System SpecsSystem Spec
16 Sep 2010   #3

Windows 7 Home Premium 64 bit

Hi, we've got exactly the same problem with our W7 64 bit machine...any suggestions would be gratefully received!

Don't these updates get tested? Our home PC set-up is hardly unusual.


My System SpecsSystem Spec

16 Sep 2010   #4

Windows 7 Home Premium 64 bit

I no longer have the problem, Windows 7 is running properly.

I'll tell you what I did.

I used the "switch off with the button on the front" method to shut the PC down. After a few seconds I powered the PC back on and got the "Windows didn't shut down properly" non-Windows message.

I was then given the option to repair potentially damaged files, or 'Start Windows normally'. Knowing that the original poster for this thread had unsuccessfully tried the 'repair files' option for this exact same fault, I tried the 'Start normally' option.

During start up I got the 'Applying update operation 217 of 217 (\Registry\Machine\Components\...)' message again, but only for about two seconds.

Then a Windows screen was displayed with the message "Preparing to configure Windows". This was displayed for a few minutes, with the little full stops moving across to indicate something was going on in the background, then everything started as normal, albeit a little more slowly than usual (just took a little longer following log in for the desktop icons to appear properly).

All seems to be running OK now.

Hope this is useful to someone!!
My System SpecsSystem Spec
21 Sep 2010   #5

Widows 7


Thanks for that lead. I tried your way and it works, or at least it works now.
Did you have any further effects?

My System SpecsSystem Spec
21 Sep 2010   #6

Windows 7 Home Premium 64 bit

Hi nandrews,

Glad it worked for you too.

We haven't seen any further effects, everything has worked normally since!


My System SpecsSystem Spec

 Applying update operation 217 0f 217

Thread Tools

Similar help and support threads
Thread Forum
PC won't start: Error C0000034 applying update operation 44 of...
I had to install a malware remover after catching a trojan, which worked just fine, but when it asked me to restart the computer it will only start in recovery mode and stay stuck on the screen saying "Error C0000034 applying update operation 44 of 62501". If I press F8 when restarting all the...
General Discussion
Applying Update Operation got stuck in windows logo
Downloaded Windows 7 update and installing it in pc shutdown. But it's stuck in a windows logo, saying "applying update operation 909 of 909 (chuchu/chuchu/..)" tried to restart the PC for bunch of times but to no avail. I tried the F8 but I get stuck with the Repair Your Computer cause I don't...
Windows Updates & Activation
stuck on applying update operation
Hi, whenever I try to start windows I get applying update operation 414 of 414 (\Registry\Machine\Compnent\I...) I've tried to repair startup and I get a message similar to this Problem signature Startup repair offline 1 - 6.1.7600.16385 2 - 6.1.7600.16385 3 - unknown 4 - 21200332
General Discussion
Fatal Error C0000034 applying update operation 236 of 93422
Last night I downloaded the upgrades and before I went to sleep I ran the upgrade. This morning I woke up and my upgrade progress had froze (couldn't move mouse even) and I had to go to class. I would leave it run but last time I left my computer on for a while it nearly overheated, so I had to...
Windows Updates & Activation
Applying update operation 217 of 217 stuck
Hi guys, When trying to boot my computer, I keep getting a message "Applying update operation 217 of 217" and it stays stuck on this all day (I've left the computer on for about 10 hours). I've tried turning off the power and rebooting but the same thing happens over and over again. Anyone...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App